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Course Overview

Course Description
The Turning Manufacturing Process course teaches the use of the
Manufacturing application for creating Lathe tool paths.

The course is taught within the context of an NC/CNC programming session
and emphasizes the programming organization and efficiency that the
Manufacturing application provides. The purpose of this class is to teach you
how to use the Turning software as you would in your work environment.

Intended Audience

This course is intended for Manufacturing Engineers, Process planners and
NC/CNC Programmers who use the NX Turning Manufacturing application.

Prerequisites

The required prerequisites for the course are:

• Practical Applications of NX or CAST equivalent

• NX Manufacturing Fundamentals with Basic Design course or the current
CAM Transition course

• Basic understanding of the Master Model concept

A working knowledge of the following:

• The NX software interface

• Part file saving conventions

• Experience as an NC/CNC programmer
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Course Description

Special Considerations

When you select lathe_mill as the Configuration and turning as the CAM
Setup, the system will create the mill_planer and drill templates in your
setup as well as the lathe templates. This course will discuss the lathe
templates and options. Mill Manufacturing is a prerequisite to this class, and
therefore, you should be familiar with planar milling and drilling (as they
pertain to milling) concepts.

The user interface is common to all of Manufacturing. The general use of
the user interface is taught in the Mill Manufacturing Process and CAM
Transition course. The specific differences in Turning are discussed in this
course.

Objectives

After successfully completing this course, you will be able to perform the
following activities:

• Create cross-sectional curves for use in defining part and blank geometry.

• Define part and blank geometry for Turning operations.

• Create facing, centerline drilling, roughing, grooving, finishing, and
threading operations.

• Visually verify the program by displaying 2D and 3D dynamic material
removal.

• Define part geometry for parts mounted at each spindle of a multiple
spindle machine.

• Manage the in-process workpiece as it is passed from one spindle to the
next.

• Create a program that contains milling and turning operations.
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Course Overview

Student Responsibilities

• Be on time

• Participate in class

• Focus on the subject matter

• Listen attentively and take notes

• Enjoy the class

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 11



Class Standards for NX Part Files

Class Standards for NX Part Files
The following standards will be used in this class. Standardization allows
users to work with others parts while being able to predict the organization
of the part file. All work should be performed in accordance with these
standards.

Class Part File Naming

This class utilizes the following filenaming standard:

When you save a part file for your later use. Use your initials (***) to replace
the course name initials. Save these files to your personal directory.

Currently up to 128 characters are valid for file names. A four
character extension (.prt, for example) is automatically added to
define the file type. This means the maximum number of user defined
characters for the file name is actually 124.

Notes provide you with information to help you understand the new
concepts.

The Arrow Symbol (→)

When you see the arrow symbol (→), it means that you choose an option,
then immediately choose another option (stacking the option selections). For
example, Tools →Operation Navigator →Tool Path →Replay means:

• put the cursor on Tools on the main menu bar.

• press mouse button #1 to display the pull-down menu.

• slide the cursor down to Operation Navigator (continuing to press mouse
button # 1).

• slide the cursor down to Tool Path.

• slide the cursor down to Replay.

• release mouse button #1.
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Course Overview

Layers and Categories

The student will notice that there are standard layer assignments as well as
standard category names in each of the part files as follows:

Layers 1-100, Model Geometry (Category: MODEL)

Layers 1-14, Solid Geometry (Category: SOLIDS)

Layers 15-20, Linked Objects (Category: LINKED OBJECTS)

Layers 21-40, Sketch Geometry (Category: SKETCHES)

Layers 41-60, Curve Geometry (Category: CURVES)

Layers 61-80, Reference Geometry (Category: DATUMS)

Layers 81-100, Sheet Bodies (Category: SHEETS)

Layers 101 - 120, Drafting Objects (Category: DRAFT)

Layers 101 - 110, Drawing Borders (Category: FORMATS)

Layers 121 - 130, Mechanism Tools (Category: MECH)

Layers 131 - 150, Finite Element Meshes and Engr. Tools (Category: CAE)

Layers 151 - 180, Manufacturing (Category: MFG)

Layers 181 - 190, Quality Tools (Category: QA)

Colors

The following colors are preset to indicate different object types:

Object Valid Colors
Solid Bodies Green
Sheet Bodies Yellow
Lines and Arc
(non-sketch curves)

Orange

Conics and Splines
(non-sketch curves)

Blue

Sketch Curves Cyan
Reference Curves
(in sketches)

Gray

Datum Features Aquamarine
Points and Coordinate Systems White
System Display Color Red
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Class Standards for NX Part Files

Seed Part

Seed parts are an effective tool for establishing customer defaults or any
settings that are part dependent (saved with the part file). This may include
non-geometric data such as:

• sketch preferences

• commonly used expressions

• layer categories

• user-defined views and layouts

• part attributes, manufacturing attributes

• parent groups (Tools, Geometry, Method and Program)

How to Use This Manual

It is important that you use the Student Manual in the sequence presented
because later lessons assume you have learned concepts and techniques
taught in an earlier lesson. If necessary, you can always refer to any previous
activity where a method or technique was originally taught.

The format of the activities is consistent throughout this manual. Steps are
labeled and specify what will be accomplished at any given point in the
activity. Below each step are action boxes which emphasize the individual
actions that must be taken to accomplish the step. As your knowledge of NX
increases, the action boxes may seem redundant as the step text becomes all
that is needed to accomplish a given task.

Step 1: This is an example of a step.

This is an example of an action box.

The general format for lesson content is:

• Presentation

• Activity

• Project

• Summary

While working through lesson activities, you will experience a higher degree
of comprehension if you read the CUE and Status lines.
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Course Overview

At the start of each class day you will be expected to log onto your terminal
and start NX, being ready to follow the instructor’s curriculum. At the end of
the day’s class you should always quit NX and log off the terminal.

Workbook Overview

The workbook contains a project that requires lathe programming. You will
start with creating geometry, then create tools and parent groups, create
facing operations, create several OD and ID roughing operations and then
finish the part.

It is the intent of this project to allow you to apply the skills taught in this
course. At any point when progress is not being made, ask your instructor
for help.

Classroom System Information

Your instructor will provide you with the following items for working in the
classroom:

Username:
Password:
Work Directory:
Parts Directory:
Instructor:
Date:

Student and Workbook Parts

The parts for this class are stored in the class Parts directory. There are
two sub-directories located in the Parts directory, the Students_parts and
workbook_parts.

The Student_parts sub-directory contains the parts that you will use when
working on activities in the Student Manual.

The workbook_parts sub-directory contains the parts that you will use when
working on the project within the workbook.

System Privileges

You do not have the system privilege to modify any of the part files. If you
attempt to do so, you will get a message saying that the file is Read Only.
However, this does not restrict you from working in these files.

You can use the File →Save As option to save the current part file using
your initials. For example, the part file tmp_any.prt rename would be (your
initials)_any.prt.
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Class Standards for NX Part Files

Saving Assembly Parts

When you save an Assembly part file in the directory provided by your
instructor, you may need to change the Load Option (File → Options→ Load
Options) to As Saved. This will allow you to open your part and the associated
assembly components.

The Parts that are available in the class room have their Load Option (File →
Options → Load Options) set to, From Directory. This limits the search for
associated assembly files to the directory in which the associated assembly
files reside.

The steps necessary are as follows:

Step 1: Change the Part File Load Options.

You are going to change the Part File Load Options from the From Directory
to As Saved.

Choose File→Options→ Load Options.

The Load Options dialog is displayed. You change the Load Options by
specifying the Load Method.

Choose As Saved from the dialog.

The N/C Programming Sequence

The Manufacturing application programming sequence is to:

• Create the Manufacturing Assembly

• Select the proper Manufacturing Configuration

• Establish the Parent Group objects

• Create the operation(s)

• Verify the tool paths created

• Postprocess the tool paths

• Create Shop Documentation
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Course Overview

The flow chart below shows the typical Manufacturing process.

Figure 1. NX Manufacturing Process — Turning
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Terminology

Terminology
The following terms are presented along with a brief definition so that you will
be somewhat familiar with the Turning terms as used in the NX environment.

CAM Files

Template Part File - any part file that contains CAM information such as,
tools, methods and operations that can be retrieved through the template
mechanism into another part file.

Operation/Tool Path

Blank is the uncut material.

In Process Workpiece - is the geometry that represents the shape of the work
piece at each stage of cutting during the machining process.

Level Angle - defines the direction of cut relative to the WCS.

Cut Type or Cut Method - predefined machining methods such as level zigzag,
contour rough zig or plunge.

Stepover - the distance the tool travels between passes.

Material Side - is the side of the part geometry that is not to be cut.

Radial Move - is motion defined perpendicular to the centerline.

Radial Clearance - is a line or level defined parallel to the centerline.

Axial Move - is motion defined parallel to the center line axis.

Axial Clearance - is a line or level defined perpendicular to the centerline.

Auto Detection - identifies regions to be cut based on part geometry,
In-process Workpiece, cut parameters, and tool shape.

Containment - are radial and axial positions that limit the area to be cut.

Teach Mode - is a cut type that enables you to define the motions of the
operation step by step. This is comparable to manual programming.

Cleanup - creates an additional pass to clear excess material left after the
rough cuts.
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Course Overview

Geometry

Reversal- Any geometry that turns away from the cut motion. The tool will
create a ramping motion into the material to cut the reversal.

Undercut- The tool motion will determine whether the geometry is a reversal
(which may be cut) or an undercut (which is not cut).
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1
Lesson

1 Defining Part and Blank
Geometry

Purpose

This lesson covers how to define the machine coordinate system (MCS), create
blank and part boundaries, and define cut region containment.

Objective

Upon completion of this lesson, you will be able to:

• Create Part and Blank boundaries by selecting their solid bodies.

• Edit the MCS_SPINDLE group.

• Create Blank boundaries as bar stock or tube stock.

• Define cut region containment within a Containment group and within
an operation.
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Defining Part and Blank Geometry

Part & Blank Boundaries
Part and Blank boundaries are required to generate a tool path. To create
Part and Blank boundaries, begin by selecting the solid bodies (1) that contain
the part and blank. Cross-sectional curves (2) representing a 2D cross section
of a solid body are created automatically. These curves serve as a reference
for tool paths and containment as you create operations. You can then display
the boundaries (3) needed for generating a tool path.
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Defining Part and Blank Geometry

Activity: Creating and Viewing Part & Blank Boundaries

In this activity, you will select the solid bodies that define the part and blank
geometry. You will then view the cross sectional curves and display the part
and blank boundaries in the TURN_WORKPIECE object.

Step 1: Open and rename the part.

Open the tmp_cross_sec_mfg part.

Save the part as ***_cross_sec_mfg, where *** represents
your initials.

Choose Start→Manufacturing.

Step 2: Specify Part and Blank geometry within the WORKPIECE group.

You will specify the Part and Blank geometry within WORKPIECE
by selecting the solid bodies of the Part and Blank.

Display the Geometry View of the Operation Navigator and
expand all objects.

Double-click WORKPIECE.

In the Workpiece dialog, choose the Part icon and Select.

In the Part Geometry dialog, make sure Selection Options are
set to Geometry and Filter Methods are set to Solid Bodies.
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Defining Part and Blank Geometry

Select the solid body of the Part as illustrated below.

OK to accept the Part Geometry.

Choose the Blank icon and Select.

Select the stock surrounding the part as illustrated below.

OK to accept the Blank Geometry.

You have now defined the Part and Blank Geometry and the
associated cross sectional curves.

Step 3: Display cross sectional curves in the TURN_WORKPIECE group.

You will display the cross sectional curves in the
TURN_WORKPIECE group by hiding the layers containing the
solids.

Choose Format→Layer Settings.

Double-click layers 1 and 2 to hide the solid bodies they contain.
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Defining Part and Blank Geometry

OK the dialog.

The solids will disappear from the screen, leaving only the
coordinate systems.

In the Operation Navigator, double-click TURN_WORKPIECE.

The 2D cross section appears shaded in isometric view.

MB3→Rendering Style→Static Wireframe to change the
display to remove the shading.

MB3→Orient View→Top to change to a TOP view.

Here you see the cross sectional curves used to define the part and
blank boundary. You will reference these curves when creating
boundaries required by operations.

In the TURN_BND dialog, select the Part icon and click Display.

Select the Blank icon and click Display.
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Defining Part and Blank Geometry

The Part (1) and Blank (2) boundaries are displayed on the cross
sectional curves you created. These boundaries help define the
tool path for operations.

Save and close the part.
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Defining Part and Blank Geometry

The Create Geometry Dialog
The Create Geometry dialog allows you to define MCS_SPINDLE
(1), WORKPIECE (2), TURN_WORKPIECE (3), TURN_PART (4),
CONTAINMENT groups (5), and AVOIDANCE (6).

MCS Spindle

MCS SPINDLE allows you to create, edit, and store Machine Coordinate
Systems, used for defining spindles.

The Lathe Work Plane options allow you to directly specify XM-YM or ZM-XM
as the desired lathe work plane. If the XC-YC plane is parallel to the XM-YM
or ZM-XM work plane, the system defaults to the XM-YM or ZM-XM work
plane respectively.

If the XC-YC plane of the WCS is not parallel to the XM-YM or ZM-XM lathe
work plane as illustrated below, you can directly specify XM-YM or ZM-XM as
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Defining Part and Blank Geometry

the desired lathe work plane. In the following figure, choosing "use ZM-XM",
specifies ZM-XM as the lathe work plane regardless of the orientation of the
WCS. This is the plane in which cross section curves and tool paths will be
created.

The Save Layout/Layer button allows you to save the current Layout and
associate it with the defined MCS. This is useful if you rotated or oriented
your part in any other view. You can then retrieve this view using the Switch
Layer/Layout option on the MB3 menu. This option is available on all of the
other Geometry dialogues.

Workpiece

WORKPIECE allows you to define the part and blank geometry by selecting
their solid bodies.

In a new CAM Setup, the MCS SPINDLE, WORKPIECE, and
TURN_WORKPIECE are created for you automatically. The initial
WORKPIECE contains no part or blank data, but it can be edited to include
this data.

If you define the part material from this dialog, that definition will override
any definition made using the menu bar (Tools→Part Material).
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Defining Part and Blank Geometry

Turn_Workpiece

TURN_WORKPIECE contains the cross-sectional curves and boundaries
derived from part and blank geometry defined in the WORKPIECE. It also
allows you to define part boundaries from faces, curves, points and blank
boundary geometry from bar stock, tube stock, curves or the in-process
workpiece.

Blank geometry can be defined in the TURN_WORKPIECE or in the
following ways.

1. Bar Stock (mount position and blank parameters)

2. Tube Stock (mount position and blank parameters)

3. From Curve (existing geometry created by lathe cross section)

4. From Workspace (references in-process workpiece)

Turn_Part

When contained within TURN_WORKPIECE parent groups, PART parent
groups help you to organize your geometry. The first geometry parent
group defined is the MCS_SPINDLE. Within the MCS is the WORKPIECE
parent group which contains the solid bodies that define the part and blank
geometry. Within the WORKPIECE parent group is the TURN_WORKPIECE
parent group which contain the part and blank boundaries. Within the
TURN_WORKPIECE parent are the PART groups that define various Part
boundaries.
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Defining Part and Blank Geometry

Naming or renaming the Geometry Parent Groups with meaningful
names can alleviate a great deal of confusion when creating programs.
Example:

• TURN_WORKPIECE Parent Group.......Contains only Blank geometry

• PART_OD Parent Group......Contains only the OD geometry

• PART_ID Parent Group......Contains only the ID geometry

Containment

CONTAINMENT restricts the cut region by allowing you to position axial and
radial trim planes and trim points. Trim points allow you to constrain the cut
region in addition to the limits imposed by axial and radial trim planes. They
allow you to be very specific about the areas you wish to cut.

An axial containment plane (1) can avoid collisions with the chuck. A radial
containment plane (2) can avoid cutting to the center line.

Avoidance

AVOIDANCE allows you to specify positions and movements for the tool as it
moves toward or away from the part. You may define avoidance as a geometry
group when several operations will use the same avoidance parameters.
Otherwise, define avoidance within individual operations when they require
unique avoidance parameters.
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Defining Part and Blank Geometry

Activity: Defining Geometry Groups

In this activity, you will edit an existing MCS_SPINDLE group, define blank
geometry within the TURN_WORKPIECE, and create a Containment group
defining axial and radial trim planes.

Step 1: Open and rename the part.

Open the tmp_geom_mfg_1 part.

Save the part as ***_geom_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Display the Geometry View of the Operation Navigator and
expand the MCS_SPINDLE object.
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Defining Part and Blank Geometry

Step 2: Examine the MCS_SPINDLE parent group.

Double-click MCS_SPINDLE to display the coordinates.

It is a good practice to check the MCS position and orientation
each time you start a session or continue someone else’s work.

OK to accept the MCS.

Step 3: Define blank geometry from bar stock.

You will redefine the blank geometry by keying in bar stock
dimensions.

Double-click TURN_WORKPIECE to edit the group.

1-12 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



1

Defining Part and Blank Geometry

Choose the Blank icon and Select.

Choose the Bar Stock icon.

Key in 3.25 in the Length field and 5.50 in the Diameter field.

The mounting position associates the blank geometry with the
part geometry via a smart point. As a result, moving the part
geometry also moves the blank geometry.

Choose Select under Mounting Position.
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Defining Part and Blank Geometry

Select the end point of the horizontal line.

Internally, the Mount Point is projected to the centerline for
blank placement.

The Point Location options orient the blank geometry in
relation to the mounting position you just defined.

Be sure At Headstock is chosen for the point location.
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Defining Part and Blank Geometry

Choose Display Blank.

OK to accept the blank geometry.

OK to complete the Workpiece.

Step 4: Create a containment group.

Cut region containment restricts the cut region by allowing
you to position axial (1) and radial (2) trim planes. Cut region
containment is sometimes necessary to avoid colliding with the
chuck or cutting too close to the center line. Containment can be
defined within the Workpiece parent group or within individual
operations.

Choose the Create Geometry icon.
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Defining Part and Blank Geometry

Choose the Containment icon.

Be sure the Parent Group option is set to TURN_WORKPIECE.

OK to begin creating the Containment group.

You will define containment geometry by positioning axial and
radial trim planes.

Turn the Trim options on next to the Radial 1 and Axial 1
buttons.

At 0.0000, Radial 1 initially lies on the XM axis and Axial 1
lies on the YM axis. You can reposition these trim planes by
selecting points or by keying in values.

Key in 0.25 in the Axial 1 field.

This will prevent the tool from colliding with the chuck.

Choose Radial 1.
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Defining Part and Blank Geometry

Select the end point of the horizontal line as illustrated below.

Choose Display Containment to display both trim planes.

The cut region is limited to the area above the radial trim plane
and to the right of the axial trim plane.

OK to accept the containment.

This completes the containment group. The Geometry
view of the Operation Navigator now displays four groups:
MCS_SPINDLE, WORKPIECE, TURN_WORKPIECE, and
CONTAINMENT. By defining the containment geometry
within a group, this geometry is defined only once and can be
used selectively when creating operations.

Save and close the part.
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Defining Part and Blank Geometry

Activity: Defining Cut Region Containment within an Operation

In this activity, you will define cut region containment within an operation.
This method is preferred over defining cut region containment within a group
because some tool path creation requires unique containment settings.

Step 1: Open and rename the part.

Open the tmp_geom_mfg_2 part.

Save the part as ***_geom_mfg_2, where *** represents your
initials.

Choose Start→Manufacturing.

Display the Program Order View of the Operation Navigator.

Step 2: Generate the tool paths.

In the Operation Navigator, highlight the PROGRAM object
and MB3→Generate.

OK as needed to generated all of the tool paths.
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Defining Part and Blank Geometry

Replay the ROUGH_TURN_OD operation.

The tool cuts to the end of the blank where it will collide with
the chuck.

You will define an axial trim plane for this operation to prevent
the tool from colliding with the chuck.

Step 3: Define an axial trim plane.

In the Operation Navigator, double-click ROUGH_TURN_OD to
edit the operation.

Choose Containment.

Turn the Trim option on next to the Axial 1 button.

You can reposition the Axial 1 trim plane by selecting points
or by keying in values.

Key in 0.25 in the Axial 1 field.
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Defining Part and Blank Geometry

OK the Geometry Containment dialog.

Step 4: Generate the tool path.

Generate the tool path for the ROUGH_TURN_OD operation.

The tool path remains to the right of the axial trim plane.

OK to complete the operation.

Leave this part open. You will continue to use it in the next
activity.
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Defining Part and Blank Geometry

Activity: Defining Blank Geometry as Tube Stock

In this activity, you will redefine the blank geometry as tube stock. You will
continue to use the part file tmp_geom_mfg_2.

Step 1: Display the Geometry View.

Display the Geometry View of the Operation Navigator and
expand the objects.

Step 2: Define blank geometry as tube stock.

In the Operation Navigator, double-click TUBESTOCK to edit
the object.

Choose Blank and Reselect.

OK the warning.

Choose Tube Stock.

Key in the following values in the Length, Outer Diameter, and
Inner Diameter fields.

• Length: 14.000

• Outer Diameter: 17.000

• Inner Diameter: 4.000
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Defining Part and Blank Geometry

Step 3: Define the mounting position.

Choose Select under Mounting Position.

Select the end point of the horizontal line as illustrated below.

Choose Display Blank.

OK to accept the blank geometry.

OK to complete the tube stock.

Step 4: Generate the tool paths.

Display the Program Order View of the Operation Navigator.
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In the Operation Navigator, highlight the PROGRAM object
and MB3→Generate.

OK as needed to generate all the tool paths.

Save and close the part.
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Summary
Turning geometry consists of spindle definition, part geometry, blank
geometry, and cut region containment. Part and blank geometry are defined
using boundaries. Blank boundaries can be defined as bar stock, tube stock,
or by selecting the solid body that contains the blank. Part boundaries are
most easily defined by selecting the solid body that contains the part. Cut
region containment can be defined within a parent group or within individual
operations. Defining cut region containment within individual operations is
preferred because tool paths sometimes require unique containment settings.
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Lesson

2 Retrieving and Creating Tools

Purpose

This lesson covers tool creation and retrieval.

Objective

Upon completion of this lesson, you will be able to:

• Retrieve tools from the library.

• Create new tools.

• Manage tools for a two turret program.
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Retrieving and Creating Tools

The Create Tool Dialog
The types of tools you can create are determined by the Machining
Environment Setup. When the Type option is set to Turning, you can only
create turning tools.

Operations must use tools of the appropriate type. Turning operations can
only use turning tools. Milling operations can only use milling tools.

New tools can be created (1) or predefined tools can be retrieved from the
library (2). When defining multi-turret operations tools can be assigned to
pockets (3) (also called faces) within carriers (4).

Determining the tool number by the pocket in which the tool is placed is
analogous to a machine operator picking up a tool and putting it into a pocket
on the machine.
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Retrieving and Creating Tools

Activity: Retrieving Tools from the Library

Step 1: Open and rename the part.

Open the tmp_tools_mfg_1 part.

Save the part as ***_tools_mfg_1.

Choose Start→Manufacturing.

Step 2: Enter the search criteria.

Display the Machine Tool View of the Operation Navigator.

Choose the Create Tool icon.

Be sure the Type option is set to turning.

Choose the Retrieve Tool icon.

Choose Apply.
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Retrieving and Creating Tools

Expand Turning and choose OD Turning in the Library Class
Selection dialog.

Choose OK.

The Search Criteria dialog is displayed.

Key in 80 in the Nose Angle field.

Choose the Count Matches button.

Three matches are found.
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Step 3: Retrieve and display the tools.

Choose OK.

The Search Result window is displayed.

Choose the tool ugti0101_012 in the list and then choose
Display.

The tool displays at the WCS.

Choose the tool ugti0101_011 in the list, and Display.

This displays a tool assembly.
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Change to a shaded view to see the assembly clearly.

Choose OK in the Search Result dialog.

OK the warning.

The tool is retrieved into the part and displayed in the
Operation Navigator.

Save the part.

Leave this part open. You will continue using it in the next
activity.

Tools retrieved from the library have predefined tool
numbers and cannot be put into faces.
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Creating New Turning Tools
You can create new tools using the tool templates or Subtypes.

Common Parameters

The tool tab displays options that allow you to define common parameters
for the specified subtype such as the size, shape, and orientation of the
cutter (1). Insert Position (2) defines whether the cutter is mounted to the
topside or the underside of the holder. The system determines a clockwise or
counterclockwise rotation of the spindle based on the specified Insert Position
and the location of the cut region above or below the centerline.
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Tool Tracking

The Tracking tab displays options that define a tracking points at the tips
of the cutter. Internally, the system calculates tool path output based on
these points.

• The Radius ID selects which corner is the active corner.

• The Tracking Point ’P’ Number selects one of nine available points around
the active corner as the tracking point. You may define a tracking point
for each available corner of the cutting insert.

• The Tool Angle tracks the tool path from operation generation at the
center of the tool nose radius, but makes the parameter value of the tool
angle available to the post processor. This is only available when P9 is
selected as the ’P’ Number.

• The Radius tracks the tool path from operation generation at the center
of the tool nose radius This is only available when P9 is selected as the
’P’ Number.

• The x offset (XOFF) is the distance between the tool’s reference point and
its tracking point measured along the spindle axis.

• The y offset (YOFF) is the distance between the tool’s reference point and
its tracking point measured normal to the spindle axis.

• The ADJUST Register provides the location of the tool offset coordinates
in the controller memory. The CUTCOM Reg adjusts the cutter path to
allow for variation in the cutter size.
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Activity: Creating New Tools

For this activity, you will continue using ***_tools_mfg_1.

Step 1: Define a button tool.

Display the Machine Tool View of the Operation Navigator.

Choose the Create Tool icon.

Choose the OD_80_L subtype icon.

Set the Parent Group option to Face1.

Key in button_.250 in the Name field.

Choose Apply at the bottom of the Create Tool dialog.

Step 2: Change the insert type and enter the tool dimension.

To create a button tool, you must change the insert type.

Set the ISO Insert Shape option to R (Round).

OK the warning.

Key in the following tool parameters.

Diameter: .250

Orient Angle: 90

Holder Control Width: .1625

Holder Control Angle: 0

The tool, button_.250, has inherited the tool number
from Face 1.
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Choose Display Tool.

Step 3: Examine the Tool Tracking Options.

Choose the Tracking tab.

This tool will track from the center point of the insert.

Choose the Tracking Point arrow and examine the choices.
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Step 4: Define the tool material.

Choose the Tool tab.

Choose the Material button.

Highlight Carbide Coated and choose OK.

OK the Turning Tool-Standard dialog to complete the tool
definition.

Step 5: Define a diamond tool.

Choose the OD_55_L subtype icon.

Set the Parent Group option to Face2.

Choose Apply at the bottom of the Create Tool dialog.
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Step 6: Change the insert size.

The Inscr. Circle (I.C.) option allows you to key in the diameter of
the inscribed circle (1). The Cut Edge Length option allows you to
key in the length of the cutting edge (2).

The I.C. ANSI option allows you to key in an ANSI code (a positive
integer denoting eighths of an inch).

Set the Size option to Inscr. Circle (I.C.).

Key in 0.2500 for the diameter of the inscribed circle.

Choose Display Tool.

OK the Turning Tool-Standard dialog to complete the tool
definition.
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Step 7: Create an ID cutting tool unassisted.

Create a Standard ID_55_L turning tool with the following
dimensions.

• Nose Radius: .0625

• Inscribed circle: .50

• Tool Material: TMC0_00004 Carbide , Coated (Indexable)

The Cut Edge Length defines the insert size.

The tools are displayed in the Operation Navigator in the
Tool View.

• Save and close the part.
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Managing Tool Changes
Turrets and faces can be defined in the Operation Navigator, allowing you to
interactively manage tool changes for multiple turret programs.

Tool numbers are assigned to faces and are inherited by tools and operations.
Inheritance can be overridden by defining the tool number within the
operation. Depending on your work environment, you will need to determine
whether it is appropriate to define the tool number at the face level or at the
tool level. Regardless of where you define the tool number, the system always
displays the output tool number within the operation and in the Tool Number
column of the Operation Navigator.
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Retrieving and Creating Tools

Activity: Defining a Single Spindle, Two Turret Program

In this activity you will use the Operation Navigator to define a two turret
program. You will create turrets and faces and assign a tool to each face.

Step 1: Open and rename the part.

Open the tmp_tools_mfg_2 part.

Save the part as ***_tools_mfg_2.

Choose Start→Manufacturing.

Step 2: Define the upper and lower turrets.

You will define upper and lower turrets and add numbered faces
to each. You will see how these faces define the tool numbers
inherited by the operations.

Display the Machine Tool View of the Operation Navigator.

Choose the Create Tool icon.

Be sure the Type option is set to turning.

Choose the Carrier icon.

Set the Parent Group option to Generic Machine.

Key in UPPER in the Name field.
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OK to define the upper turret.

OK to complete the turret definition.

Repeat these steps to define a LOWER turret.

Step 3: Add faces to turrets.

You will add numbered faces to each turret. This is the most
common method of determining the tool number on the machine
tool. These turret numbers will be inherited by the tools and
operations as tool numbers and output to the postprocessor.

Choose the Create Tool icon.

Choose the MCT_POCKET icon.

Set the Parent Group option to UPPER.

Key in FACE_1 in the Name field.

Apply to begin defining the face.

Key in 1 in the Pocket ID field and OK the pocket dialog.

This is the number that will be assigned to the tool.
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Key in FACE_2 in the Name field and repeat the process until
FACE_1 through face_6 have been defined in the UPPER
turret as illustrated below.

Create faces 7–10 in the LOWER turret as illustrated below.

Cancel the Create Tool dialog.

Step 4: Place tools into faces.

You will drag and drop tools into the faces you just defined. In
doing so, the tools inherit the face numbers and the operations are
divided between the upper and lower turrets. Determining the
tool number by the face in which the tool is placed is analogous to
a machine operator picking up a tool and putting it into a pocket
on the machine.

In the Operation Navigator, display the Tool Number column
next to the Name column as illustrated below. This will allow
you to see the tool numbers as the tools inherit them.
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Drag and drop each tool into each face as illustrated below.

Save and close the part.
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Retrieving and Creating Tools

Summary
Tools can be created or retrieved from libraries. Turrets and faces can be
defined in the Operation Navigator, allowing you to interactively manage tool
changes for multiple turret programs.
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Lesson

3 Facing Operations

Purpose

This lesson teaches you how to create a Facing operation. Facing the end of
the part is one of the first operations you will perform in a typical turning
program.

Objective

Upon completion of this lesson, you will be able to:

• Face the end of a part.

• Display the cut region.

• Limit the cut region using an axial trim plane.

• Specify face stock.

• Generate the tool path and visualize the in-process workpiece.
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Facing Operations
Facing operations remove material from faces by roughing normal to the
centerline. Many of the parameters found in Facing are common to other
roughing operations.

Defining Faces

The system defines faces based on parameters specified in the Contour Types
dialog.
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When the parameters are specified as shown above, any line or curve with
a slope between 3 and 357 degrees (1) is recognized as a diameter, to which
Radial stock is applied. Any line or curve with a slope between 87 and 93
degrees (2) is recognized as a face, to which Face stock is applied.

The In-Process Workpiece

The in-process workpiece is the remaining material at each stage of the
cutting process. The system tracks and graphically displays the in-process
workpiece as the program progresses. Each subsequent operation uses the
in-process workpiece as it progresses from operation to the next.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 3-3



3

Facing Operations

Cut Regions and Automatic Cut Region Detection

Roughing (and Finishing) operations use automatic cut region detection. The
system detects the remaining material between the In-process Workpiece and
the part surface and then uses the cut region for the subsequent operation.

The material that can be removed by a single operation depends on the:

• shape of the In-Process Workpiece.

• part boundary.

• blank boundary.

• tool shape.

Autodetection Control

Autodetection Control is used to change and adjust auto-detected cut regions.

The Minimum Area (1) can be used to eliminate small cut regions whose area
is less than the minimum area value. This option prevents the generation of
unwanted cut motion for small cut regions. The area is measured in square
inches/millimeters. If you are having a problem detecting a small amount of
material, you can reduce the minimum area.

The Start/End Offset (2) and Start/End Angle (3) options apply only in the
case of open boundaries, and only if a containment has not been set.
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Activity: Creating a Facing Operation

In this activity, you will create an operation to cut the face of the part. You
will generate the tool path using only the default settings. You will then
reject the operation and set some of the options available on the Facing dialog.

Step 1: Open and rename the part.

Open the tmp_face_mfg_1 part.

Save the part as ***_face_mfg_1, where *** represents you
initials.

Choose Start→Manufacturing.

Display the Geometry view of the Operation Navigator and
expand the objects.

Step 2: Begin the Facing operation.

Choose the Create Operation icon.

Set the Type option to turning.
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Choose the Facing icon.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........OD_80_L

• Use Method......LATHE_ROUGH

Choose OK.

Step 3: Display the cut region.

By defining the part and blank geometry in parent groups, the
system can track the material that needs to be removed. The
blank geometry is defined in the BARSTOCK object and the part
geometry is defined in the PART object.

Choose Display.

The cut region (1) is displayed.
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Step 4: Limit the area the tool will cut.

You will face the end of the part. The cut region indicates that the
entire OD is going to be cut in this operation. You will use a trim
plane to contain the cut region.

Choose Containment under Cut Regions.

Turn the Trim option on next to the Axial 1 button.

Choose the Axial 1 button.

Select the inferred point on the vertical line as illustrated
below.

A point labeled Axial 1 displays on the face of the part and a
dashed line indicates the trim plane.

OK to complete the geometry containment.
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Step 5: Display the cut region.

In the Cut Regions area, choose Display.

The cut region (1) is contained to the right of the trim plane.

Step 6: Observe the face stock.

Choose Stock.

The Face Rough Stock is currently set to 0.0200.
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This is the amount of material that will be left on the face.

Cancel the stock dialog.

Step 7: Define Start and Return points.

Start and Return points allow the tool to move away from or
toward the part between operations. These and other avoidance
parameters will be discussed in more detail in the Common
Options lesson.

Choose Avoidance.
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Turn the Motion to Start Point and Motion to Return Point
options on.

Motion Type determines how the tool will move between the
avoidance points and the part. You will leave both of these
options set to Direct. This will allow the tool to take a direct
(shortest) path.

Under Motion to Start Point, choose Select.

Indicate a point at the approximate screen position illustrated
below.

This position defines the Start Point and is labeled ST.

Under Motion to Return Point, choose Select.
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Indicate a second point near the first.

This position is labeled RT.

Change the Motion Type to Direct.

OK to complete the avoidance parameters.

Step 8: Generate the tool path.

Choose the Generate icon at the bottom of the dialog.

The tool cuts the face of the part leaving behind the specified
face stock.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.
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Choose Play at the bottom of the dialog.

OK to complete the visualization.

OK to complete the operation.

Save and close the part.
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Summary
Facing removes material by roughing normal to the centerline. The system
defines faces based on parameters specified in the Contour Types dialog.
Axial cut region containment allows you to restrict the region to be faced
while Face Rough Stock defines the amount of material that will be left on
the faces. Once generated, the tool path and the in-process workpiece can be
displayed using 2D Material Removal.
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Lesson

4 Verification

Purpose

You will use the Verify Tool Path function to visually validate single and
multiple tool paths.

Objective

Upon completion of this lesson, you will be able to:

• Display the in-process workpiece as a 2D or 3D static image.

• Display dynamic material removal in both 2D and 3D.

• Display dynamic material removal for a single operation as well as for a
sequence of operations.

• Edit display parameters for the tool and the in-process workpiece.
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Displaying Cut Motion and Dynamic Material Removal
The Verify Tool Path function allows you to display dynamic material removal
for a single operation or a sequence of operations and visually examine the
tool movement in both 2D and 3D.

You can control the animation speed of the tool movement, the tool display,
and verify that the tool is cutting the correct portions of the material. It is
important, for example, to determine if the tool is gouging the part. You can
display the tool, the part, and the in-process workpiece in a variety of ways
in both 2D and 3D. Verify Tool Path can also report unacceptable conditions
such as collisions.
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Displaying the In-Process Workpiece Using Show 2D / 3D
You can display the in-process workpiece as a static image by highlighting the
operation in the Operation Navigator and choosing MB3→Workpiece→Show
2D (1), Show filled 2D (2), or Show 3D (3). Since the sequence of operations is
important, it is best to select the operation in the Program Order View of the
Operation Navigator. If operations are reordered, the system recalculates the
in-process workpiece.
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Activity: Verification Using Show 2D and 3D Options

Step 1: Open the part.

Open the tmp_verify_mfg_1 part.

Choose Start→Manufacturing.

Step 2: Display the in-process workpiece in 2D.

Display the Program Order View of the Operation Navigator
and expand the objects.
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Highlight ROUGH_TURN_OD and MB3→ Workpiece→Show
filled 2D .

The shaded area (1) represents the in-process workpiece. The
outlined area (2) represents the cut region.

Refresh the graphics display.

Step 3: Display the in-process workpiece in 3D.

Change to a Trimetric view.
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Highlight ROUGH_BORE_ID and MB3→ Workpiece→Show
Spinning 3D.

The in-process workpiece is displayed in 3D.

Choose the Shaded icon.

Step 4: Compare the finished part to the in-process workpiece.

You will begin by displaying the finished part.

Choose Format→Layer Settings.

Double-click on layer 110.
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Choose OK.

The in-process workpiece (1) is superimposed on the finished
part (2).

Refresh the graphics window.

Leave this part open. You will continue using it in the next
activity.
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Activity: Verification Using Tool Path Visualization

Step 1: Visualize 2D material removal for a single operation.

Rotate the part to the approximate viewing angle
illustrated below.

In the Operation Navigator, highlight ROUGH_TURN_OD.

MB3→ Tool Path→ Verify or choose the Verify Tool Path icon.

Make sure the Replay tab is active.

Turn the 2D Material Removal option on. This will display the
blank material in a 2D plane (1).
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At the bottom of the dialog, set the Animation Speed to 7.

Choose Play.

Change to a Top view.

Choose Rewind to Previous Operation.

Turn the 2D Material Removal option off and then on again.
This will redisplay the blank material.

Choose Play.

Choose Reverse Play.

Choose OK.
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Step 2: Visualize 3D material removal for a single operation.

Once again, rotate the part to the approximate viewing angle
illustrated below.

Choose the 3D Dynamic tab.

Choose Play.

Choose Reset.

Choose Display Options.

Set the IPW Color option to some other color that will contrast
the part color.

Set the IPW Translucency option to about 50.

This will allow you to see the part through the in-process
workpiece.
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OK the 3D Dynamic Options dialog.

Choose Play.

Step 3: Visualize 3D material removal for a sequence of operations.

In the Operation Navigator, highlight the operations FACING
through ROUGH_BORE_ID.

Set the Animation Speed to 2.
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Choose Play.

The tool paths are replayed in their entirety in sequence.

Step 4: Visualize 2D material removal for a sequence of operations.

Choose Reset.

Change to a Top view.

Choose the Replay tab.

Turn the 2D Material Removal option on.

Choose Play.

OK the Tool Path Visualization dialog.

Do not save the part.

Save and close the part.
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Summary
The Verify Tool Path function allows you to display dynamic material removal
for a single operation or a sequence of operations and visually examine
the tool movement in both 2D and 3D. You can also display the in-process
workpiece of any operation as a static image in both 2D and 3D.
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Lesson

5 Common Options

Purpose

The purpose of this lesson is to introduce you to many of the common
parameters you will use in creating tool paths. These parameters, which
include stock, feeds and speeds, avoidance moves, engage and retracts, and
feed rate control, are common to all or most turning operations.

Objective

Upon completion of this lesson, you will be able to:

• Define From, Return, and Start points.

• Define rough stock.

• Define grind stock.

• Define Engages and Retracts.

• Define feed rates.
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Common Options in Turning

Option Rough Finish Thread Drill Teach
Mode

Level Angle X
Reversal Mode X X
Containment X X
Autodetection X X

Engage/Retract X X X X
Cutting X X X
Corner X X X

Feed Rates X X X X X
Profile X X
Stock X X X

Machine X X X X
Avoidance X X X X

Local Return X X
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Stock
The Stock function allows you to leave material on the part. Rough Stock
(1) leaves material after roughing. Profile Stock (2) leaves material after
profiling. Blank Stock (3) adds material to the work piece.

For each type of stock (rough, profile, blank), separate stock values can be
applied to faces and diameters. Face stock and Radial stock are applied in
addition to the Equidistant stock. Equidistant stock adds the same stock to
all elements. Face stock adds stock to faces only. Radial stock adds stock to
diameters only.

In the following figure, the total face stock (1) is equal to the Equidistant
stock plus the specified Face stock. The total diameter stock (2) is equal to the
Equidistant stock plus the specified Radial stock.
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Part Boundary Parameters
The following options control part boundaries and are available by editing the
part boundary of a TURN_WORKPIECE object.

Tolerance Offset

Tolerance Offset lets you control the dimensions of the design model of your
part in manufacturing.

This feature is useful if you require optimal surface control for the part you
want to machine. Use this feature when you need to consider tolerance values
specified for the part you want to machine.
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General Offset

General Offset lets you define stock or offset values for individual surface
areas of your manufacturing part.

This feature is useful if you require optimal surface control for the part you
want to machine. Use this feature when you need to consider individual
stock/offset values for certain boundary members of your part.
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Fine Finish Offset

Fine Finish Offset provides corner control options specialized to leave proper
finish or grind stock on selected portions of the part surface.

This feature is useful if you want optimal surface control for the part you
want to machine. Use this feature when you need to leave finish or grind
stock on your part surface.
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Corner 1/Corner 2

Corner 1/Corner 2 options let you control the offset/stock shape and corner
treatment at either corner of the selected boundary member individually. Use
this feature if you want to specify a corner control type such as Constant
Radius/Chamfer for Tolerance Offset or Angular Line for Fine Finish Stock
with Corner Cleanup.
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Control

The Control option menu allows you to specify additional corner control for an
individual corner of the selected boundary member. It may be combined with
offset/stock definition but can also be independently defined. Use this feature
when you need a specific corner control option either at Corner 1 or Corner 2
of your selected boundary member.

Create Chamfer/Round Control

Create Chamfer/Round Control allows you to create a chamfer or a round at
a selected corner in your boundary. It may be combined with offset/stock
definition but can also be independently defined. Use this feature when you
need a specific corner control option either at Corner 1 or Corner 2 of your
selected boundary member.
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Corner Cleanup

Corner Cleanup ensures that the tool’s cutting motions leave a clean round or
chamfer surface while respecting the angular corner of a Fine Finish Offset.
You should use this feature when selecting the Angular Line option in Fine
Finish Offset/Stock for diameter surfaces that have blends or chamfers next
to them.

Automatic Corner Cleanup allows the contact point of the cutter to cut all the
way to the tangent point of the blend before cutting along the chamfer. This
assures that grind stock is never left on the blend and that the round is clean.
As a result, the tool may cut into the chamfer before moving up and over the
chamfer. You can specify a Cleanup Distance to cut beyond the tangent point.
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Manual Corner Cleanup respects the chamfer, but can leave unwanted grind
stock on the blend near the tangent point. The Adjust Distance option can
correct this by allowing the tool to cut further along the blend.
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Feed Rates
Feed Rate is the rate at which the tool advances. The Feed Rate submenu
contains a variety of feed rate control parameters which allow for fine-tuning
of the Turning processor’s results. Speeds refer to spindle and surface speeds.
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Spindle Output
Mode

The method in which the Feed Rate is specified. RPM
(Revolutions per Minute) refers to the number of times
the spindle turns in 60 seconds. SFM/SMM (Surface
Feet/Meters per Minute) refers to the distance in
feet or meters that the spindle travels in 60 seconds
measured at the surface of the part. Here the spindle
speed adjusts its speed to the amount of material to be
removed in order to ensure a constant surface speed.

Surface Speed The speed found on the surface of the part at any
moment in the machining process

Maximum RPM Defines the maximum RPM during the SFM or SMM
motion.

Preset RPM Defines the RPM that will be output prior to entering
the SFM or SMM mode.

Spindle Direction Determines the correct spindle rotation direction
based on the location of the cut region with respect to
the spindle axis of rotation and whether the insert
is on the top side or the underside of the tool holder.
Defaults to Automatic

Set Non-Cut Units initializes the feed rate unit for all movements which
do no cut through material such as traversals and
returns. This option sets the units of all non-cut
moves at once so you don’t have to individually change
the unit of each feed rate.

Set Cut Units Initializes the feed rate unit for all movements which
cut through material such as engage and cut moves.
This option sets the units of all cutting moves at once
so you don’t have to individually change the unit of
each feed rate.

Reset from Table Allows the system to recommend appropriate feeds
and speeds based on the user specified part material,
tool type and material, cut method, and cut depth
parameters. The system extracts an appropriate
Surface Speed from the library (maintained by system
administration) based on the user input. The feed
rate values, which appear under the Feeds tab, are
then calculated.

Not all conditions will find a feed and speed solution in the library.
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Feed rates can be specified for each type of cutting and non-cutting move. A
feed rate of zero indicates that the move uses a value specified elsewhere. For
example, an Engage feed rate of zero causes the tool to engage at the Cut feed
rate. An Approach feed rate of zero causes the tool to move at the Rapid feed
rate if the engage method is specified; otherwise, the Engage feed rate is used.
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Rough Feed Rates are available to assign specific Feed Rate values to motions
carried out in Roughing operations only. Acceleration and deceleration feed
rates allow feed rate changes at the beginning and at the end of each singular
rough cut, for example when approaching a shoulder. This feature helps to
prevent insert breakage due to chips accumulating at the end of a rough cut
close to a shoulder or to protect a forged part from breakage in those moments
where the cutter enters or leaves the material.

Profile Feed Rates are available to assign specific feed rate values to motions
carried out during finishing or profiling passes:
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Ramp Feed Rates pertain to the cutting motions that are not made along
the part profile in cleanup, finishing or additional profiling. If any of these
cleanup feed rates are set to 0, those movements are carried out at the linear
feed rate from the Profile/Finishing tab control feed rates for additional
profiling moves.
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Avoidance Geometry
The Avoidance option enables you to define clearance motions for the tool as
it moves toward or away from the part. You can specify points or planes to
help you define these clearance motions.
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From Point Defines the initial cutter location at the start of a tool
path. The FROM/ command is output as the first
entry in the tool path, but there is no tool movement.
It is advisable to specify a FROM point when using
the GPM for postprocessing the tool path since the
first GOTO point is removed from the output

Motion to Start
Point

Defines the tool position location in the cutter start
up sequence. If a From Point has been defined, the
cutter will rapid from it to the Start Point. The Start
Point outputs a GOTO/ command at the rapid feed
rate after the FROM/ and post commands and before
the first Engage move.

Motion to Return
Point / Clearance
Plane

defines the tool location at the end of a cutting
sequence. The Return Point outputs a GOTO/
command at the Rapid feed rate following the Final
Retract motion.

Motion to GoHome
Point

Outputs a GOHOME/ command as the final entry in
the tool path. The From Point is often used as the
GOHOME point.

Clearance Defines a safe distance from the work piece along the
radial or axial positions, for positioning moves to the
Start and Return points

Creating Associative Points

Points, Vectors, and Planes (usually used for avoidance geometry) can be
created as associative geometry so that when the referenced geometry is
modified, the associated geometry is also modified.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 5-17



5

Common Options

Activity: Rough Stock and Avoidance Options

In this activity, you are going to create an operation to finish the face of
the part by removing the Rough Face stock. You will edit the Rough Face
operation, add a From point. a Start point, and a Return point in order to
gain more tool control between operations.

Step 1: Open and rename the part.

Open the tmp_common_mfg_1 part.

Save the part as ***_common_mfg_1, where *** represents
your initials.

Choose Start→Manufacturing.

Step 2: Replay the existing operation.

In the Operation Navigator, display the Program Order View
and expand the objects.
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Highlight ROUGH_FACE and choose the Replay Toolpath icon.

The tool removes material in two passes leaving .02 (the
roughing default) stock on the face.

Step 3: Add a From, Start, and Return Point to this operation.

In the Operation Navigator, double-click ROUGH_FACE to edit
the operation.

You are going to specify several Avoidance settings.

Choose Avoidance.
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Turn the Motion to Start Point and Motion to Return Point
options on.

Under each option, set the Motion Type to Direct.

Motion Type determines how the tool will move between the
avoidance points and the part. You will leave both of these
options set to Direct. This will allow the tool to take a direct
(shortest) path.

Choose Select under Motion to Start Point and click the
approximate screen position illustrated below.
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Choose Select under Motion to Return Point and click near
the Start Point.

The Start and Return Point indicators are placed on top of
each other.

Turn the From Point option on.

Choose Select.
In many cases, you may have a specific From point location
that you use with each machine.

Key in 6.00 in the XC field.

Key in 5.00 in the YC field.

Choose OK until you return to the FACING dialog.
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Generate the tool path.

The tool moves from the From Point (1) to the Start point (2),
cuts the part (3), and then moves to the Return point (4).

Notice that creating avoidance points allowed the tool path
to generate without displaying the Last Tool Position
dialog.

Choose OK to complete the operation.

Step 4: Copy and rename the operation.

You are going to copy the operation and then edit the Method and
the Stock. When you copy the operation, the Avoidance parameters
you just defined will already be set.

Highlight ROUGH_FACE in the Operation Navigator, then
(using MB3) choose Copy.

The operation is copied. Now you will paste it into the list on
the Operation Navigator.

With the ROUGH_FACE operation still highlighted in the
Operation Navigator, use MB3 to Paste the copied operation.
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Make sure that the operation that you just copied is
highlighted, then use MB3→Rename to rename the operation
to FINISH_FACE.

Step 5: Edit the Method.

Double-click FINISH_FACE to edit the operation.

Choose the Groups tab at the top of the Facing dialog.

Choose Method and Reselect.

Set the Method option to LATHE_FINISH.

OK to accept the Method.

Step 6: Edit the Stock values of the operation.

Choose the Main tab.

Choose Stock.

Verify the stock values are zero 0.

OK to accept the stock.
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Step 7: Display the Cut Region.

It is always a good practice to display the cut region before
generating a path.

In the Cut Regions area, choose Display.

Generate the tool path.

The tool path finishes the face of the part.

Refresh the graphics display.
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Step 8: Edit the Start point.

You are going to edit the Start point in the FINISH_FACE
operation.

Choose Avoidance.

Choose Reselect next to Motion to Start Point option.

This Start point will be a smart point. You will associate the
Start point to the end point of the blank. If the blank changes,
the Start point will also change.

Set the Offset option to Rectangular.

Choose the End Point icon.

Select the end point of the horizontal or vertical line.

Key in 1.00 in the XC field.

Key in .25 in the YC field.

OK to accept the Start point.

OK to accept the avoidance parameters.
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Generate the tool path.

The tool moves to the Start point above centerline and then
moves to the first cut position.

Step 9: Removing the From point.

You are going to remove the From point since this is not the first
operation in the program.

Choose Avoidance.

Turn the From Point option off.

OK to accept the avoidance parameters.

Generate the tool path.

OK to complete the operation.

Save and close the part.
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Engage and Retract Moves
Engage and Retract moves control the tool motion to bring the tool safely into
contact with the blank and part to begin each machining pass. They also
control retract motions to safely move the tool away from the work piece at
the end of each machining pass. For each engage or retract situation (1), the
selected strategy (2) works together with the specified parameters (3).
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The engage and retract conditions are defined as follows:

Profiling The engage/retract that is applied to the start or end of a
profile pass.

Level/
Blank

The engage is applied when a roughing pass cuts only blank
material (does not contact any part material).

The retract is applied when the rough pass cuts to the end of
the blank, without cutting any part material.

Level/ Part The engage is applied whenever a rough pass in a reversal
engages to part material.

The retract is applied whenever a rough cut stops at part
geometry. The retract motion is applied after a rough cut or
— if applicable — after the cleanup cut.

Level/ Safe The engage that is applied to the last pass of roughing when
the pass contours the part shape.

Plunge The engage/retract that is used in the plunging passes in
grooving.

1st Plunge Gives separate control for engage and retract for the first
plunge pass.
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Engage and Retract Strategies

Each of the previous listed Engage and Retract options allows you to define
specific Engage/Retract Strategies. The table below indicates which Strategy
options are available for each Engage/Retract Situation.

Option Profile Level/
Blank

Level/
Part

Level/Safe

(no Retract)
Plunge and
1st Plunge

Auto
Circular X

Auto Linear X X X X X
Vector X X X X X
Angle/
Distance X X X X X

Relative
Linear X

From a Point
(eng) To a
Point (ret)

X X X X (no ret)

Two Circles X
2 Pt.
Tangent X X
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Activity: Engage and Retract Moves

In this activity, you are going to edit an existing operation and examine the
automatic engage and retracts. You will then change and add different engage
and retract moves, then examine the results. The purpose of this activity is to
introduce some of the many methods of engagement and retracting.

Step 1: Open the part, rename it, and enter Manufacturing.

Open the tmp_common_mfg_2 part.

Save the part as ***_common_mfg_2, where *** represents
your initials.

Choose Start→Manufacturing.

Step 2: Replay the roughing OD operation.

Display the Program Order view of the Operation Navigator
and expand the objects.
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Highlight ROUGH_TURN_OD and replay the tool path.

Notice the default engage and retract moves.

All engages and retracts are Auto Linear except those for the
Profile cut which uses Auto Circular (1).

You will now change some of the engages and retracts.

Step 3: Create an Engage move on a Profile pass.

You will change the engage move to use the Relative Linear
strategy. The tool will use this move when engaging the part
material on a profile pass.

Double-click on the ROUGH_TURN_OD operation.

Choose Engage/Retract.

The Engage/Retract dialog is displayed. The default engage
for Profiling is Auto Circular.
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Choose Relative Linear.

Key in 90 in the Angle field.

Key in 0.050 in the Distance field.

OK to return to the ROUGH_TURN_OD dialog.

Generate the tool path.

The tool now engages at 90 degrees into the material on the
Profile pass.

Step 4: Create an Engage move when engaging the Blank material.

This time you will disable the automatic setting on the linear
engage type and input manual values.

Choose Engage/Retract.

Choose Level/Blank.

The default engage for Level/Blank is Auto Linear.

Deselect the Use automatic values option.
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Key in 255 in the Angle field.

Key in 0.050 in the Distance field.

Choose OK to return to the ROUGH_TURN_OD dialog.

Generate the new tool path.

The tool now engages at 255 degrees into the Blank material.

Step 5: Create a Retract move.

Choose Engage/Retract.

Choose the Retract tab.

Be sure Profiling is selected.

Choose the Vector icon.

Key in 0.00 in the Vector (X) field.

Key in 0.15 in the Vector (Y) field.

Step 6: Create a Retract move when exiting the Part material.

Choose Level/Part.

Choose the Angle/Distance icon.

Key in 90 in the Angle field.

Key in 0.10 in the Distance field.

Choose OK to return to the ROUGH_TURN_OD dialog.
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Generate the tool path.

The first retract is the Level/Blank retract. It is using the
default Auto Linear.

The second pass retract uses the Level/Part retract, which uses
Angle/Distance to define the move.

The last pass retract is the Profiling pass which uses a Vector
to define the move.

Note that the retracts look the same. When you specified
a Vector of X=0 and Y=.15 for the Profile retract and
Angle/Distance of 90 and .1 for the Part retract move, they
produce the same result. The result is a direct move along the
Y axis. The only difference is that the profiling move is longer
than the Part Retract move.

Step 7: Change the Engage and Retract types.

Now try some of the other Engage and Retract strategies, such
as To or From a Point. Examine the results.

Save and close the part.
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Activity: Applying Grind Stock

In this activity you will specify a Fine Finish Offset and a Tolerance Offset.
Fine Finish Offset allows you to leave finish or grind stock on your part
surface. Tolerance Offset allows you to achieve localized mid-tolerance part
size control.

Step 1: Open the tmp_common_mfg_3 part and start the Manufacturing
application.

Step 2: Edit a boundary member.

Display the Geometry view of the Operation Navigator and
expand the objects.

Double-click TURN_WORKPIECE in the Operation Navigator
to edit the object.

Choose Edit in the TURN_BND dialog.

Choose Edit in the Part Boundary dialog.
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Select the boundary member illustrated below.

This is the member to which you will add Fine Finish and
Tolerance Offsets.

Step 3: Define a fine finish offset.

You will define a Fine Finish Offset to leave grind stock on the
part diameter.

Choose the Fine Finish Offset tab.

Turn the Offset Value option on.

Key in 0.020 in the Offset Value field.

This value is deliberately large so you can graphically see the
offset. A more realistic offset may be 0.005.
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Zoom In on Corner 2 and choose Preview to see the offset.

The ends of the boundary member being edited are numbered
(1, 2) and are referred to as “corners”. This corner control
allows you to control the transition from the stocked member
to the adjacent member.

Step 4: Define an angled corner.

You will define Corner 2of the Fine Finish Offset as an angled
corner.

Set the Type option for Corner 2 to Angular Line.

Set the Angle option to At current segment.

This is the segment from which the angle will be measured.

Key in 45.000 in the Angle field.
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Choose Preview to see the angled corner.

The angled corner begins at the tangency point of the blend
and extends upward at 45 degrees measured from the current
boundary member.

Step 5: Specify automatic corner cleanup.

Automatic Corner cleanup assures that the contact point of the
tool reaches the tangent point of the blend despite the chamfer.

Turn the Corner Cleanup option on.

Set the Corner Cleanup option to Automatic.

OK the Edit Member dialog.

OK the Part Boundary dialog.

OK the TURN_BND dialog.

Step 6: Visualize material removal.

Generate the tool paths for the two operations in the program.

Highlight FINISH_TURN_OD and choose Verify Toolpath from
the toolbar.
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Turn the 2D Material Removal option on.

Notice how the tool path joggles up to leave the grind stock
(Fine Finish Offset) on the part.

Choose the Step option at the bottom of the Tool Path
Visualization dialog until the tool reaches the tangent point as
illustrated below.

Notice that the tool cuts into the chamfer to reach the tangent
point (1). Automatic Corner cleanup assures that the contact
point of the tool reaches the tangent point of the blend despite
the chamfer. As a result, grind stock is not left along the blend
and the round is always smooth.

Continue stepping through the tool path to see the tool jog up
and over the fine Finish Offset.

Cancel the Tool Path Visualization dialog.
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Step 7: Specify manual corner cleanup.

You will see how a Manual Corner Cleanup can leave unwanted
material along the blend unless you specifically control the cleanup.

Select the TURN_WORKPIECE object and edit the boundary
again as you did in Step 2.

Select the boundary member as you did in Step 2.

Choose the Fine Finish Offset tab.

Set the Corner Cleanup option to Manual.

OK the Edit Member dialog.

OK the Part Boundary dialog.

OK the TURN_BND dialog.

Step 8: Visualize material removal.

Generate the tool paths for the two operations in the program.

Highlight FINISH_TURN_OD and choose Verify Toolpath from
the toolbar.

Turn the 2D Material Removal option on.
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Choose the Step option at the bottom of the Tool Path
Visualization dialog until the tool positions near the top of the
part as illustrated below.

Notice that the tool contact point (1) never reaches the blend
tangent point (2). The tool does not cut into the angled corner,
but instead cuts up and over the angled corner as soon as it is
encountered.

As a result, unwanted grind stock is left along the blend (3)
and the round is not smooth.

The Adjust Distance option can correct this by allowing the
tool to cut further along the blend, cleaning up the unwanted
grind stock. Automatic Corner Cleanup, however, is generally
a better option to use in these cases.

Continue stepping through the tool path to see the tool jog up
and over the Fine Finish Offset.
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Cancel the Tool Path Visualization dialog.

Step 9: Define a tolerance offset.

Tolerance Offset allows you to control the dimensions of the design
model of your part in Manufacturing. It allows you to achieve
localized mid-tolerance part size control. This offset defines a stock
that will not be removed by any machining operation.

Double-click TURN_WORKPIECE in the Operation Navigator
to edit the object.

Choose Edit in the TURN_BND dialog.

Choose Edit in the Part Boundary dialog.

Select the boundary member illustrated below to edit as you
did before.

Turn the Offset option on.
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Set the Offset option to Tolerance.

Key in 0.010 in the Tolerance field.

This value is deliberately large so you can graphically see the
offset. A more realistic offset may be 0.002.

Zoom in on Corner 2 and choose Preview to see the combined
Tolerance and Fine Finish Offsets.

You will change the Corner Cleanup for the Fine Finish Offset
back to Automatic so that unwanted grind stock is not left on
the blend.

Choose the Fine Finish Offset tab.

Set the Corner Cleanup option to Automatic.
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Step 10: Visualize material removal.

Generate the tool paths for the two operations in the program.

Highlight FINISH_TURN_OD and choose Verify Toolpath from
the toolbar.

Turn the 2D Material Removal option on.

Choose the Play option at the bottom of the Tool Path
Visualization dialog.

Notice how the Tolerance Offset (1) gradually increases around
the blend. The Fine Finish Offset (2) is then added to the
Tolerance Offset once the tool contact point reaches the tangent
point of the blend. As a result, there is no unwanted grind
stock left on the blend and the round is smooth.

Cancel the Tool Path Visualization dialog.

Save and close the part.
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Summary
This lesson covered many of the common parameters you will use in creating
tool paths. These parameters, which include stock, feed rate, avoidance
moves, engage and retracts, and feed rate control, are common to all or most
turning operations. The Stock function allows you to leave material on the
part. The Feed Rate is the rate at which the tool advances. Feed Rates can be
specified for each type of cutting and non-cutting move. The Avoidance option
enables you to define clearance motions for the tool as it moves toward or away
from the part. Engage and Retract moves control the tool motion to bring the
tool safely into contact with the blank and part to begin each machining pass.
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Lesson

6 Centerline Operations

Purpose

This lesson describes the use of Centerline operations.

You will create several Lathe Drilling operations. You will specify the tool
start point, the drill depths, and learn how to use the break chip methods.

Objective

Upon completion of this lesson, you will be able to:

• Create centerline spot drilling and drilling operations.

• Define drilling geometry both automatically and manually.

• Control chip removal by defining variable increments.
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Drilling Operation Types

1. CENTERLINE_SPOTDRILLING

2. CENTERLINE_DRILLING

3. CENTERLINE_PECKDRILL

4. CENTERLINE_BREAKCHIP

5. CENTERLINE_REAMING

6. CENTERLINE_TAPPING
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Drilling Cycles
Use the Cycle menu to choose a drilling cycle type for the operation. Cycle
types determine which parameters are available and the cycle event that
is output in canned machine cycles.

Drilling cycles may be either Canned or Simulated.

Canned Use cycles supplied by your NC machine. Generates a
CYCLE event containing all cycle parameters and a single
GOTO statement representing the start position of the
cycle. To use canned cycles, make sure the Simulated option
is turned off.

Simulated Generates a centerline drilling tool path and a series of
GOTO statements. Does not create a CYCLE event. To use
simulated cycles, make sure the Simulated option is turned
on.
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Drill Geometry
Automatic Start Position determines the drilling start point based on the
current IPW and tool shape.

When you choose Select or Reselect under the Drilling Geometry label, the
Point Constructor dialog is displayed. You are then prompted to specify a
Start Point. The Start Point is the point at which the tip of the drill first
contacts the part (1).
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Total Depth
Total Depth defines the total cutting depth of the drill.

There are 6 options available:

Depth requires that you key in a positive value next to the Depth label. This
value is applied along the drill axis (parallel to the centerline through the
Start Point).

End Point uses the Point Constructor dialog to specify the drilling end point.

Cross Hole Data requires that you enter values for:

Diameter – the diameter of the cross hole.

Distance – the distance between the drill Start Point and the intersection
of the cross hole axis with the drill axis (parallel to centerline through
the start point).

Angle – the angle that the cross hole axis makes with the drill axis
(parallel to the XM or YM axis).

When you enter the data to define the cross hole, the depth value is calculated.
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Cross Hole allows you to select an existing circle as a cross hole. The drilling
depth is based on the distance from the start point along the drilling axis to
the selected cross hole. The drill depth is calculated such that the drill fully
pierces the side of the cross hole and then retracts. It allows you to specify
the Cross Hole:

• using the cursor

• entering the depth

• specifying an end point

Shoulder Depth allows you to specify the drilling depth by referencing the
shoulder of the tool. The tracking point is established at the tip of the tool by
adding the calculated tool tip length to the specified shoulder depth.

Countersink Diameter determines the cut depth by allowing you to specify
the diameter to be cut by the spot drilling tool.

Break Through

The Break Through option controls the distance that the tip of the tool can
exceed the specified drilling depth.
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Chip Removal
The Drill, Deep and Drill, Break Chip simulated cycles automatically clear
or break chips during the drilling operation. You may specify chip removal
parameters on the Chip Removal tab within the Cycle Parameters dialog by
clicking the Settings as shown below.

Increment Type

You may specify whether the distance that the drill will move before clearing
the chips (Increment Type) is Constant or Variable.

Number of Cuts refers to the number of times you wish to repeat the specified
Variable Increment.

Increment refers to the distance the drill moves forward with each move.

Departure Distance refers to the distance the drill moves backward.
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Clearance Distance
The Clearance Distance is a safety zone around the workpiece for non-cutting
tool moves.

The tool rapids to the Clearance Distance (1) from the specified Start Point
(2) and then proceeds at the cut feed rate.

At the end of the drilling operation, the tool returns to the Clearance Distance
before going to the Return and/or GOHOME points.
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Engage Distance
Engage Distance uses the diameter of an existing drilled hole to adjust the
contact point of the drill with the material. The calculations are made using
the defined entrance diameter and the drill point angle. The tool begins at
the original start point (1), and drills to the new start point (2). The engage
distance (2) is calculated based on the drilled hole (3).
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Dwell
This option allows you to specify a dwell interval (Delay) in tool motion at the
end of a machining pass to relieve tool pressure.

You must first specify the units (SECONDS or REVOLUTIONS) and then the
number of units. A DWELL/ command is output at various times depending
on the chip removal method. If you do not specify chip removal, a DWELL/
command is output when it reaches the total depth.
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Activity: Centerline Drilling – Spot Drilling

In this activity, you are going to create an operation to spot drill the face in
preparation for a standard drilling operation. The tools for this operation are
contained within the part file. You will define the Parent Groups, select the
geometry, and examine the Total Depth options.

Step 1: Open the and rename the part.

Open the tmp_drill_mfg_1 part.

Save the part as ***_drill_mfg_1, where *** represents your
initials.

The part and blank geometry have been predefined for this
operation.

Choose Start→Manufacturing.

Step 2: Verify the Facing operation tool path.

The program contains a Facing operation. The tool path generated
by the subsequent spot drill operation must use the IPW created
by the Facing operation.

Display the Program Order View of the Operation Navigator
and highlight the FACING operation.

Choose the Verify Toolpath icon in the toolbar.
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Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

Material is removed from the face of the blank.

The subsequent spot drill operation must take into
consideration the material already removed by the facing
operation. The system can establish the drilling start point
automatically based in the in-process workpiece (IPW).

OK to complete the tool path visualization.

Step 3: Begin a Centerline Spot Drill operation.

Choose the Create Operation icon.

Be sure the Type option is set to Turning.

Choose the CENTERLINE_SPOTDRILL icon.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....TURN_WORKPIECE

• Use Tool..........SPOTDRILL_.500

• Use Method......LATHE_CENTERLINE
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Choose OK.

The CENTERLINE_SPOTDRILL dialog is displayed. You will
display the part and blank boundaries.

Choose the Groups tab.

Choose the Geometry button, then choose Display.

The part (1) and blank (2) boundaries are displayed.

Choose the Main tab.
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Step 4: Display the drilling geometry.

With the Automatic Start Position option turned on, choose
Display.

The start point (1) is determined automatically based on the
IPW.

The end point (2) is determined by the Total Depth measured
from the start point. Look at the default Total Depth value.

Step 5: Generate and verify the tool path.
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Choose the Generate icon.

Now you can observe the relationship between the start point,
the end point, and the tool path.

Choose Display under Drilling Geometry.

Choose the Replay icon at the bottom of the dialog.

The start point (1) is the point at which the tool begins to cut.
The end point (2), defined by the Total Depth value, is where
the tool stops cutting. The Clearance Distance (3) allows the
tool to retract out of the hole past the start point to assure that
the tool clears the material.
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Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

Step 6: Define the start point manually.

Turn the Automatic Start Position option off and choose Select.
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Select the vertical line that defines the front face of the blank
geometry.

The start point (1) is positioned on the face of the blank. The
end point (2) is positioned 0.100 inside this face.
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Remember that the face you selected has been removed by the
facing operation. Consequently, you will need to increase the Total
Depth for the tool to reach the IPW. The disadvantage of this
method is that you are cutting empty space as the tool moves from
the start point toward the IPW.

As an alternative, you might consider positioning the start point
(1) on the front face of the part. This, however, would embed the
start point in the IPW (2).
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Step 7: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

The tool clearly does not reach the IPW. You will need to
increase the Total Depth.

OK to complete the tool path visualization.

Step 8: Increase the total depth.

Choose Total Depth.

Key in 0.250 in the Depth field.
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OK the Total Depth dialog.

The end point has moved to the left.

Step 9: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

Now the tool reaches the IPW.
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OK to complete the tool path visualization.

You can see by these two examples that it is much easier
and more effective to use Automatic Start Position than to
manually define the start point.

Step 10: Specify an automatic start position.

Turn the Automatic Start Position option on.

Specify a Total Depth of 0.100.

Generate the tool path.

OK to complete the operation.

Save the part.
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Activity: Centerline Drilling – Standard Drilling

In this activity, you are going to create a standard drilling operation. You will
define the Geometry, the Total Depth, and then examine the Chip Removal
options.

Step 1: Continue to use the ***_drill_mfg_1 part.

Step 2: Begin a Centerline Drilling operation.

Choose the Create Operation icon.

Choose the CENTERLINE_DRILLING icon.

Set the Use Tool option to DRILL_.470.

The Program, Use Geometry, and Use Method options are set
correctly from the previous operation.

Choose OK.

Step 3: Display the automatic start point.
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With the Automatic Start Position option turned on, choose
Display.

The start point position (1) is based on the IPW.

Step 4: Specify the total depth.

The end point is determined by the Total Depth measured from the
start point. The default Total Depth value is 0.0000.

Choose Total Depth.

You want the tool to drill completely through the part.

Turn the Break Through option on.

Change the Total Depth to End Point.

Choose Select.

The Point Constructor dialog is displayed.
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Select the vertical line defining the back face of the blank.

OK to accept the total depth.

Step 5: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.
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Step 6: Change the Chip Removal setting.

You can change the Chip Removal setting (Break Chip or Peck
Drill) within an operation.

Change the Cycle option to Drill, Deep.

Choose Settings icon. .

Click the Chip Removal tab and change the increment type
to Variable

Enter the following values in order into the list:

• Number of Cuts 2 Increment .35

• Number of cuts 4 Increment .25

• Number of cuts 4 Increment .15

• Number of cuts 2 Increment .05

The Safe Distance determines how far the tool will retract
between each cut. Use the default setting of .100.

OK to accept the chip removal increments.
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Step 7: Generate and verify the tool path.

Choose the Generate icon.

The tool moves along the centerline to the end position, drilling
through the part using the increment that you entered. Note
the last passes of the tool path. You specified two cuts at .05.
The tool used these values, but there was material remaining.
The system continued to cut to the specified depth using the
last specified value (.05).

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 3.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.
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Step 8: Examine the Clearance Distance setting in the tool path listing.

Choose the List icon at the bottom of the
CENTERLINE_DRILLING dialog.

The data is listed in the window.

The tool cuts to 1.8825 (1) then rapids to the clearance distance
of 2.3325 (2). (the 2.3325 value is .100 from the IPW). The
tool then rapids to a clearance distance of .100 away from the
previous cut depth (3). The tool continues to cut in this manner
until it clears the back of the IPW.

Dismiss the Information window.

Choose OK to complete the operation.

Save the part.
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Activity: Centerline Drilling – Unassisted

In this activity, you are going to create an operation to remove the material
within the larger ID. You are going to create this activity using fewer
instructions.

Step 1: Continue to use the ***_drill_mfg_1 part.

Step 2: Create an operation.

Begin a new Centerline Drilling operation.

Define the Parent Groups for this operation. Use the .612
diameter drill.

Step 3: Define the following options for this operation:

Drill Geometry

Total Depth

Chip Removal (Optional)

Dwell (Optional)

Step 4: Generate and accept the tool path.

Step 5: Save and close the part.
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Summary
In this lesson, you learned how to create centerline spot drilling and drilling
operations. You learned how to define drilling geometry both automatically
and manually. When defined automatically, the drilling geometry is based
in the IPW making the automatic method much easier and more efficient to
use than the manual method. When drilling, you learned how to control chip
removal by defining variable increments.
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Lesson

7 Roughing Operations – OD Work

Purpose

The roughing options in Turning allow you to remove large amounts of
material and leave sufficient material for finishing operations.

Objective

Upon completion of this lesson, you will be able to:

• Create a Rough Turn Outer Diameter operation.

• Change the Cut Pattern.

• Identify the appropriate Cut Depths.

• Add and remove Cleanup passes.

• Create additional Profiling passes (spring pass).

• Add a Local Return Point to the Spring pass.

• Add Post Commands to Local Return moves.

• Apply Single and Multiple Ramping Cut Strategies.

• Edit Part Boundary parameters from within an operation.
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Roughing Options
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Roughing Operations – OD Work

Cut Patterns

1. Linear Zig is a straight cut in one direction. Each pass is parallel to the
previous pass.

2. Ramping Zig is for inclined/declined cuts in one direction.

3. Contour Zig are parallel contour cuts in one direction. Each pass follows
the parts profile.

4. Plunge Zig are typical plunge cuts in one direction within the cut region.

5. Plunge Alternate cuts with alternating stepover direction. Each
subsequent plunge is applied to the opposite side of the first plunge.

6. Linear Zig-Zag is a straight cut with each subsequent pass cutting in an
alternating direction.

7. Ramping Zig-Zag is for inclined/declined cuts in alternating directions.

8. Contour Zig-Zag are parallel contour cuts with alternating direction.
Each pass follows the part profile.

9. Plunge Zig-Zag is for repeated plunge cuts to a specified level and in
alternating directions.

10. Plunge Castling is a unique plunge pattern which leaves pillars between
plunges, then returns to cut the pillars. The result is even cutting
pressure on the tool.
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Stepover (Cut Depth)
Stepover (for Plunge cuts) and Cut Depth (for Zig and Zig_Zag cuts)
determine how the tool will move from one cut level to the next. The cut
pattern determines which types are available.

Stepover/Cut Depth Types and Cut Patterns

Types Linear
Zig

Linear
Zig-Zag

Cont.
Zig

Cont.
Zig-Zag

Plunge
Zig

Plunge
Alt.

Plunge
Castle

Const. X X X X X X X
Variable
Max. X X X X X

Variable
Avg. X X X X X

# of
Levels X X

# of
Passes X X

Indiv. X X X X

Constant specifies the maximum depth of cut to be made on each roughing
pass. This value is used as many times as possible and then any remaining
material is removed in one pass.

Variable Max. determines the cut regions, cuts at the maximum value as
many times as possible, and then removes the remaining material in one pass
if it is greater than or equal to the minimum within each separate region.

Variable Avg. calculates the minimum number of passes required based on
never cutting more than the maximum or less than the minimum for each
region.
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# of Levels produces equal depths of cut by allowing you to define the number
of levels for linear roughing.

# of Passes allows you to define the number of contour passes to be taken to
remove the material.

Individual produces a series of differing cut depths by allowing you to define
the number of passes at each cut depth.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 7-5



7

Roughing Operations – OD Work

Cleanup
Cleanup is an additional pass applied at the end of the tool path designed to
remove material such as steps (1) left by the previous rough cutting passes.

Cleanup passes can be done in several different ways.

All Creates a cleanup on all contours.
Steep Only Creates a cleanup on only the steep elements. Steep

parameters are defined using the Contour Types located
under the Cutting button.

All but Steep Creates a cleanup for all geometry that does not qualify
as steep.

Level Only Creates a cleanup on geometry that is defined as level
only. Level parameters are defined using the Contour
Types located under the Cutting button.

All but Level Creates a cleanup on all geometry except the geometry
that does not qualify as Level.

Down Only Creates a cleanup in a down direction. This option is
commonly used in grooving

Per Reversal Creates a cleanup in the reversals only.
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Contour Types

The parameters that define Faces and Diameters are located on the Contour
Types dialog. This dialog is accessed when you choose Cutting→Settings.
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Cutting
The options that are located under the Cutting button allow you to add
additional tool control.

Tolerance

Tolerances allows you to set values for Intol and Outtol. The tolerance is
applied to the Part boundary and determines the acceptable amount of
deviation from the boundary.

Cutter Clearance Angles

This option is used as a clearance for the Lead and Heel Angle. This option is
used to prevent the tool from gouging.

Minimum Clearance

Minimum Clearance defines a safe clearance distance away from the blank
boundaries. You can define individual distances for both:

• diameters

• faces

Minimum Clearance ensures that positioning moves between cutting regions
or during a traversal move, clears the In-Process Workpiece.

Cut Constraints

These options allow you to define a Minimum depth of cut and Minimum
length of cut for the operation. These options only apply to the Linear cutting
options.

Cut Regions

This option allows you to machine all cut regions in a single operation,
reducing the number of operations required to machine your part. Region
Sequencing allows you to control the cut region machining sequence.
Sequences include Single Direction, Inverse Direction, Alternate, and
Bi-directional.

Cut Control

The Cut Control option allows you to control the extent of the tool’s entry into
undercut areas on your workpiece.
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Dwell after Rough Cut

This option outputs a dwell command after each and every rough plunge
motion. The dwell is not triggered for subsequent motions along the part
profile which may also be generated by the rough plunge cut operation. It is,
however, initiated during the successive incremental plunge motions when
chip control is activated. Dwell may be input as seconds or revolutions.
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Activity: Creating an OD Rough Turn Operation

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_rgh_od_mfg_1 part.

Save the part as ***_rgh_od_mfg_1, where *** represents
your initials.

Choose Start→Manufacturing.

Step 2: Define the parent groups for this operation.

Expand the PROGRAM_RGH_OD Parent Group in the
Operation Navigator.

Choose the Create Operation icon.

Be sure the Type option is set to Turning.

Choose the ROUGH_TURN_OD icon.

Set the following Parent Groups:

• Program..........PROGRAM_RGH_OD

• Use Geometry....RIGHT_END_OD

• Use Tool..........OD_80_L

• Use Method......LATHE_ROUGH
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Choose OK.

The ROUGH_TURN_OD dialog is displayed.

Next you will verify the geometry.

Choose the Groups tab at the top of the dialog.

Choose the Geometry button, then Display.

Choose the Main tab at the top of the dialog.

Step 3: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.
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Choose the Play icon at the bottom of the dialog.

The Cut Pattern is Linear Zig.

OK to complete the tool path visualization.

Step 4: Changing Cut Patterns.

You will change the cut pattern and then regenerate the tool path.

Choose the Linear Zig-Zag icon.

Choose the Generate icon.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.
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Choose the Play icon at the bottom of the dialog and notice
the motion of the tool.

The tool lifts from the material then feeds back in at the
same point. This pattern is not acceptable for this part/tool
combination. You will try a different cut pattern.

OK to complete the tool path visualization.

Choose the Contour Zig icon.

Key in 0.100 in the Depth field.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.
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Choose the Play.

The tool path is generated and looks very different. This
time the tool cuts in a contour pattern following the shape
of the finished part. This pattern could work very well for a
non-stepped profile, but for this deeply stepped part, the tool
will bury into the faces.

OK to complete the tool path visualization.

Change the Cut Pattern back to Linear Zig.

Next you will examine the Cleanup option. This option is
unique to Roughing Operations.

Step 5: Examine the results of the Cleanup option.

Cleanup is designed to remove material (steps in most cases) left
from roughing passes. First, you are going to examine the results
of the cleanup option.
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Generate and Verify the tool path as you did before.

The tool path continues the pass along the contour of the part
in order to remove the material left from the previous pass.
If you were to turn the Cleanup option off, no cleanup would
be created.

The cleanup pass leaves the 0.030 radial stock (1) 0.020 face stock
(2) defined in the Stock→Rough Stock settings.

Turn off the Cleanup option.
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Generate and Verify the tool path.

There is no cleanup pass.

OK to complete the operation.

Step 6: Cleanup steep areas only.

Double-click ROUGH_TURN_OD to edit the operation.

Click on the Cleanup option to turn it on.

Next to the Cleanup option, choose Steep Only.

The system delineates steep from non-steep based on the Steep
parameters specified in the Contour Types dialog.

Choose Cutting.

Choose Settings under Cut Control.

Areas with angles falling between the specified Steep Min.
Angle and Max. Angles are regarded by the processor as steep.

You will not make any adjustments to the steep parameters.

Steep
Min. Angle 87.0000
Max. Angle 93.0000

Choose Back until you return to the ROUGH_TURN_OD dialog.

7-16 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



7

Roughing Operations – OD Work

Generate and Verify the tool path.

Only steep areas (1) are cleaned up. Non-steep areas (2) are
not cleaned up.

Change the Cleanup option back to All.

Generate the tool path once again.

Note that the tool cuts slightly into the thread relief and groove.

Choose OK to complete the operation.

Save the part.
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Profiling
Profiling options provide additional Spring Passes and Multiple Finish
Passes. These options differ from Cleanup in that they follow the part
boundary, where as the Cleanup option only removes excess step material.
The Additional Profiling option (1) will cause the operation to use the profiling
parameters you define in the Profiling Options dialog.

Note that you must turn the Additional Profiling option on in order to use
the Profile option that you defined.

The Profiling options allow you to make finish passes within a Roughing
operation.
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Override Autodetection

After the roughing passes, the system re-evaluates the material and the
In-Process Workpiece (using a second cut region detection process) and then
performs the profiling cuts.

Override Autodetection eliminates the second cut region detection and allows
the tool to cut exactly the same region that the roughing pass cuts.

Override Autodetection requires Rough and Profile Stock to be identical.

If rough and profile stock differ, the activated toggle to override the second
cut region detection process would cause the processor to execute the profile
cut with the wrong offset setting.

Local Returns

Local Return moves are available in Roughing, Finishing and Threading
operations. Local Return in Roughing can be defined separately for Rough
and Profile passes.
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Activity: Creating Additional Profile Passes

Step 1: Continue to use the ***_rgh_od_mfg_1 part.

Step 2: Create an Additional Profiling pass (spring pass).

When creating an Additional Profiling pass (spring pass), the
processor will first calculate a Cut Region for the Rough Stock and
execute the rough cuts. Then it will calculate a Cut Region using
Profile Stock and execute that cut.

Expand PROGRAM_PROFILE so you can see the three
operations.

Double-click ROUGH_TURN_OD_PROFILE to edit the
operation.

Choose Verify.

Turn the 2D Material Removal option on.
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Choose the Play.

The cleanup pass leaves the 0.030 radial stock (1) and the 0.020
face stock (2) defined in the Stock→Rough Stock settings.

OK to complete the tool path visualization.

On the ROUGH_TURN_OD dialog, turn on the Additional
Profiling option.

Choose Profiling.

You are going to use the default Cut Pattern (Profile All) the
first time and add one spring pass to this operation.

Enter 1 into the Spring Passes value field.

Choose OK from the Profiling Options dialog.
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Generate and Verify the tool path as you did before.

Note that the final pass cuts to finish depth.

This is due to the Profile Stock settings of Stock→Profile Stock
settings of 0.0000 Face and 0.0000 Radial. This is an example
of a roughing operation that has a finish pass.

Step 3: Add a Local Return Point and an operator message.

You are going to add a local return point to the Profile pass only.
This is done by defining the Local Return option inside of the
Profiling Options dialog. You can also add a Local Return to the
rough pass. To apply the Local Return to the rough pass you select
the Local Return button on the ROUGH_TURN_OD dialog.

Choose Profiling.

Choose Settings next to Local Return.

Turn on the Local Return option and set No. of Passes to 1.

Turn on the Local Return Point option and choose the Select
button.
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Enter the following values:

• XC = 4

• YC = 4

OK to accept the Point Constructor dialog.

Choose Display to display the local return point.

Now you are going to add an Opstop and an Operator message.
Note in the Resequence output list that these commands are in
brackets. As you pick the options to activate them, the brackets
will be removed.

Turn the Opstop and Operator Message options on.

In the Operator Message text field type Check Part Diameters.
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Step 4: Resequence the commands.

You can resequence the commands that you have activated using
the Resequence Output window and arrows. Notice that the
commands that you selected are no longer in brackets.

Highlight Operator Message in the Resequence Output area.

Use the down arrow to move the Operator Message below
Opstop.

You are ready to generate the spring pass changes, the local
return and additional commands.

Choose OK twice to return to the ROUGH_TURN_OD dialog
and then Generate the tool path.

The tool cuts the part including a cleanup cut. Before cutting
the spring pass the tool moves to the Local Return Point, then
cuts the spring pass.
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Step 5: List the tool path data.

Choose the List icon.

Scroll until you see the Opstop and Message commands in the
text.

Dismiss the Listing window.

This Local Return Point that you have just created is
only applied to the Profile pass. Remember, on the main
ROUGH_TURN _OD dialog you can define a Local Return.
This Local Return is applied at the end of each Rough pass.

Test this yourself by putting in an a different message and
different return position using the Local Return located on
the ROUGH_TURN _OD.

Turn the Additional Profiling option off.

Choose OK to complete the operation.

Save and close the part.
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Ramping
Ramping cut strategies can prolong tool life (particularly ceramic inserts) and
reduce machining time when rough cutting hard materials. Notching effects
on the insert can be effectively reduced or even completely avoided through
ramping which leads to savings in tooling costs and machining time.

By ramping every pass or every other pass in the roughing cut pattern, the
hot point on the cutting edge of the insert moves continually, distributing
stress and heat and extending the life of the insert.

In cases where a single ramp over the length of a cut is ineffective due
to a shallow cut depth, multiple ramping achieves the desired effect of a
constantly changing depth by generating a "sawtooth" or "wavy" cut pattern.

Ramping Zig ramps into or out of the part in one cut direction.

Ramping Zig-Zag ramps into or out of the part in both cut directions.
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The following ramping modes are used in combination with Ramping Zig
and Ramping Zig-Zag.

1. Ramp Out on Every Other Pass starts with a deep cut and diminishes the
depth of cut. This is followed by a level cut.

2. Ramp In on Every Other Pass starts at the surface of the work piece and
ramps downward into the material. This is followed by a cut level.

3. Ramp Out First alternately ramps every cutting pass with the first pass
ramping out.

4. Ramp In First alternately ramps every cutting pass with the first pass
ramping in.
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Activity: Creating Ramping Cut Patterns

In this activity, you are going to create single and multiple ramping cut
patterns.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_ramp_mfg_1 part.

Save the part as ***_ramp_1_mfg_1, where *** represents you
initials.

If necessary, enter the Manufacturing application.

Step 2: Specify a Ramp Zig cut pattern.

Expand the PROGRAM Parent Group in the Operation
Navigator.

Double-click ROUGH_OD in the Operation Navigator to edit
the operation.

Choose the Ramping Zig icon.

Choose Cutting.

Choose Settings next to Ramping.

Choose OK to accept the Ramp Out on Every Other Pass option

as the Ramping Mode.

Choose OK to accept the Cutting dialog.
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Generate and Verify the tool path.

OK to complete the operation.

Step 3: Specify a Multi Ramp pattern

Multi Ramp patterns are useful in cut regions that are long and
shallow where ramping over the length of the cut is ineffective
because the inclination is nearly horizontal.

Double-click ROUGH_OD_1 in the Operation Navigator to edit
the operation.

Choose the Ramping Zig icon.

Choose Cutting.

Choose Settings next to Ramping.

Turn the Multi Ramp Pattern option on and key in 0.500 in
the Max. Ramp Length field.

Notice that the default Multi Ramp Pattern is Ramp Out Only.

OK to accept the ramping parameters.
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OK to accept the Cutting dialog.

Generate and Verify the tool path using an Animation Speed
of 1.

The last linear pass assures that the surface is cut flat.

Step 4: Omit the last pass.

The Omit Last Pass option suppresses the final linear pass along
the part surface.

Choose Cutting.

Choose Settings next to Ramping.

Turn the Omit Last Pass option on.

OK to accept the ramping parameters.

Choose OK to accept the Cutting dialog.
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Generate and Verify the tool path.

Notice that the surface is not flat, but irregular.

OK to complete the operation and save the part.
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Activity: Custom Boundary Data

You can edit part boundary and member parameters for individual operations
in cases where the parameters must differ from those defined at the geometry
group level. These parameters include custom stock, cut feed rate, and
machine control events.

Step 1: Continue to use the ***_ramp_mfg_1 part.

Step 2: Verify the part boundary.

You will verify that the part boundary has been defined in the
PART geometry parent group.

Display the Geometry View of the Operation Navigator and
expand the objects.

Highlight the TURN_WORKPIECE geometry group in the
Operation Navigator and MB3→Object→Display .

The part and Blank boundaries display.
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Step 3: Edit boundary parameters.

You will see how the part boundary parameters can be edited from
within the operation.

Double-click ROUGH_OD to edit the operation.

Choose the More tab.

Choose Edit under Part Boundary.

The Part Boundary dialog displays allowing you to apply Stock
and Cut Feed Rate to the entire boundary, but only for the
current operation. The Stock you apply here overrides the
Custom Boundary Data Offset specified in the geometry group.

Turn the Stock option on and key in 0.300 in the Stock field.

Step 4: Edit member parameters.

You will see how the member parameters can be edited from
within the operation.

Choose Edit in the Part Boundary dialog.

The Edit Member dialog displays allowing you to apply Stock,
Cut Feed Rate, and machine control events to individual
boundary members. The Stock you specify here overrides the
Custom Member Data Offset specified in the geometry group.

Choose OK twice to return to the ROUGH_TURN_OD dialog.
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Step 5: Generate the tool path.

You will generate the tool path and see how the 0.300 stock has
been applied to the part boundary.

Generate and Verify the tool path as you did before.

The 0.300 stock is applied to the entire part boundary.

OK to complete the operation.

Step 6: Create a new operation.

You will create a new roughing operation to see how the part
boundary stock you specified earlier does not apply to this
operation.

Choose the Create Operation icon.

Choose the ROUGH_TURN_OD icon from the Create Operation
dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....TURN_WORKPIECE

• Use Tool..........OD_80_L

• Use Method......LATHE_ROUGH

OK to create the operation.

OK to complete the operation.
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Step 7: Generate the tool paths.

You will generate the tool paths for the entire program and see
how the final tool path removes the stock you specified in the first
operation.

In the Program Order View of the Operation Navigator, choose
PROGRAM and MB3→Generate.

OK to generate each of the three tool paths.

With PROGRAM still highlighted in the Operation Navigator,

choose Verify Toolpath in the toolbar

Turn the 2D Material Removal option on and Play.

Notice that the last tool path removes the part boundary stock
you specified in the ROUGH_OD operation.

OK to complete the operation.

Save and close the part.
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Summary
In this lesson, you learned how to create a roughing operation to cut the
OD of the part.

In this lesson you:

• Created roughing operations.

• Used several different roughing Cut Patterns.

• Removed and added a cleanup pass to an operation.

• Created an additional pass (spring pass) and adjust the profiling options
for that pass.

• Added a Local Return and post commands that were applied to a spring
pass.

• Applied Single and Multiple Ramping Cut Strategies.

• Edited Part Boundary parameters from within an operation.
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Lesson

8 Roughing Operations – ID Work

Purpose

This lesson is designed to teach you how to create roughing operations to
remove ID material. These operations are similar to OD roughing operations.
This lesson will also allow you to use some of the options that you have used
previously in a little different context.

Objective

Upon completion of this lesson, you will be able to:

• Create a roughing operation to remove material from the part ID.

• Use Containment to limit the cut area.

• Use the different Reversal Mode options to remove material from part
reversals.
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Roughing Operations for ID Work
ROUGH_BORE_ID operation subtypes have the same options available as
ROUGH_TURN_OD operation subtypes.
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Level Angle/Step Angle

In Rough Turn operations, the Level Angle (Zig and Zig-Zag cuts) and Step
Angle (Plunge cuts) options (1) define the angle at which the rough cuts
are made. They are accompanied by a visual indicator (2) that graphically
displays the cut angle. The cut angle is measured counterclockwise from
the spindle centerline.

The Forward/Backward direction arrows (3) determine the cut direction along
the cut angle. The Forward Direction arrow cuts in the direction indicated by
the Level Angle visual indicator. The Backward Direction arrow cuts in the
opposite direction indicated by the Level Angle visual indicator.

There are two methods of determining the cut angle:

• Specifying an existing line using the selection ball

• Entering a value

When you select a line to determine the cut angle, the angle is based on the
location of the cursor relative to the line’s midpoint.

In the following activities you will create a ROUGH_BORE_ID operation to
remove most of the ID material. You will use several Reversal Mode options
and examine the tool path results.
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Activity: Roughing the ID

In this activity, you are going to create two operations to remove material on
the ID of the part. You will limit the tool path using Containment, observe
how the system automatically determines which of several cut regions to use,
and learn how to manually specify the desired cut region.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_reducer_mfg_1 part.

Save the part as ***_reducer_mfg_1, where *** represents
your initials.

The cross section geometry has been predefined for this
operation.

Choose Start→Manufacturing.
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Step 2: Define the parent groups for the first ID operation.

Choose the Create Operation icon.

Be sure the Type option is set to Turning.

Choose the ROUGH_BORE_ID icon.

The Parent Groups for this program have been predefined for
you.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........ID_80_L

• Use Method......LATHE_ROUGH

Choose OK.

The ROUGH_BORE_ID dialog is displayed.

Choose the Groups tab.

Choose the Geometry button and then choose Display.
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Step 3: Display the cut region.

It is always a good practice to display the cut region before
generating a path. You will then see what the tool will cut.

Choose the Main tab.

In the Cut Regions area, choose Display.

Step 4: Limit the area the tool will cut.

The back portion of the part will be cut in a different setup. You
are going to add containment to restrict the cut region to the area
indicated below.

Choose Containment from the Cut Regions section of the dialog.

The Geometry Containment dialog is displayed. You are going
to specify an axial containment for this operation.

Check the Trim option next to Axial 1.

Choose the Axial 1 button.

Next to the Offset label, change the option to Rectangular.
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Select the end of the horizontal line to define the containment
position at the as shown below.

You are going to add an .100 offset to the axial containment.

Key in –.100 in the Delta-XC field and choose OK until you
return to the ROUGH_BORE_ID dialog.

Step 5: Avoid cutting the reversal.

Change the Reversal Mode option to Omit.

Step 6: Define the avoidance geometry.

Define a From point and a Motion to Return Point at the
approximate screen position shown below.

Set the Motion Type to Direct.
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Step 7: Generate the tool path.

Choose the Generate icon.

The tool path is generated. The tool cuts the ID and the axial
trim you defined. The tool also omits the reversal.

Choose OK to complete the operation.

Step 8: Save and close the part.
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Reversal Mode
The Reversal Mode determines which reversal of a cut region will be cut first.

• As Level completes cutting at one level within a reversal before moving to
the next reversal within a cut region.

• Inverse reverses the cut order.

• Closest cuts the reversal that is the closest to the current tool position.

• Cut Later completes cutting the first reversal it comes to then moves to
the next reversal.

• Omit does not cut the reversals.
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Activity: Roughing the ID – Reversals

You are going to examine the different reversal mode options. Reversal
Mode determines the sequence in which the reversals of a cut region (i.e.
the valleys of the part boundary found in this cut region) are addressed for
material removal.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_bearing_sleeve_mfg_1 part.

Save the part as ***_bearing_sleeve_mfg_1, where ***
represents your initials.

Step 2: Examine the As Level Reversal Mode.

The As Level Reversal Mode performs each rough cut at maximum
reach into the reversal. As soon as a cut level is reached which
leads into lower reversals, the system will continue to cut the
reversal which comes next as seen in the direction of the level
angle.

Display the Program Order view and expand the T5678_B
parent group.

Double-click ROUGH_BORE_ID to edit the operation.

Notice that the Reversal Mode is set to As Level.
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Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose the Play.

Note the order (1, 2) in which the reversals are cut.

OK to complete the tool path visualization.
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Step 3: Examine the Inverse Reversal Mode.

With an Inverse Reversal Mode, the reversals are cut in a pattern
opposite to the As Level Mode. In other words, the system will cut
the last reversal first and work backwards to the first reversal.

Set the Reversal Mode option to Inverse.

Generate the tool path.

Verify the tool path as you did before.

Note the order (1, 2) in which the reversals are cut.

OK to complete the tool path visualization.
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Step 4: Examine the Omit Reversal Mode.

The Omit option does not cut the reversals.

Change the Reversal Mode to Omit.

Generate the tool path.

Verify the tool path as you did before.

OK to complete the tool path visualization.

Step 5: Examine the Closest Reversal Mode.

The Closest option is especially useful in combination with the
zig-zag cut strategy, as the system will always choose to next cut
that reversal which is closest to the current tool position. With a
particularly complicated part boundary, this can save considerable
machining time as tool travel is reduced.

Change the reversal Mode to Closest.

Change the cut type to Linear Zig-Zag.

Generate the tool path.
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Verify the tool path as you did before.

Note the order (1, 2) in which the reversals are cut.

The reversal on the right is cut first because it is the first
reversal the tool encounters as it cuts along the OD from right
to left (zig).

OK to complete the tool path visualization.

Next, you will change the maximum cut depth.

Key in 0.1500 in the Maximum field. This will cause the tool to
cut along the OD as it zags from left to right (zag).

Generate the tool path.

Verify the tool path as you did before.

Note the order (1, 2) in which the reversals are cut.

The reversal on the left is cut first because it is the first
reversal the tool encounters as it cuts along the OD from right
to left (zag).

OK to complete the tool path visualization.

OK to complete the operation.

Step 6: Save and close the part.
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Summary
In this lesson, you learned how to create roughing operations that remove
ID material. You also explored the various reversal modes and observed how
each mode affects the order in which reversals are cut.
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Lesson

9 Finish Operations OD and
ID Work

Purpose

The Finish operation type is used to remove remaining material after
roughing. Like roughing operations, finishing operations use the in-process
workpiece to track the remaining material on the part.

Objective

Upon completion of this lesson, you will be able to:

• Create a Finish operation to cut the part OD.

• Create a Finish operation to cut the part ID.

• Use the Corner Control options to finish the convex corners.

• Use the Fillet options to finish the concave corners.
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Creating Finishing Operations
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The FINISH_TURN options
These options allow you to create finish passes, including spring passes.
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Finish Cut Patterns
The cut patterns found on the Finish dialog are the same cut patterns
available for Profile passes on the Rough dialog.

1. Finish Diameters Only creates finish cuts on diameters only.

2. Finish Faces Only creates finish cuts on faces only.

3. Finish Diameter First, then Faces creates finish cuts on all of the
diameters, then creates finish cuts on the faces.

4. Finish Faces First, then Diameters creates finish cuts on all of the faces,
then creates finish cuts on the diameters.

5. Towards Corners creates finish cuts towards the corners. This is
accomplished with two cut moves. The retract move applied in this cut
pattern is an automatic retract.

6. Into Corners creates finish cuts into the corners. This is accomplished
with two cut moves. The engage and retract moves share the same angle
value which is computed automatically.

7. Down Only create finish cuts that always cut towards the bottom of the
groove.

8. Finish All creates finish cuts that contour the boundary in a contiguous
pass.
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Spring Pass
The Spring Passes option (1) allows more than one finish pass.

Alternate

The Alternate option (2) alternates finish spring passes in a Zig Zag cut
pattern.

Direction

The Direction arrows (3) invert the cutting direction for finishing and spring
passes with respect to the boundary direction.
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Activity: Creating a Finish OD Operation

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_bearing_sleeve_mfg_2 part.

Save the part as ***_bearing_sleeve_mfg_2, where ***
represents your initials.

Choose Start→Manufacturing.

Step 2: Examine the rough tool path.

In the Operation Navigator, double-click ROUGH_TURN_OD_1
to edit the operation.

Choose Display in the Cut Regions area.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.
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Choose Play.

The tool removes most of the material in the reversal. You
are going to create an OD Finish operation to remove the
remaining material.

OK to complete the tool path visualization.

Cancel the operation.

Step 3: Create a finish operation to cut the OD.

Define the Parent Groups for this operation.

Choose the Create Operation icon.

Choose the FINISH_TURN_OD icon from the Create Operation

Dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........OD_55_L

• Use Method......LATHE_FINISH

Choose OK.

The FINISH_TURN_OD dialog is displayed.

Choose the Groups tab, the Geometry button, and then
Display.

Choose the Main tab.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 9-7



9

Finish Operations OD and ID Work

Step 4: Generate the tool path and examine the results.

Set the Tool Display to 2-D, and Generate the tool path.

The tool does not cut the entire OD. Although the cut type is
set to Finish All, the tool stops before the left reversal.

Step 5: Turn on Machine all Regions

You will activate the Machine all Regions option to finish the
outside diameter in a single operation.

Choose Cutting.

Turn the Machine all Regions option on.

OK the Cutting dialog.

Generate the tool path.

The tool now cuts the entire outside diameter, including the
material to the left of the reversal area. However, the tool proceeds
too far into the blank, where it could collide with the chuck.
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Step 6: Create trim points.

Trim points allow you to constrain the cut region so that you can
be very specific about the areas you wish to cut.

Choose Containment under Cut Regions.

Turn on Trim Point 1 and choose Select.

Trim points should be defined on the part boundary. If you
define a point slightly off the boundary, the point projects to the
part boundary at a minimum distance.

Select the end of the horizontal line near the front of the part.

The point is labeled TP 1.

Turn on Trim Point 2 and choose Select.
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Select the end of the horizontal line near the back of the part.

The point is labeled TP 2.

Choose OK to accept the trim points.

Step 7: Generate the tool path and examine the results.

Generate the tool path.

Zoom in on the trim points.

Notice that the tool cuts a short distance before the first trim
point and a short distance after the second trim point.
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Because trim points are associative to the geometry from which
they were created, the tool cuts along the associated geometry as
it approaches the first trim point and continues cutting along the
associated geometry after it passes the second trim point until it
cuts through the in-process workpiece.

You can control the distance the tool cuts before the first trim point
and after the second trim point.

Step 8: Retracting directly from the trim point.

You will eliminate the unwanted cutting move that occurs after the
second trim point.

Choose Engage/Retract.

Choose the Retract tab.

Turn on the Direct retract from trim point option.

When Extend Distance is set to 0.0000, the cutting move to the
second trim point is completely eliminated. Entering a value
for Extend Distance determines the length of the cutting move
following the trim point.

OK the Engage/Retract dialog.

Step 9: Generate the tool path and examine the results.

Generate the tool path.

The tool now retracts directly from the second trim point.

Next, you will define Avoidance geometry.
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Step 10: Define the avoidance geometry.

There are no Start and Return points defined. You will define both
for this operation.

Define a Motion to Start Point and Motion to Return Point
as shown.

Set the Motion Type to Axial→Radial for both points.

Step 11: Generate the tool path.

Choose the Generate icon.

The tool cuts to the finish dimension of the part.

Step 12: Save the part.
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Activity: Creating a Finish ID Operation

In this activity, you are going to create an ID Turning Operation with limited
assistance.

Step 1: Create a new operation using the finish bore subtype.

Continue to use the ***_bearing_sleeve_2_mfg part.

Choose the Create Operation icon.

Choose the FINISH_BORE_ID icon.

Step 2: Define the Parent Groups.

Program..........PROGRAM

Use Geometry....PART

Use Tool..........ID_55_L

Use Method......LATHE_FINISH

Step 3: Define the following options for this operation:

Start and Return Point

Omit Reversals on

Step 4: Generate the tool path.

Step 5: Save and close the part.
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Corner Control
The Corner Control option allows you to control tool path when the tool
cuts boundary corners. You can remove a specified amount of material or
none at all.
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Type Options

Roll Around Corners– keeps the tool in constant contact with the material by
inserting an arc into the tool path to keep the tool tangent to the boundary as
it moves around the corner.

Clear Corners – causes the tool to leave the Part Boundary at the corners.

Round Corners– adds a radius to the corner. You enter the desired radius
value.

Break Corners– allows chamfering of corners. The tool moves the specified
distance in a straight line across the corner.

Shallow Corners

This option allows you to control tool motion when convex corners has an
included angle larger than 180 degrees.
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Activity: Using Corner Control

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_fin_od_mfg_1 part.

Save the part as ***_fin_od_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Step 2: Edit an existing operation.

Double-click FINISH_TURN_OD in the Operation Navigator to
edit the operation.

Choose Replay from the FINISH_TURN_OD dialog.

Step 3: Examine the Clear Normal Corners option.

Turn the Tool Display option off and Replay the tool path.

The tool rounds the corners. This is the default setting for the
Corner Control option.

Choose the Corner button.
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In the Normal Corners area, change the Type to Clear, and
then choose OK.

Generate the tool path.

The tool clears the edge of the Normal convex corners (1). The
tool still rolls around the Shallow Corner (2).

Step 4: Examine the Round Normal Corners option.

Generally, you have to round the sharp corners and push the burr
in front of the tool.

Again, choose the Corner button.

In the Normal Corners area, change the Type to Round.

Key in 0.0500 in the Break Dist/Rad field.

Choose OK.

The FINISH_TURN_OD dialog is displayed.
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Generate the tool path.

The tool path is generated. The tool rounds the corners using a
0.0500 radius.

Step 5: Verify the tool path.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose Play.

You can clearly see that the tool rounds the corner with a
0.0500 radius.

OK to complete the tool path visualization.

OK to complete the operation.

Step 6: Save and close the part.
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Fillets
The Fillets option determines when fillets will be cut. This works in
conjunction with the cut patterns Diameters First, then Faces and Faces
First, and then Diameters options.

Add into Faces - cuts the fillets when cutting the adjacent face. For example,
if you selected Diameters First, Then Faces as the cut type, the fillets are
cut when the adjacent faces are cut.

Add into Diameters - cuts the fillets when cutting the adjacent diameters.
For example, if you selected Diameters First, Then Faces as the cut type, the
fillets are cut when the adjacent diameters are cut rather than the face.

Split - cuts half of the fillet when cutting the adjacent face and the other half
of the fillet when cutting the adjacent diameter.

Omit - does not cut the fillets at all.
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The following illustrations show the fillet options for "Diameters then Faces"
with auto circular engage and auto linear retract.
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Activity: Cutting Fillets

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_fillets_mfg_1 part.

Save the part as ***_fillets_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Step 2: Observe the Add into Faces option.

Double-click FINISH_OD in the Operation Navigator to edit
the operation.

Notice the cut type is set to Diameters First, Then Faces
and the Fillets option is set to Add into Faces.

Generate the tool path.

Choose Verify at the bottom of the dialog.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.
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Choose Play.

The fillets are cut when the adjacent faces are cut because the
cut type is set to Diameters First, Then Faces and the Fillets
option is set to Add into Faces.

OK to complete the tool path visualization.

Step 3: Observe the Add into Diameters option.

Set the Fillets option to Add into Diameters.

Generate the tool path.

Verify the tool path as you did before.

The fillets are cut when the adjacent diameters are cut because
the cut type is set to Diameters First, Then Faces and the
Fillets option is set to Add into Diameters.

OK to complete the tool path visualization.
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Step 4: Observe the Split option.

Set the Fillets option to Split.

Generate the tool path.

Verify the tool path as you did before.

Half of the fillet is cut when cutting the adjacent face and the
other half of the fillet is cut when cutting the adjacent diameter.

OK to complete the tool path visualization.

OK to complete the operation.

Step 5: Save and close the part.
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Summary
In this lesson, you created Finish OD and ID operations, specified trim points
and explored various corner control and fillet options.
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10 Grooving

Purpose

Grooving is a roughing operation that is used to remove material in grooves
or undercut areas.

Objective

Upon completion of this lesson, you will be able to:

• Identify the different groove methods.

• Identify the options unique to grooving.

• Specify Stepover and Cut Depth.

• Manually specify the cut region.

• Create GROOVE_OD, GROOVE_ID, and GROOVE_FACE operations.
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Grooving Operation Types

1. GROOVE_OD

2. GROOVE_ID

3. GROOVE_FACE

The Groove Options

The Groove options located on the Groove OD, Groove ID, and Groove Face
dialogs are identical, with the exception of the Step Angle. The Step Angle
determines the angle at which the tool will cut.
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Cut Patterns

There are four plunging cut patterns.

1. Plunge Zig are typical plunge cuts in one direction within the cut region.

2. Plunge Alternate cuts with alternating stepover direction. Each
subsequent plunge is applied to the opposite side of the first plunge.

3. Plunge Zig-Zag causes the tool to plunge to a specified depth of cut, then
perform a series of plunge cuts to remove all the material at that depth.
It then plunges again to the cut depth, and removes all material at that
level. These series of cuts are performed back and forth in a zig zag
pattern until the bottom of the groove is reached.

4. Plunge Castling is a unique plunge pattern which leaves pillars between
plunges and then returns to cut the pillars. The result is an even cutting
pressure on the tool.
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There are six cut patterns that cut by level.

1. Linear Zig creates linear cuts by level in one direction within the cut
region.

2. Ramping Zig is for inclined/declined cuts in alternating directions.

3. Contour Zig creates cuts by level that follow the contour of the groove in
one direction within the cut region.

4. Linear Zig-Zag creates linear cuts by level in both directions within the
cut region.

5. Ramping Zig-Zag is for inclined/declined cuts in alternating directions.

6. Contour Zig-Zag creates cuts by level that follow the contour of the groove
in both directions within the cut region.

Stepover

The Stepover determines the amount that the tool moves over between
plunges. You have three Stepover methods.
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The Stepover options are defined in the table below.

Constant Specifies the maximum depth of cut to be made on each
roughing pass. This value is used as many times as
possible and then remaining material is cut in one pass.

Variable Max. Determines the cut regions, cuts at the maximum value
as many times as possible and then cuts the remaining
material in one pass if it is greater than or equal to the
minimum within each separate region.

Variable Avg. Calculates the minimum number of passes required
based on never cutting more than the maximum or less
than the minimum for each region.

The Step value is based on a percentage of the tool width or a specified value
in inches.

First Plunge

The first plunge of the grooving tool path is automatically determined. The
option, First Plunge, allows you to reposition the first plunge by defining an
axial or radial position or by defining a point.
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Chip Control

The typical plunge cut is one non-interrupted cutting motion. Chip Control
allows you to interrupt each plunge cut to clear the chips from the groove.
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Activity: Creating an OD Groove Operation
In this activity, you are going to create a simple outside diameter grooving
operation.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_grv_all_mfg_1 part.

Save the part as ***_grv_all_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Step 2: Create an outside diameter grooving operation.

Choose the Create Operation icon.

Set the Type option to turning.

Choose the GROOVE_OD icon from the Create Operation

dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........GROOVE_OD

• Use Method......LATHE_GROOVE

Choose OK.

The GROOVE_OD dialog is displayed.
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Step 3: Verify the geometry.

Next you will verify the part and blank geometry.

Choose the Groups tab at the top of the dialog, choose the
Geometry button, then choose Display.

Both the Part and the Blank geometry have been defined in
parent groups.

Choose the Main tab at the top of the dialog.

Step 4: Specify the cut region.

A turning operation can only cut a single region. In cases like this
one where there is more than one cut region, you can manually
select which region to cut.

Choose Containment under Cut Regions.

Turn the Select Manually option on and then choose Select
under Cut Regions.
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Use Cursor Location to select near the desired cut region as
illustrated below.

Choose OK to accept the cut region.

Step 5: Display the cut regions.

Choose Display under Cut Regions.

Notice that there are multiple cut regions. The operation will
be performed on the region closest to the RSP point.

Step 6: Change the cut type.

You will plunge using alternating stepover directions.

Choose the Plunge Alternate icon.

Turn the Cleanup option off.

Turn the Additional Profiling option on.

Step 7: Set Engage Parameters
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Choose Engage / Retract.

On the Engage tab, make sure Profiling is selected.

Choose Vector.

In the Vector (Y) field, enter -.06.

OK to accept the Engage / Retract parameters

Step 8: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose Play.

OK to complete the tool path visualization.

Step 9: Define avoidance parameters.

You will define a Start Point, a Return Point.

Choose Avoidance.
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Define a Motion to Start Point and Motion to Return Point
as shown.

Choose Radial→Axial for the Motion Type for both points.

Choose OK to accept the Avoidance Parameters.

Step 10: Generate the tool path.

Choose the Generate icon.

Choose OK to complete the operation.

Save the part.
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Step Angle
The Step Angle allows you to create plunge cuts at any angle. Plunge cuts
are perpendicular to the step angle line and are generated in sequence in the
direction of the Step Angle line, indicated in the dialog by a red arrow.
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Activity: Creating an Angled OD Groove Operation

In this activity, you are going to create an outside diameter operation that
cuts an angled groove using plunge cuts.

Step 1: Continue to use the ***tmp_grv_all_mfg_1 part.

Step 2: Create an outside diameter grooving operation.

Choose the Create Operation icon.

Choose the GROOVE_OD icon from the Create Operation

dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........GRV_45_DEG

• Use Method......LATHE_GROOVE

Key in GRV_ANGLE for the name.

Choose OK.
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Step 3: Change the step angle.

You will change the Step Angle so that the plunges cut directly
into the groove.

Key in 315 next to Step Angle.

The angle is measured counter clockwise from the centerline
and defines the orientation and the direction of progress for the
plunge cuts. Notice that the arrow indicates the cut angle for
visual reference.

Change the Direction to Backward.

Direction (backward)

Step 4: Define avoidance parameters.

Choose Avoidance.

Define a Motion to Start Point and Motion to Return Point
as shown.

Choose OK to accept the Avoidance Parameters.

The system will use the cut region closest to the Start Point.
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Step 5: Change the cut type.

You will plunge cut using alternating stepover directions.

Choose the Plunge Alternate icon.

Step 6: Create an additional profiling pass.

An additional profile pass allows you to perform a cleanup of the
part surface after rough cuts have been made.

Turn the Cleanup option off.

Turn the Additional Profiling option on.

Step 7: Set the Engage and Retract parameters

Choose Engage / Retract.

On the Engage tab, make sureProfiling is selected.

Choose Vector.

Key in -.06 in the Vector (X) and Vector (Y) fields.

Choose the Retract tab and make sure Profiling is selected.

Choose Vector.

Key in .1 in the Vector (X) and Vector (Y) fields.

OK to accept the Engage / Retract parameters
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Step 8: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose Play.

OK to complete the tool path visualization.

Choose OK to complete the operation.

Save the part.
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Activity: Creating a Face Groove Operation

In this activity, you are going to create an operation that cuts a groove into
the front face of the part using a linear zig-zag cut motion.

Step 1: Continue to use the part file ***_grv_all_mfg_1.prt.

Step 2: Create a face groove operation.

Choose the Create Operation icon.

Choose the GROOVE_FACE icon from the Create Operation

dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........RTJ_GROOVE_TOOL

• Use Method......LATHE_GROOVE

Choose OK.

10-18 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



10

Grooving

Step 3: Display the cut regions.

Choose Display under Cut Regions.

Notice the two cut regions at the lower right corner of the part.

You will allow the system to automatically determine which cut
region to use based on the Start Point position.

Step 4: Change the cut type.

In this operation, you will rough out the groove one level at a time
using a zig-zag motion.

Choose the Ramping Zig-Zag icon.

Step 5: Specify the cut depth.

The Cut Depth determines the depth of each zig-zag cutting pass.

Be sure Constant is specified as the Cut Depth.

Key in 0.100 in the Maximum field.

Step 6: Create an additional profiling pass.

An additional profile pass allows you to perform a cleanup of the
part surface after rough cuts have been made.

Turn the Cleanup option off.

Turn the Additional Profiling option on.

Step 7: Define avoidance parameters.

You will define a Start Point and Return Point.

Choose Avoidance.
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Define a Start and Return Point as shown using Axial→Radial
for the motion type.

Choose OK to accept the Avoidance Parameters.

Step 8: Define the ramping mode.

Choose Cutting and select the Settings button next to Ramping.

Set the Ramping Mode to Ramp In First.

OK to accept the ramping.

Step 9: Set Engage parameters.

Choose Engage / Retract.

On the Engage tab, make sure Profiling is selected.

Choose Vector.

Key in -.06 in the Vector (X) field.

OK to accept the Engage / Retract parameters

Step 10: Generate and verify the tool path.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.
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Choose Play.

OK to complete the tool path visualization.

Choose OK to complete the operation.

Save the part.
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Activity: Creating an ID Groove Operation

In this activity, you are going to create a simple outside diameter grooving
operation.

Step 1: Continue to use the ***_grv_all_mfg_1 part.

Step 2: Create an inside diameter grooving operation.

Choose the Create Operation icon.

Choose the GROOVE_ID icon from the Create Operation dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........ID_GRV_TOOL

• Use Method......LATHE_GROOVE

Choose OK.
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Step 3: Display the cut regions.

Choose Display under Cut Regions.

Notice that there are two cut regions.

You will allow the system to automatically determine which cut
region to use based on the Start Point position.

Step 4: Change the cut type.

You will plunge using alternating stepover directions.

Choose the Plunge Alternate icon.

Step 5: Specify the stepover.

When plunging, the stepover determines the maximum amount of
material that can be removed on each cutting pass. This value is
used as many times as possible and then any remaining material
is cut in one pass.

Choose Constant for the Stepover and key in 50 for the Step %.

Turn the Cleanup option off.

Turn the Additional Profiling option on.
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Step 6: Define avoidance parameters.

You will define a Start Point, a Return Point and motions that
prevent the tool from colliding with the part.

Choose Avoidance.

Define a Start and Return Point as shown with a Radial→Axial
motion type.

Choose OK to accept the Avoidance Parameters.

Step 7: Set the Engage and Retract parameters

Choose Engage / Retract.

On the Engage tab, make sureProfiling is selected.

Choose Vector.

Key in .1 in the Vector (Y) field.

Choose the Retract tab and make sure Profiling is selected.

Choose Vector.

Key in .06 in the Vector (X) field.

OK to accept the Engage / Retract parameters

Step 8: Generate the tool path.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

10-24 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



10

Grooving

Slow the Animation Speed down to 1.

Choose Play.

OK to complete the tool path visualization.

Choose OK to complete the operation.

Save and close the part.
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Summary
Grooving removes material in grooves or undercut areas.

In this lesson you:

• Learned how to create outside diameter, inside diameter, and face groove
operations.

• Learned the different cut patterns.

• Learned about the unique options in Groove.

• Learned to specify Stepover and Cut Depth.

• Learned to manually specify the cut region.
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11 Teach Mode

Purpose

Teach Mode allows you to define cutting and non-cutting moves individually
and in sequence. It is useful for finishing in areas that require a high degree
of cutter control.

Objective

Upon completion of this lesson, you will be able to:

• Identify the different types of suboperations.

• Determine the sequence of the suboperations.

• Identify the Drive geometry.

• Create a Teach Mode operation that cut faces and diameters.
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The Teach Mode options
Teach Mode allows you to create a sequence of suboperations that define
individual cutting and non-cutting motions.
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Suboperation Types

1. Linear Rapid

2. Linear Feed

3. Engage Setting

4. Retract Setting

5. Follow Curve Motion

6. Machine Control Events

Linear Rapid

Linear Rapid allows you to define a point from which the tool will move to the
engage position and the motion it will use to get there.

The Motion Axis options allow you to define various radial and axial
movements for the rapid motion.
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The End Point options allow you to define a point to which the tool will rapid.

The Initial Retract options allow you to specify an additional retract motion
from last tool position which is output before the Rapid motion. The retract
motion can be specified by its angle to the positive rotation axis and the
motion length. These values can be inferred from the selected tool or can be
specified by the selection of Automatic or Manual. It is disabled by selecting
the option menu entry None.

Linear Feed

Linear Feed defines a motion from the current tool position to a new position
in Cut Mode at a specified feed rate. You can apply different feed rates to
different cut motions.
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Engage and Retract Setting

The Engage Setting dialog is used to specify a modal engage move that is
used by the subsequent Follow Curve suboperations.

Extend Drive Curve is used to create overlapping tool paths on the drive
curve starts/ends within the In-process Workpiece. This will allow the tool to
engage TO rather than INTO the blank.

You can manually or automatically extend the drive curve at the start and
end by distance (manual) or to the blank geometry (automatic).

Both the Engage/Retract settings need to be set prior to the motion
suboperation(s).
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Follow Curve Motion

Follow Curve allows you to define the drive geometry along selected curve
segments and to specify starting and stopping points along those segments.

The Point start/stop positioning method gives you precise control of the
starting/stopping positions. You can also specify geometry that defines engage
and retract positions.

Option No Previous Follow
Curve Previous Follow Curve

Previous Check Curve Uses check geometry as
stop position method

Previous Drive Curve Uses same geometry as
Previous Follow Curve

New Drive Curve Selects new curve to
machine
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Activity: Creating a Teach Mode Operation

In this activity, you are going to create a Teach Mode operation that finishes a
portion of the outside diameter of the part.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_teach_mfg_1 part.

Save the part as ***_teach_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Step 2: Begin Creating the Operation.

Choose the Create Operation icon.

Set the Type option to turning.

Choose the TEACH_MODE icon from the Create Operation

dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........OD_35_L

• Use Method......LATHE_FINISH

Choose OK.
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Step 3: Define the Initial Rapid Motion

You will begin the sequence of cutting and non-cutting moves with
a rapid motion to the engage position.

Choose Linear Rapid.

In the Rapid Motion dialog, make sure the Point option is
turned on and choose Select.

Indicate the point at the approximate screen position
illustrated below.

OK to accept the rapid motion.

The Rapid Motion suboperation is now listed in the Teach
Mode dialog.

The end point position is displayed in the graphics window
and is labeled EP. This is the position from which the tool will
move to the engage.

11-8 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



11

Teach Mode

Step 4: Define the Engage Suboperation.

You will now define an engage suboperation. Once defined, the
engage suboperation will apply to every subsequent cutting move
in the operation until a different engage suboperation is specified.

Choose Engage Setting.

Choose Angle/Distance.

Key in 270 in the Angle field.

Key in 0.100 in the Distance field.

These parameters will engage the tool in a downward direction.

OK to complete the Engage Setting suboperation.

The Engage Setting suboperation is now listed in the Teach
Mode dialog.

Step 5: Define the Retract Suboperation.

You will now define a retract suboperation. Once defined, the
retract suboperation will apply to every subsequent cutting move
in the operation until a different retract suboperation is specified.

Choose Retract Setting.

Choose Auto Circular.

This option specifies that the tool will retract in a circular
motion at the end of each cutting move.
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OK to complete the Retract Setting suboperation.

The Retract Setting suboperation is now listed in the Teach
Mode dialog.

Step 6: Define the Follow Curve Motion.

Next, you will define the Follow Curve Motion. You will define the
drive geometry and the parameters that determine how the tool
will cut along the drive geometry.

Choose Follow Curve Motion.

You will specify a boundary along which the tool will cut.

Choose New Drive Curve and Select.

Select the curve toward the top end as illustrated below.

The end you select defines the direction of the boundary. The
direction of the boundary is used to establish the forward cut
direction. If you had chosen the bottom of the curve, you could
reverse the cut direction by choosing the Backward arrow.

Set the Material Side option to Right.

OK to accept the drive geometry.
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Choose Display to display the boundary.

OK to complete the Follow Curve Motion suboperation.

The Follow Curve Motion suboperation is now listed in the
Teach Mode dialog.
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Step 7: Generate the tool path.

You will generate the tool path defined so far by the Rapid, Engage,
Retract, and Follow Curve Motion suboperations.

Choose the Generate icon.

Turn the Tool Display option off and generate the tool path
again so you can see the motions clearly.

1. Rapid

2. Engage

3. Follow Curve Motion

4. Retract
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Step 8: Defining a Rapid Motion

Next, you will define the end point of another linear rapid motion.
This will position the tool for the next engage, cut, and retract
sequence.

Choose Linear Rapid.

In the Rapid Motion dialog, make sure the Point option is
turned on and choose Select.

Indicate the point at the approximate screen position
illustrated below.

OK to accept the rapid motion.

The Rapid Motion suboperation is now listed in the Teach
Mode dialog.

The end point position is displayed in the graphics window
and is labeled EP. This is the position from which the tool will
move to the engage.
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Step 9: Define the Engage suboperation.

The next sequence of cutting moves will require a different engage
setting.

Choose Engage Setting.

Choose Auto Circular.

OK to complete the Engage Setting suboperation.

The Engage Setting suboperation is now listed in the
Teach Mode dialog. This engage setting will apply to every
subsequent cutting move in the operation until a different
engage setting is specified.

Step 10: Define the Follow Curve Motion.

Next, you will define the next Follow Curve Motion. You will define
the drive geometry and the parameters that determine how the
tool will cut along the drive geometry.

Choose Follow Curve Motion.

You will specify a boundary along which the tool will cut.

Choose New Drive Curve and Select.
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Select the four curves in the order illustrated below.

The order in which you select the curves defines the direction
of the boundary. The direction of the boundary is used to
establish the forward cut direction.

Leave the Material Side option set to Left.

OK to accept the drive geometry.

Choose Display to display the boundary.

OK to complete the Follow Curve Motion suboperation.

The Follow Curve Motion suboperation is now listed in the
Teach Mode dialog.

Step 11: Generate the tool path.

Set the Tool Display option to 2–D.
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Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose Play.

OK to complete the tool path visualization.
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Step 12: Copying an Engage Setting.

The next Follow Curve Motion will require an Engage Setting
similar to the one defined for the first Follow Curve Motion. You
will copy and paste the first Engage Setting and then make a
minor edit.

Choose 2: Engage Setting in the list box and choose the Copy

icon.

Choose 7: Follow Curve Motion in the list box and choose the

Paste icon.

The Engage Setting suboperation (line 8) now appears after the
selected Follow Curve Motion suboperation. This Engage Setting
will apply to the next Follow Curve Motion in the sequence.

You will edit this Engage Setting by adding an extend distance to
prevent the engage from hitting the stock.

Double-click 8: Engage Setting in the list box to edit the
suboperation.

Key in 0.050 in the Extend Distance field.

OK to accept the Engage Setting.

This extension will prevent the tool from hitting the stock on
the next diameter.
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Step 13: Define the Follow Curve Motion.

Choose Follow Curve Motion.

You will specify a boundary along which the tool will cut.

Choose New Drive Curve and Select.

Select the three curves in the order illustrated below.

The order in which you select the curves defines the direction
of the boundary. The direction of the boundary is used to
establish the forward cut direction.

Set the Material Side option to Right.

OK to accept the drive geometry.

Choose Display to display the boundary.
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OK to complete the Follow Curve Motion suboperation.

The Follow Curve Motion suboperation is now listed in the
Teach Mode dialog.

Step 14: Define a Rapid Motion

You will define the end point of a linear rapid motion.

Choose Linear Rapid.

In the Rapid Motion dialog, make sure the Point option is
turned on and choose Select.

Indicate the end point at the approximate screen position
illustrated below.

OK to accept the rapid motion.

The Rapid Motion suboperation is now listed in the Teach
Mode dialog.
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Step 15: Generate the tool path.

Choose the Generate icon.

Choose Verify.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 1.

Choose Play.

OK to complete the tool path visualization.

OK to complete the operation.

Save and close the part.
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Summary
Teach Mode allows you to create a sequence of suboperations that define
individual cutting and non-cutting motions. It is useful for finishing areas
that require a high degree of cutter control. In this lesson, you created
a Teach Mode operation that cut faces and diameters. You defined drive
geometry, avoidance moves, and applied appropriate engages and retracts.
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12 Threading Operations

Purpose

This lesson teaches you how to create OD and ID threading operations.

Objective

Upon completion of this lesson, you will be able to:

• Define the thread geometry.

• Identify the thread root.

• Identify the crest line.

• Specify the pitch.

• Define the cut increments.

• Create finish passes.

• Create chase passes.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 12-1



12

Threading Operations

Threading Operations
Threading operations can be developed to cut both straight and tapered
threads. They can be single start or multiple start threads which are either
internal, external, or face threads (such as the thread advance used in a
three-jaw chuck).
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Developing a Threading Operation

Threading operations require you to specify a crest line, a root line, and a
pitch. The crest line (1) represents the outer tip of the thread. The end you
select (2) determines the start of the thread. The root line (3) determines the
depth of the thread. The pitch (4) is the distance between corresponding
points measured from one thread to the next.

Crest Line

The Crest Line represents the outer tip of the thread.

The Start Point is the point at which the threading motion begins.

The system determines the length and angle of the thread based on the
selected line, and displays START and END at each end of the line.

Root

The Root Line determines the total depth of the thread. The total depth can
be reached using constant, variable, or percentage increments.

Pitch

The Pitch is the distance between corresponding points measured from one
thread to the next. You specify the Pitch by defining the Pitch and Lead
or by defining the Threads Per Inch.
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Pitch/Lead/Tpi

You must specify the Pitch and Lead (1) or Threads Per Inch (2).

The Number of Starts determines the Pitch and Lead as shown in the
following example of a 1/4-20 thread:

Threads Per Inch = 20

Pitch = (1 (inch) / 20) = .05

Lead = .05 x 1 (No. of Starts)

In this case, the Pitch and Lead are .050 because there is only one Start. If
there were two Starts, the Lead would be .100, or twice the Pitch.

When you choose the Specify button, the following dialog is displayed. You
can define the following options from this dialog.
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Thread Geometry

Thread Geometry defines the Start (1) and End (2) points of the thread.
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Offset/End Line

Offset/End line adjusts the start point and end point for the thread motion.
Positive Offset values increase the thread length; negative Offset values
shorten the thread length.

1. 0.1500 Start Offset

2. –.05000 End Offset

Offsets are measured along the thread angle, which is dependent upon the
method of depth specification.

Start adjusts the Start Point of the thread.

End adjusts the End Point of the thread.

Init From Tool causes the system to calculate the End Offset so that the tool
clears the thread.

End Line defines the end of the thread by selecting a line which intersects the
Crest Line.

12-6 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



12

Threading Operations

Total Depth

Total Depth determines the thread root line.

The Total Depth gives you options to establish a Root Line by using the cursor
to select a line, or by entering Depth and Angle values.

Each Increment method provides a Tolerance option which allows you to
specify the increment for the last roughing pass.

Constant - Specify a single increment value that is used throughout the
tool path. You may wish to use this method when specifying relatively few
roughing passes since tool pressure rapidly increases with each pass. The tool
moves the input distance as it cuts along the thread angle until it reaches
the start of the Finish Passes.
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In the following illustration, a constant increment of 0.0150 has been
specified. The system takes the average of the last two passes to keep them
as close as possible to the specified constant increment value.

1. Three passes at 0.0150 depth each

2. Two passes at 0.0140 depth each

Variable - Specify a set of variable increments and the number of times each
is to be repeated. This allows the greatest control over individual passes.

1. Two passes at 0.0150 depth each

2. Four passes at 0.0070 depth each

3. Remaining depth at 0.0030 per pass

If the sum of the increments does not equal the start of the Finish Passes
depth, the system repeats the last non-zero increment value until the
appropriate depth is reached. If the sum of the increments exceeds the start
of the Finish Passes depth, the system ignores the excess increments.
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Percentage - This method is particularly useful in roughing threads because
it resembles the finishing technique (even allowing you to bypass that option
and using the Chase option instead) and is easily modified to accommodate
different materials, thread pitch, RPM changes, etc.

This method allows you to specify the increment depth of each pass as a
percentage of the total roughing depth that remains at the time of the pass.
This causes the depth of each cutting pass to decrease as the tool moves deeper
into the thread. The Maximum value prevents the initial passes from cutting
too deeply. As the tool approaches the Total Depth, the increment depth can
become very small. Therefore, to control the number of passes, you must
enter a Minimum increment value so that the tool can reach the total depth.

1. 0.0100 Maximum

2. Each pass is 30% of remaining depth
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Finish Passes

You can specify a number of finish passes and increments when cutting
threads.

When you generate a thread tool path, the tool cuts to the Roughing Thread
Depth using the number of passes determined by the Increment Method and
data specified under the Total Depth option. The tool then proceeds to the
Finish Thread Depth using the number of passes determined by the Finish
Passes data you specified.
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Chase Passes

You can specify a number of spring passes to control size of thread and
minimize tool deflection using the Chase Passes option. The passes are made
at the Total Thread Depth.

You can also specify the number of OPSTOPS to be output and a local return
move.

Chase passes are always bracketed by OPSTOP, OPSKIP/ON and
OPSKIP/OFF commands.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 12-11



12

Threading Operations

Activity: OD Threading

In this activity, you will create an operation to cut an external thread.
This will include defining the necessary thread parameters, such as pitch,
Offset/End lines, crest, and root geometry.

Step 1: Open the part file, save as and enter the Manufacturing
application.

Open the tmp_thread_mfg_1 part.

Save the part as ***_thread_mfg_1, where *** represents your
initials.

Choose Start→Manufacturing.

Step 2: Define the parent groups for this operation.

Choose the Create Operation icon.

Set the Type option to turning.

Choose the THREAD_OD icon from the Create Operation

dialog.

Set the following Parent Groups:

• Program..........PROGRAM

• Use Geometry....PART

• Use Tool..........THREAD_EXT

• Use Method......THREAD_METHOD

Choose OK.
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Choose the Groups tab and display the geometry.

Refresh the graphics display.

Step 3: Define the pitch.

Choose the Main tab.

Choose Specify next to Pitch/Lead/Tpi .

Display the Defining Values options.

Choose Constant.

Key in 1/18 in the Pitch field.

OK to accept the pitch.
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Step 4: Define the crest line.

Choose the Select option under Thread Geometry.

Select the crest line near the right end as illustrated below.

The start point should appear at the right end of the selected
line.

Step 5: Define the total depth.

Choose Settings.

You will first define the Total Depth and Thread angle by
keying in values. You will then define the Total Depth by
selecting the root line.

Choose Depth & Angle.

Key in 0.0334 in the Depth field.
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Key in 180 in the Thread Angle field.

The Increment defines how the tool will cut from the crest
line to the final depth. Percentage is one of the most common
methods used to define the Increment.

Change the Increment to Percentage and choose Settings.

You must specify the Percentage and the Maximum and
Minimum values.

Key in the following values in the Percentage Increment dialog:

• Percentage = 30

• Maximum = .04

• Minimum = .005

Choose OK.

OK to accept the total depth.

Generate the tool path.

Zoom in on the start point to see the incremental cut depth.

Now you will define the Total Depth by selecting a root line.

Refresh the graphics display.

Choose Settings.
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Choose Root Line.

Choose Select.

Choose the Thread Root Line as illustrated below.

OK to accept the total depth.

The Total Depth and Thread Angle have been calculated from
the selected root line.

Step 6: Define an offset for the start of the thread.

Choose Offsets/End Line.

Key in 0.100 in the Start field.

Choose OK.
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Generate the tool path.

The start point has been offset 0.100 to the right.

Step 7: Specify a finish pass.

Choose Finish Passes.

Enter 2 passes of .002.

Choose OK to return to the THREAD_OD dialog.

Step 8: Specify a chase pass.

Choose Chase Passes.

Key in 2 in the Number of Chases field.

Choose OK to return to the THREAD_OD dialog.

Generate the tool path.

The tool path is generated with the Finish and Chase Passes.

OK to complete the operation

Save the part.
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Activity: ID Threading

In this activity, you will create an operation to cut an internal thread. This
time you will have fewer instructions.

Step 1: Continue to use the ***_thread_mfg_1 part.

Step 2: Choose the THREAD_ID icon and define the parent groups for this
operation.

Step 3: Define the parent groups.

Program..........PROGRAM

Use Geometry....PART

Use Tool..........THREAD_INT

Use Method......THREAD_METHOD

Step 4: Define the following options for this operation.

Pitch and Constant value

Crest Line

Root Line

Total Depth and Increment

Step 5: Generate the tool path.

Step 6: Edit the operation and define the following options:

Final Pass

Chase Pass

Engage and Retract

Avoidance Geometry

Step 7: Generate the tool path.

Step 8: Save and close the part.
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Summary
Threading operations can cut both straight and tapered threads. Threading
operations require you to specify a crest line, a root line, and a pitch. The crest
line represents the outer tip of the thread. The end you select determines
the start of the thread. The root line determines the depth of the thread.
The pitch is the distance between corresponding points measured from one
thread to the next.

In this lesson you:

• Selected the thread geometry.

• Defined the root and crest line of the threads.

• Specified the thread pitch.

• Defined the cut increments.

• Specified finish and chase passes.
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Lesson

13 Using Multiple Spindles

Purpose

This lesson will teach you how to use cross sectional curves to define part
geometry for parts mounted at each spindle of a multiple spindle machine.
You will also learn how to manage the in-process workpiece as it is passed
from one spindle to the next.

Objective

Upon completion of this lesson, you will be able to:

• Define part geometry for parts mounted at each spindle of a multiple
spindle machine.

• Define blank geometry at Spindle 2 by referencing the IPW generated
at Spindle 1.

• Generate the tool paths for the program and observe material removal
at both spindles.
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MCS Objects Available for Lathe Cross Sections
An in-process workpiece (IPW) can be created and referenced as it is
transferred from one spindle to another or turned around in the spindle.
When the workpiece is remounted, the IPW from the previous workspace
defines the blank geometry in the current workspace. This allows the system
to progressively remove material while passing the workpiece from one
workspace to another.

1. Spindle 1

2. Spindle 2
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Activity: Using a Multiple Spindle Setup

You are going to define part geometry at two spindles. You will then define
the blank geometry at Spindle 2 by referencing the IPW generated at Spindle
1. You will generate the tool paths for the program and see how the system
progressively removes material while passing the workpiece from one spindle
to the next.

Step 1: Examine the setup for a two spindle machine.

Open the tmp_turn_assy_1 part.

Save the part as ***_turn_assy_1, where *** represents your
initials.

Choose Start→Manufacturing.
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Display the Geometry view of the Operation Navigator and
expand the objects.

Step 2: Display the blank boundary at Spindle 1.

Double-click TURN_WORKPIECE_1 in the Operation
Navigator.

Choose the Blank icon in the TURN_BND dialog.

Choose Display.

Cancel the TURN_BND dialog.
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Step 3: Display the spindles.

Each spindle is defined in the assembly model by an MCS.

Notice the location of the MCS at the first spindle.

Double-click SPINDLE2 in the Operation Navigator to display
the second MCS.

Cancel the MCS_SPINDLE dialog.
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Step 4: View the cross section curves.

You will now change to a top view and display only the cross
section curves.

Choose Format→Layer Settings from the menu bar.

Make layers 1 and 2 Invisible.

Choose OK in the Layer Settings dialog.

In the graphic window, choose MB3→Replace View→Top.

Step 5: Define part geometry at Spindle 1.

In the Geometry View of the Operation Navigator, double-click
TURN_WORKPIECE_1 to edit the object.

With the Part icon active, choose Select.

With the Curve Boundary icon active, choose Closed under
Type. Be sure Material Side is Inside.

Choose Chaining.
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At Spindle 1, select the horizontal line at the approximate
position illustrated below (right end).

Select the angled line.

Choose OK in the Part Boundary dialog.

Choose Display.

OK the TURN_BND dialog to complete the boundary.
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Step 6: Generate the tool paths at Spindle 1.

Choose SPINDLE1 in the Operation Navigator and
MB3→Generate.

Choose OK three times in the Tool Path Generation dialog to
generate all three tool paths at Spindle 1.

Step 7: Define part geometry at Spindle 2.

In the Geometry View of the Operation Navigator, double-click
the TURN_WORKPIECE_2 object.

With the Part icon chosen, choose Select.

With the Curve Boundary icon chosen, choose Closed under
Type. Be sure Material Side is Inside.

Choose Chaining.
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At Spindle 2, select the horizontal line at the approximate
position illustrated below (right end).

Select the angled line.

Choose OK twice to complete the part boundary.

Step 8: Define blank geometry for the rough bore operation.

Blank geometry for the Rough Bore ID operation at Spindle 2
is defined by referencing the IPW generated by the previous
operations at Spindle 1.

Double-click TURN_WORKPIECE_2 in the Operation
Navigator.

Choose the Blank icon.

Choose Select.
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Choose the From Workspace icon.

To define the blank geometry for this operation
(ROUGH_BORE_ID), you will first define a Reference
Position in the source, or "from" workspace and then define a
Target Position in the current, or "to" workspace. Any two points
will work as long as they correspond in each workspace.

Step 9: Define the reference position.

You will first define a reference position on the part at Spindle 1.

Choose Select under Reference Position.

Choose the end point of the horizontal line on the part at
Spindle 1 as illustrated below.

The point is labeled "Ref Pt".

Step 10: Define the target position.

You will now define a corresponding target position on the part at
Spindle 2.

Choose Select under Target Position.
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Choose the end point of the horizontal line on the part at
Spindle 2 as illustrated below.

The point is labeled "Target Pt".

Step 11: Display the blank orientation.

The blank geometry must maintain the same relative orientation
to the workpiece as the IPW.

Choose Display Blank.

The vectors point in the same direction. The orientation of the
blank geometry at Spindle 2 is correct because the workpiece
is transferred from one spindle to the next and is not flipped.
If the workpiece were flipped at Spindle 2, you could flip the
blank by choosing Flip Direction.

OK to accept the blank definition.

OK to accept the TURN_BND dialog.
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Step 12: Generate the tool path for the rough bore operation.

Now that the blank material for the Rough Bore ID operation
has been defined by referencing the IPW from Spindle 1, you can
generate the tool path.

Highlight the ROUGH_BORE_ID operation and
MB3→Generate.

OK to accept the tool path.

Step 13: Verify material removal for the program.

You will see how the system progressively removes material while
passing the workpiece from one workspace to another.

Display the Program Order View of the Operation Navigator.

Highlight PROGRAM.

Choose the Verify Toolpath icon in the toolbar.

Turn the 2D Material Removal option on.

Slow the Animation Speed down to 3.
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Choose Play.

1. Spindle 1

2. Spindle 2

Choose OK to complete the Toolpath Visualization.

Step 14: Save and close the part.
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Summary
In this lesson, you learned how to use cross sectional curves to define part
geometry for parts mounted at each spindle of a multiple spindle machine.
You also learned how to manage the in-process workpiece as it is passed
from one spindle to the next.
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Lesson

14 Mill-Turn

Purpose

This lesson will teach you how to create a program that contains milling
and turning operations. You will also learn how to apply the turning IPW to
subsequent milling operations.

Objective

Upon completion of this lesson, you will be able to:

• Define the MCS for milling operations.

• Save the turning IPW as a separate part file.

• Add the turning IPW to the assembly.

• Define the milling blank geometry using the turning IPW.

• Add milling and drilling operations to the program.

• Postprocess the program.
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Overview of Creating a Mill-Turn Program
A mill-turn program requires the definition of at least two machine coordinate
systems; one for the milling program and one for the turning program. This
is required since turning programs and milling programs utilize machine
coordinate systems differently. Turning operations typically generate the tool
path in the ZM-XM plane with the ZM axis along the spindle centerline, while
milling operations typically generate the tool path in the XM-YM plane.

The turning IPW (in-process workpiece) can be used as blank geometry for
the subsequent milling operations by saving it as a separate part file and then
importing it back into the assembly.

The process defined in this lesson describes how to set up the machine
coordinate systems and how to utilize the turning IPW in the subsequent
milling operations to create a simple mill-turn program. It also describes how
to postprocess the mill-turn program.
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Activity: Creating a Mill-Turn Program

In this activity, you are going to create a program that first turns and then
mills a part. The turning operations have been provided. You will begin by
defining the MCS and geometry groups for the milling operations. You will
then save the turning IPW as a separate part file. You will add the turning
IPW to the assembly and use it to define the blank geometry for the milling
operations. You will then create the milling and drilling operations and
generate the tool paths.

Step 1: Open the part file and enter the Manufacturing application.

Open the tmp_mill_turn_assy_mfg_1 part.

Save the part as ***_mill_turn_assy_mfg_1, where ***
represents your initials.

Choose Start→Manufacturing.

Choose Start→Assemblies if necessary to turn the Assemblies
option on.
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Step 2: Examine the MCS_SPINDLE orientation.

In the Geometry View of the Operation Navigator, choose
MCS_SPINDLE and MB3→Object→Display.

You will define the milling MCS at the same location and
orientation as the turning MCS displayed above.

Step 3: Create a MCS_MILL object.

Mill operations must use a MCS separate from the one defined for
the turning operations.

Choose the Create Geometry icon.

Set the Type option to mill_planar.

Choose the MCS icon.

Set the Parent Group option to Geometry.

Key in MCS_MILL in the Name field.

Choose OK to begin creating the MCS_MILL object.
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Choose the Origin icon.

Choose the arc center of the outer arc for the location of the
MCS_MILL object as shown below.

Drag the handles of the MCS_MILL coordinate system to
orient it as shown below.

The MCS_SPINDLE and MCS_MILL coordinate systems are
at the same location and have the same orientation.

Choose OK to create the MCS_MILL coordinate system.
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Step 4: Create blank and part geometry groups.

You will create geometry groups for milling of the part and blank
geometry. Later, you will define the geometry within these groups.

Choose the Create Geometry icon.

Choose the WORKPIECE icon.

Set the Parent Group option to MCS_MILL.

Key in BLANK_M1 in the Name field.

Choose OK to begin creating the BLANK_M1 object.

Choose OK to complete the object.

Choose the Create Geometry icon.

Choose the WORKPIECE icon.

Set the Parent Group option to BLANK_M1.

Key in PART_M1 in the Name field.

Choose OK to begin creating the PART_M1 object.
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Choose OK to complete the object.

Step 5: Exporting the turning IPW.

You will highlight the last turning operation and save the IPW for
the turning subprogram as a separate part. Later, you will import
this part back into the assembly and use it as blank geometry for
the milling operations.

In the Operation Navigator, highlight the last turning operation
(FINISH_BORE_ID) and MB3→Workpiece→Save as.

Save the part file ***_ipw.prt, where *** represents your
initials.

In the Assembly Navigator, choose the check mark next to
tmp_swug_mill_turn_blk to remove the blank material from
the display.

Only the part should be displayed in the assembly.

Step 6: Look at the IPW part file.

You will open the ipw part file and observe the orientation of the
WCS.

Open the part file ***_ipw.prt.
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Choose Initialize at the bottom of the Machining Environment
dialog.

Notice that XC in the exported IPW is aligned with the
centerline of the spindle and YC is the cross-axis. When you
export the IPW, the system assumes your turning work plane
(ZM-XM) is an X-Y work plane.

Step 7: Add the turning IPW to the assembly.

You will add the turning IPW part to the assembly and then use it
as the blank material for the milling operations.

Choose Window→***_mill_turn_assy_mfg_1.prt in the menu
bar to display the assembly.

Choose the Add Existing Component icon.

Choose ***_ipw in the listing window.

Choose OK to accept the selected part.

Set the Positioning option to Mate.

Choose OK to accept it.

Choose the Center icon under Mating Type.

In the Component Preview window, MB3→Orient
View→Trimetric.
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Choose the cylindrical face of the IPW as the From face.

Choose the cylindrical face of the part as the To face.

Choose the Align icon under Mating Type.
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Choose the front face of the IPW as the From face.

Choose the front face of the part as the To face.

Choose OK twice to see the IPW superimposed on the part.

Cancel the Select Part dialog to complete the assembly.
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Step 8: Select the IPW as the blank geometry.

Double-click the BLANK_M1 object in the Operation Navigator.

In the Workpiece dialog, choose the Blank icon and Select.

Select the turning IPW as the blank geometry and then choose
OK.

OK to accept the Workpiece dialog.

Choose the check mark next to ***ipw in the Assembly
Navigator to remove the blank component from the display.

Only the part should be displayed in the assembly.

Step 9: Select the part geometry.

You will define the part geometry by selecting the solid body.
Although the body is not used by the planar mill operations, it is
necessary for gouge checking.

Double-click the PART_M1 object in the Operation Navigator.

In the Workpiece dialog, choose the Part icon and Select.
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Select the part and choose OK.

OK to accept the Workpiece dialog.

Step 10: Begin creating the first milling operation.

You will create a Planar Mill operation that machines one of the
slots on the front face of the part.

Choose Create Operation.

Set the Type option to mill_planar.

Choose the PLANAR_PROFILE icon.

Set the following Parent Groups:

• Program..........TAPE_12345_A

• Use Geometry....PART_M1

• Use Tool..........EM_1.25_.03

• Use Method......MILL_FINISH
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Choose OK to begin creating the operation.

Step 11: Define the part boundary.

Choose the Part icon and Select.

Set the Mode option to Curves/Edges.

Set the Type option to Open.

Set the Plane option to User-Defined.

Choose the Two Lines icon.

Select the two lines illustrated below.

Set the Material Side option to Right and be sure the Tool
Position option is set to Tanto.
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Choose the upper line at the end toward the outside diameter.

Choose OK to create the boundary.

Choose OK to complete the boundary geometry.

Choose Display.

Step 12: Define the remaining operation parameters.

Choose the Floor icon and Select.

Set the Filter option to Face.
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Select the face as illustrated below and OK to define it as the
floor.

Be sure the Cut Depth option is set to Floor Only.

Choose the Edit Display icon and set the Tool Display option
to 3-D.

Generate the tool path.

Choose OK to complete the tool path.

Choose OK to complete the operation.

Step 13: Create the second milling operation.

You will create a Planar Mill operation that machines the second
slot. You will do this by copying the first operation and defining a
new part boundary.

Highlight the PLANAR_PROFILE operation in the Operation
Navigator and MB3→Copy.
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With the PLANAR_PROFILE operation still highlighted, use
MB3→Paste.

Step 14: Redefine the part boundary.

You will redefine the part boundary so that the operation machines
the other slot.

Double-click on the PLANAR_PROFILE_COPY icon in the
Operation Navigator to edit the operation.

Choose the Part icon and Reselect.

OK the warning.

Create the boundary illustrated below as you did before.

Generate the tool path.
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Choose OK to complete the operation.

Step 15: Create the spot drilling operation.

You will create an operation that spot drills the holes in the slots.

Choose the Create Operation icon in the toolbar.

Set the Type option to drill.

Choose the SPOT_DRILLING icon from the Create Operation
dialog.

Set the following Parent Groups:

• Program..........TAPE_12345_A

• Use Geometry....PART_M1

• Use Tool..........SPOTDRILL_.250

• Use Method......SPOT_DRILLING

Choose OK to begin creating the operation.

Step 16: Define the drilling geometry.

Choose the Holes icon and Select.

Choose Select in the Point dialog.

Select the two holes.

Choose OK to accept them.

OK the Point dialog.
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Step 17: Define the remaining operation parameters.

Choose Standard Drill.

Choose OK to accept 1 as the Number of Sets.

Choose Rtrcto - None.

Choose Distance.

Key in 1.000 in the Rtrcto field and OK to accept it.

Choose OK in the Cycle Parameters dialog.

Generate the tool path.

Choose OK to complete the operation.

Save the part.
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Activity: Postprocessing

In this activity, you are going to postprocess the mill-turn program and view
the output.

Step 1: Postprocess the mill-turn program.

Display the Program Order View of the Operation Navigator.

In the Program Order View of the Operation Navigator,
highlightTAPE_12345_A.

Choose MB3→Generate.

Choose the Post Postprocess icon in the toolbar.

Choose MILLTURN in the Available Machines list.

Specify the directory and file name. The system will save the
file as ***_mill_turn_assy_mfg_1.prt in the current directory
by default.

Choose OK to create the file.

Step 2: View the output.

Scroll through the Information window to where the milling
operations begin.

At this point, a milling tool is used and the spindle functions as
a rotating table top to accommodate the milling operations.

Dismiss the Information window.

Save and close the part.

©UGS Corporation, All Rights Reserved Turning Manufacturing Process — Student Guide 14-19



14

Mill-Turn

Summary
A mill-turn program allows you to perform both milling and turning
operations in a single program.

In this lesson you:

• Defined the MCS for milling operations.

• Saved the turning IPW as a separate part file.

• Added the turning IPW to the assembly.

• Defined the milling blank geometry using the turning IPW.

• Added milling and drilling operations to the program.

• Postprocessed the program.
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A Merging Lathes

Purpose

This lesson will teach you how to use the Synchronization Editor to control
the synchronization and merging of machining operations and events for
Merging Lathes and Multiple Spindle Production Centers.

Objectives

After completing this lesson, you will:

• Define a Single Spindle, Two Turret Program.

• Use the Synchronization Editor to synchronize turret movements within
the program.
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Merging Lathes
Merging Lathes allows you to program turning machines that can
simultaneously cut with two or more tools. You can apply synchronization
states to tool paths when programming any type of merging lathe from
Vertical Turret Lathes to complex production centers. It includes a method for
synchronizing the motion of turrets, capturing the synchronization positions,
and displaying and simulating the synchronized results for verification and
post processing.
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Synchronization Editor

The Synchronization Editor lets you control the synchronization and merging
of machining operations and events for Merging Lathes and Multiple Spindle
Production Centers. It gives you an overview of all operations assigned to your
turrets, slides or other machine tool components that are working in parallel.
These are presented in a multi-column list window that lets you conveniently
reorder the operations and events using cut, copy, paste, or drag and drop.
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The Synchronization Editor supports the insertion of wait and
synchronization marks, rearranging the operations and events into the proper
(parallel) time sequence for you. Integrated visualization of machining times
(time chart) and simulation control (ISV) provide immediate verification
feedback. This feature is useful if you need to optimize your NC-program for
simultaneous machining of multiple slides or turrets. Use this feature if you
want to achieve shorter machining times with better balanced NC-programs
for Merging Lathes and Multiple Spindle Production Centers.

Time Chart Diagram

The Time Chart Diagram window gives you an indication of the efficiency of
your program in graphical form. This feature is useful if you want to inspect
how far your program has been optimized through the usage of simultaneous
machining with multiple slides or turrets. Use this feature if you want to see
a graphical representation of your NC-program’s machining times versus
idle times, the synchronization marks and wait events. It helps you to judge
whether your NC-program for Merging Lathes is sufficiently balanced.
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Simulation Control for Multiple Slide / Multiple Spindle Machining

The integrated Simulation Control provides functionality that lets you control
the simulation of your Multiple-Slide / Multiple-Spindle NC-program from
within the Synchronization Editor. It allows you to produce a program for
Merging Lathes is efficient and free from collisions before it is sent out to
production.

Select the Play button to start the simulation from within the Synchronization
Editor, or choose Step Forward/Backward in order to single step through your
program. At any time while the simulation is running, you may click the
Stop icon to terminate the simulation. Pressing the Reset button makes the
simulation return to the event or operation where your simulation started.
Also, you may adjust your simulation speed using an integrated UI control. If
you select the Simulation Options icon, you can activate collision checking
or configure collision pairs.

ISV for Merging Lathes

The CAM Integrated Simulation and Verification module (ISV) provides
simulation and time calculation for Merging Lathes and Multiple Spindle
Production Centers. You use it in the same way as the current milling ISV
module, but while creating and synchronizing manufacturing operations to be
machined on merging lathes and multiple spindle production centers.
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Activity: Defining a Single Spindle, Two Turret Program

In this activity you will use the Operation Navigator to change a
single turret turning program into a two turret program. You will
then use the Synchronization Editor to synchronize turret motions
and insert dwells.

Step 1: Open the tmp_merging_lathe_mfg part and start the
Manufacturing application.

Step 2: Add pockets to carriers.

You will add numbered pockets to each carrier. In doing so, you will
define tool numbers at the pocket level. This is the most common
method of determining the tool number on the machine tool and
the method you will most likely use. These pocket numbers will be
inherited by the tools and operations as tool numbers and output
to the postprocessor.

Display the Machine Tool view of the Operation Navigator.

Choose the Create Tool icon.

Be sure the Type option is set to turning.
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Choose the MCT_POCKET icon.

Set the Parent Group option to UPPER.

Key in MCT_POCKET_1 in the Name field.

Apply to begin defining the pocket.

Key in 1 in the Pocket ID field and OK the pocket dialog.

Key in MCT_POCKET_2 in the Name field and repeat the
process until MCT_POCKET_1 through 6 have been defined in
the UPPER carrier as illustrated below.

Create pockets 7–10 inside the LOWER carrier as illustrated
below.

Cancel the Create Tool dialog.
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Step 3: Place tools into pockets.

You will drag and drop tools into the pockets you just defined. In
doing so, the tools inherit the pocket numbers and the operations
are divided between the upper and lower turrets. Determining the
tool number by the pocket in which the tool is placed is analogous
to a machine operator picking up a tool and putting it into a pocket
on the machine.

Drag and drop each tool into each pocket as illustrated below.
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Step 4: Specify the postprocessors to use for each turret.

You must associate the UPPER and LOWER turrets with the
appropriate postprocessors.

In the Machine Tool view of the Operation Navigator, choose
UPPER and MB3→Object→Start Post.

In the User Defined Events dialog, choose Head in the Available
list (you may need to scroll) and choose Add.

In the Head dialog, turn the Name Status option on and key in
LATHE_UPPER in the Name field.

LATHE_UPPER is the “trigger”, defined within the
postprocessor, that specifies the correct post for the upper
turret.

OK the Head dialog.

OK the User Defined Events dialog.
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Repeat these steps for the LOWER turret, keying in
LATHE_LOWER in the Name field.

Step 5: Specify the postprocessor for the program.

The program must be assigned a single postprocessor. Yet, the
program must use two postprocessors, one for the upper turret and
one for the lower turret. To accommodate this situation, you must
specify a single postprocessor that is linked to the postprocessors
for the upper and lower turrets.

In the Program Order view of the Operation Navigator,
highlight PROGRAM and MB3→Tool Path→Synchronize.

Choose Browse.
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Browse to where your part files are saved, open the posts
folder, and choose lathe_upper.pui.

This is linked to the postprocessors for the upper and lower
turrets.

OK the Open Postprocessor dialog.

OK the Postprocess dialog.

Step 6: Synchronize the operations.

The Synchronization Editor reflects the program order as defined
by the Program Order view. While the program order cannot be
changed in the Synchronization Editor, the Synchronization Editor
does allows you to determine when each turret becomes active.
This allows you to determine when they run independently and
simultaneously.

In this example, the facing and spotdrilling operations execute
simultaneously. The remaining operations execute sequentially.
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Facing should not occur while spotdrilling because this will cause
a collision between upper and lower turrets. Rough od and rough
id operations, however, should run simultaneously for program
efficiency. Synchronization marks must be inserted to coordinate
the turret movements.

You will begin by specifying that the spotdrilling operation will
run first followed by the drilling operation. The upper turret will
remain idle while these operations are executing.

Highlight ROUGH_BORE_ID.

Choose the Insert Sync Event icon.

Set the Primary option to None.

None must be specified when a single turret is active and no
dependency between turrets (primary turret) is needed. Because
you must always synchronize at least two turrets, UPPER and
LOWER under must both remain turned on.

In this case, the synchronization involves allowing one turret to
remain idle while the other performs drilling operations.
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OK the Synchronization Mark dialog.

The Synchronization Mark always appears above the selected
operation.

In the UPPER column, drag and drop the synchronization
mark so it is positioned above FACING.

Now the spotdrilling and drilling operations run in sequence using
the lower turret while the upper turret sits idle.

Next, you want facing to occur after drilling. You do not want the
facing operation to run in conjunction with any other operation.
This will require that the upper turret is active while the lower
turret sits idle. To do this, you must position a synchronization
mark after FACING.

Highlight ROUGH_TURN_OD.

Choose the Insert Sync Event icon.

Set the Primary option to None.
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OK the Synchronization Mark dialog.

The Synchronization Mark always appears above the selected
operation.

The asterisk next to ROUGH_BORE_ID indicates that the
rough bore id operation has been interrupted by the facing
operation.

Drag the synchronization2 mark in the LOWER column above
ROUGH_BORE_ID.

Spotdrilling and drilling operations run in sequence using the
lower turret while the upper turret sits idle. The facing operation
then runs using the upper turret while the lower turret sits idle.

Notice that the ROUGH_TURN_OD and the ROUGH_BORE_ID
operations both run at the same time. This is what you want.
However, when two operations run at the same time, you must
designate one of the two operations as Primary. By doing this, the
system is able to resolve conflicting operation parameters such
as spindle speeds.
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Double-click the second synchronization mark.

In the Synchronization Mark dialog, set the Primary option
to UPPER.

The parameters defined by the upper turret operation,
ROUGH-TURN_OD, are now used to resolve conflicting
operation parameters.

OK the Synchronization Mark dialog.

Next, you want the GROOVE_OD and GROOVE_ID operations
to run at the same time.

Highlight GROOVE_ID.

Choose the Insert Sync Event icon.

Set the Primary option to LOWER.

OK the Synchronization Mark dialog.

The Synchronization Mark always appears above the selected
operation.

The asterisk next to TEACH_MODE indicates that the
teach mode operation has been interrupted by the groove id
operation.

Drag the synchronization3 mark in the UPPER column above
GROOVE_OD.
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Now the GROOVE_OD and GROOVE_ID operations run at the
same time. The parameters defined by the lower turret operation,
GROOVE_ID, are used to resolve conflicting operation parameters.

Centerline spotdrilling is followed in sequence by centerline
drilling. Both are performed by the lower turret while the lower
turret remains idle. The upper turret then faces the part while
the lower turret remains idle. Rough turn od and rough turn
id operations are then performed simultaneously by the upper
and lower turrets. The upper turret is designated as primary
to resolve conflicting operation parameters. The face of the
part is then grooved by the upper turret while the lower turret
remains idle. Next, the groove od and groove id operations are
run simultaneously with the lower turret designated as primary.
Finally, the remaining operations are executed in sequence by the
upper turret while the lower turret remains idle.

Step 7: Insert a dwell.

Dwells can be added to pause operations. This sometimes becomes
necessary when a manual process must be performed by the
operator. Like synchronization marks, dwells are inserted above
the selected operation.
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Highlight TEACH_MODE.

Choose the Insert Dwell Event icon.

Key in 20.000 in the Dwell Value field.

OK the Dwell dialog.

Step 8: View the time chart.

The time chart is a graphical representation of turret events along
a time line.

Choose the Open time chart icon.
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Click on the operations and the synchronization marks in the
Synchronization Editor to graphically locate their positions
on the time chart.

Choose the Toggle Legend icon to display a legend of the colors

and symbols used in the time chart.

Step 9: View operation details.

Expand All allows you to view every move and command in each
of the operations.

Choose the Expand All icon.

Step 10: Show postprocessor output.

The Show Machine Code Lines icon shows the postprocessor
output.
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Choose the Show Machine Code Lines icon.

Postprocessing is the preparation of machine code used to drive a
specific machine tool. Postprocessing converts the internal tool
path containing events and motions into a format compatible to the
machine tool’s controller. By default, the postprocessor will create
a file with the root name of the part file and a .ptp extension. To
postprocess, a tool path and postprocessor are required.

Choosing the Postprocess icon will create the .ptp files for the
upper and lower turrets in your current directory

Close the part.
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Summary
Merging Lathes allows you to program turning machines that can
simultaneously cut with two or more tools. It includes a method for
synchronizing the motion of turrets, capturing the synchronization positions,
and displaying and simulating the synchronized results for verification and
post processing.

In this lesson you:

• Define a Single Spindle, Two Turret Program.

• Use the Synchronization Editor to synchronize turret movements within
the program.
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B Vertical Turret Lathe

Purpose

This lesson will teach you how to create a Vertical Turret Lathe (VTL)
program.

Objective

Upon completion of this lesson, you will:

• Examine the setup of a VTL.

• Create facing, roughing, grooving, and finishing operations.

• Postprocess the program.

Overview of Creating VTL Program
A Vertical Turret Lathe (VTL) program requires the MCS to be oriented
according to the requirements of the postprocessor. The vertical centerline of
the spindle must be defined by either the ZM axis or the XM axis. The Lathe
Work Plane must then be specified accordingly. For convenience, the part
should be viewed in a vertical orientation and the WCS should be rotated so
that YC is pointing upward and XC is pointing to the right. This will allow
angles to be referenced from the conventional three o’clock position.
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Activity: Examining a VTL Setup and Program

In this activity, you are going to examine the finished setup and program.

Step 1: Open the part file and enter the Manufacturing application.

Open the part file tmp_vtl_mfg_1.prt.

Enter the Manufacturing application.

Step 2: View the MCS.

In the Geometry View of the Operation Navigator, double-click
MCS_SPINDLE.

The vertical centerline of the spindle must be defined by either
the ZM or XM axis, depending on your postprocessor. In this
case, it is defined by the ZM axis.

Cancel the TURN_ORIENT dialog.
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Step 3: View the blank geometry.

The blank geometry has been defined just once in a parent group
so that all of the operations can reference it.

Double-click BLANK in the Operation Navigator.

Choose the Blank icon and Display.

Cancel the TURN_BND dialog.

Step 4: View the part geometry.

The Part geometry has been defined just once in a parent group so
that all of the operations can reference it.

Double-click PART in the Operation Navigator.

Choose Display.

Cancel the PART dialog.

Step 5: Verify the tool path.

In the Program Order View of the Operation Navigator,
highlight T563489A and choose the Verify Toolpath icon in the
toolbar.

Turn the 2D Material Removal option on.
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Choose Play.

This is the program you will create in the next activity.

Choose OK to complete the Toolpath Visualization.

Save and close the part file.
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Activity: Creating the Operations

In this activity, you are going to create a program consisting of facing, od
roughing, boring, grooving, and finishing operations.

Step 1: Open the part file and enter the Manufacturing application.

Open the part file tmp_vtl_mfg_2.prt.

Enter the Manufacturing application.

Save the part file as ***_vtl_mfg_2.prt, where *** represents
your initials.

Step 2: Rough the face.

Choose the Create Operation icon in the toolbar.

Be sure the Type option is set to turning.

Choose the FACING icon as the subtype.
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Specify the following parent groups.

• Program..........T563489A

• Use Geometry....PART

• Use Tool..........OD_80_5R_RH_RGH

• Use Method......LATHE_ROUGH

OK to begin creating the operation.

Step 3: Specify the operation parameters.

Be sure the Cut Depth option is set to Variable Avg.

Key in 0.040 in the Minimum field and 0.750 in the Maximum
field.

Choose Containment.

Turn the Axial 1 Trim option on.

Choose Axial 1 and specify a Trim Plane on face of the part as
illustrated below.

OK to accept the Trim Plane.

Choose Avoidance and turn the Start Point and Return Point
options on.
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Choose Specify and create a Start Point and a Return Point at
the approximate screen positions illustrated below.

OK to accept the points.

Step 4: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

OK to complete the operation.
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Step 5: Rough the OD.

Choose the Create Operation icon in the toolbar.

Choose ROUGH_TURN_OD as the subtype.

Specify the following parent groups.

• Program..........T563489A

• Use Geometry....PART

• Use Tool..........OD_80_5R_RH_RGH

• Use Method......LATHE_ROUGH

OK to begin creating the operation.

Step 6: Specify the operation parameters.

Be sure the Cut Depth option is set to Variable Avg.

Key in 0.040 in the Minimum field and 0.750 in the Maximum
field.

Choose Avoidance and turn the Start Point and Return Point
options on.
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Choose Specify and create a Start Point and a Return Point at
the approximate screen positions illustrated below.

OK to accept the points.

Step 7: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

OK to complete the operation.
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Step 8: Rough the ID.

You will use the same turning tool to rough bore as you used to
rough turn. The processor will automatically reverse the spindle
when the tool crosses the centerline.

Choose the Create Operation icon in the toolbar.

Choose ROUGH_TURN_OD as the subtype.

Specify the following parent groups.

• Program..........T563489A

• Use Geometry....PART

• Use Tool..........OD_80_5R_RH_RGH

• Use Method......LATHE_ROUGH

Key in ROUGH_BORE in the Name field.

OK to begin creating the operation.

Step 9: Specify the operation parameters.

Be sure the Cut Depth option is set to Variable Avg.

Key in 0.040 in the Minimum field and 0.750 in the Maximum
field.

Choose Avoidance and turn the Start Point and Return Point
options on.
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Choose Specify and create both the Start Point and Return
Point at the end of the horizontal line as illustrated below. Be
sure you define them to the left of the centerline.

OK to accept the points.

Step 10: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

OK to complete the operation.
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Step 11: Finish the face.

Choose the Create Operation icon in the toolbar.

Be sure the Type option is set to turning.

Choose the FINISH_TURN_OD icon as the subtype.

Specify the following parent groups.

• Program..........T563489A

• Use Geometry....PART

• Use Tool..........OD_80_3R_RH_FIN

• Use Method......LATHE_FINISH

OK to begin creating the operation.

Step 12: Specify the operation parameters.

Key in 180 in the Cut Angle.

Choose Containment.
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Turn the Axial 1 Trim option on and key in 21.825.

The axial trim plane should appear just below the part face.

OK to accept the Trim Plane.

Choose Avoidance and turn the Start Point and Return Point
options on.

Choose Specify and create a Start Point and a Return Point at
the approximate screen positions illustrated below. Be sure you
define them to the right of the centerline.

OK to accept the points.

Step 13: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.
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Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

OK to complete the operation.

Step 14: Finish the OD.

Choose the Create Operation icon in the toolbar.

Be sure the Type option is set to turning.

Choose the FINISH_TURN_OD icon as the subtype.

Specify the following parent groups.

• Program..........T563489A

• Use Geometry....PART

• Use Tool..........OD_80_3R_RH_FIN

• Use Method......LATHE_FINISH

OK to begin creating the operation.
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Step 15: Specify the operation parameters.

Choose the Diameters First, Then Faces icon at the top of the
dialog.

Choose Avoidance and turn the Return Point option on.

Choose Select and create a Return Point at the end of the
horizontal line as illustrated below.

OK to accept the point.

Step 16: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.
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OK to complete the operation.

Step 17: Cut the groove.

Choose the Create Operation icon in the toolbar.

Choose GROOVE_OD as the subtype.

Specify the following parent groups.

• Program: T563489A

• Use Geometry: PART

• Use Tool: OD_GROOVE_L

• Use Method: LATHE_ROUGH

OK to begin creating the operation.

Step 18: Specify the operation parameters.

Choose the Plunge Alternate icon.

Turn the Additional Profiling option on.

Choose Avoidance and turn the Start Point and Return Point
options on.
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Choose Specify and create a Start Point and a Return Point at
the screen positions illustrated below.

Set the Motion to Start Point option for both the Start Point
and Return Point to Radial→Axial.

OK to accept the points.

Choose Containment.

Turn the Axial 1 and Axial 2 Trim options on.

Choose Axial 1 and select the side of the groove.
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Choose Axial 2 and select the other side of the groove.

OK to accept the Trim Planes.

Step 19: Generate the tool path and visualize material removal.

Generate the tool path.

Choose the Verify icon at the bottom of the dialog.

Turn the 2D Material Removal option on.

Choose the Play icon at the bottom of the dialog.

OK to complete the tool path visualization.

OK to complete the operation.
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Step 20: Postprocess the program.

In the Program Order View of the Operation Navigator,
highlight T563489A.

Choose the Postprocess icon in the toolbar.

Choose LATHE_2_AXIS_TOOL_TIP in the Available Machines
list.

Specify the directory and file name. The system will save the
file as ***_tmp_vtl_2.prt in the current directory by default.

Choose OK to create the file.

Scroll through the Information window.

Dismiss the Information window.

Save and close the part file.
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Summary
In this lesson you created a Vertical Turret Lathe (VTL) program.

You learned how to:

• Create facing, roughing, grooving, and finishing operations for a VTL.

• Postprocess the program.
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C Lathe Cross Sections

Purpose

Lathe Cross Section allows you to create associative curves that represent a
2D cross section of a solid body. These cross sectional curves are needed for
boundary creation in NX3 and before.

The body can be rotational symmetrical (e.g., cylindrical, cone, etc.) requiring
a Simple cross section, or non-symmetrical (e.g., a cam shaft hex, etc.)
requiring a Complex cross section.

Objective

Upon completion of this lesson, you will be able to:

• Create simple cross sections.

• Create complex cross sections.

• Observe the associativity between cross sectional curves and parent
geometry.
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The Lathe Cross Section Feature
The two cross sectioning methods are:

Simple - The Simple method (1) uses a single section plane. The resulting
cross-sectional curves lie in the plane used to create the cross section. This
method is intended for parts with consistent cross sections.

Complex - The Complex method (2) uses multiple section planes. The
cross-sectional curves are rotated about a specified axis onto a projection
plane. This method is intended parts with variable cross sections.

The Selection Steps icons (1) define the body, axis, projection plane, and
section plane of the cross section. The next two icons (2) define the cross
sectioning method. The Defaults options (3) define the axis, projection plane,
and section plane for the cross sectional curves. The MCS_SPINDLE option
automatically designates the plane defined by the lathe work plane. The
Radial Planes option defines the section planes using the rotation axis and
specifying a point. This option is available only when defining complex
sections. The User Defined option defines the section planes using the Plane
Subfunction.
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Activity: Creating a Simple Cross Section

In this activity, you are going to create simple cross sections for the
blank and the part geometry.

Step 1: Open and rename the part.

Open the part tmp_crs_sec_mfg_1.prt.

Be sure the blank geometry is displayed as translucent. If it is
not, choose Preferences→Visualization→Visual tab and turn
the Translucency option on.

Save the part file as ***_crs_sec_mfg_1.prt, where ***
represents your initials.

Choose Application→Manufacturing.

Double-click the Operation Navigator tab in the resource bar
and undock the Operation Navigator (using the Ctrl key) so it
displays in a separate window.

Step 2: Check the location of the MCS.

Check the location of the WCS and MCS before you start since
many of the cross sections are created using the default MCS
XY-Plane.

Visually check the WCS and MCS locations.

Note that the WCS and MCS are both in the same location.
You must also check the MCS_SPINDLE Parent Group.

Change the Operation Navigator view.

Display the Geometry View of the Operation Navigator.
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Double-click on the MCS_SPINDLE Parent Group in the
Operation Navigator.

The TURN_ORIENT dialog is displayed.

Visually check the MCS location.

The XM is along the Spindle axis and the YM is parallel to the
face of the chuck.

Choose Cancel to dismiss the dialog.

Step 3: Cross section the blank.

To create cross sectional curves, you must first select a solid body
and then define a section plane.
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Choose Tools→Lathe Cross-Section.

The Lathe Cross Section dialog is displayed. The Body and
Simple Section icons are chosen.

Before creating cross sections, note that the work layer is layer
50. This layer currently contains no geometry. Creating each
cross section on a separate layer will allow you to easily display
the curves.

Select the blank geometry.

Choose OK.

The plane symbol is displayed at MCS XY-Plane.

Step 4: Specify the section plane.

The Section Plane icon is automatically selected.

You are going to use the default Section, MCS_SPINDLE.
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Choose OK.

You now have associative curves that can be used for blank
boundary creation.

Next, you will create a cross section of the part geometry.
Before you begin, change the work layer.

Step 5: Change the work layer.

Creating each cross section on a separate layer will allow you to
easily display the curves.

Choose Format→Layer Settings from the menu bar.

Key in 55 in the Work field and choose the Make Work button
below the list box.

Now you will make layer 50 invisible. This is the layer that
contains the blank cross sections.

Double-click on Layer 50.

You no longer need the blank cylinder geometry. You will make
it invisible as well.

Double-click on layer 53.
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Choose OK.

Layer 55 is now the work layer and layers 50 and 53 are
invisible. You should be able to see the part geometry clearly.

Step 6: Cross Section the part.

You will now cross section the part geometry. The Body and Simple
Section icons are chosen.
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Select the part geometry.

Choose OK.

Again, you are going to use the default Section, MCS_SPINDLE.

Choose OK.

You now have associative curves that can be used for part
boundary creation.

Step 7: Change the layer settings.

You are going to change the layer settings to make the curves
clearly visible. This will allow you to easily select the cross
sectional curves when you create the boundaries.

Choose Format→Layer Settings from the menu bar.

The Layer Settings dialog is displayed.
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Double-click on Layer 1 (contains the part geometry) to make
it invisible.

Choose OK.

You should be able to clearly see the part cross sectional curves.

Next you will make layer 50 selectable.

Choose Format→Layer→Settings from the menu bar.

Double-click on Layer 50 and choose OK.

You should be able to clearly see the blank cross sectional
curves.

Choose File→Save from the menu bar.

Close the part.
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Lathe Cross Sections

Activity: Create a Simple Cross Section Unassisted

Step 1: Open and rename the part.

Open the part file tmp_crs_sec_mfg_2.prt.

Save the part file as ***_crs_sec_mfg_2.prt, where ***
represents your initials.

Step 2: Create the cross section geometry.

Put the Cross Section geometry on Layer 53.

If you have any questions, ask your instructor.

Save the part file.

Save and close the part.
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Lathe Cross Sections

Activity: Create a Complex Cross Section

In this activity, you are going to create complex cross sections for the
part geometry. These cross sections will define the hole diameter and
the minimum cross section of the part.

Step 1: Open and rename the part.

Open the part file tmp_crs_sec_mfg_3.prt.

Save the part file as ***_crs_sec_mfg_3.prt, where ***
represents your initials.

Choose Application→Manufacturing.

Step 2: Create the cross section geometry that represents the smallest
ID of the part.

Make layer 50 the work layer.

Choose Tools→Lathe Cross-Section.

Choose the Complex Section icon.

Notice under the Selection Steps label, the Body icon is
highlighted.
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Lathe Cross Sections

Select the part body.

Choose OK.

Under the Definition Steps label, notice that the Axis icon has
been selected. Also notice that the Axis label is highlighted.

You are prompted to specify the axis of rotation for the cross
section curves. The default MCS_SPINDLE is correct for this
part.

Choose OK.

Note that under the Definition Steps label, the Projection Plane
icon is highlighted. You are prompted to specify the plane to
which the cross section curves are to be rotated.

Also note that the Projection label is highlighted. The default
MCS_SPINDLE is correct for this part.

C-12 Turning Manufacturing Process — Student Guide ©UGS Corporation, All Rights Reserved mt11055_g NX 4



C

Lathe Cross Sections

Choose OK.

Note that under the Definition Steps label, the Section Plane
icon is highlighted. You are prompted to specify the plane that
will be used to create the cross section curves.

Also note that the Section label is highlighted.

Change the Section to User Defined.

Choose the Three Points icon.

Choose the Arc/Ellipse/Sphere Center icon.

Select the two arcs as shown in the following illustration.

Choose the Control Point icon.
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Lathe Cross Sections

Choose the midpoint of the edge of the pad. This point defines
the smallest ID of the part.

Choose Yes when you are prompted to define more additional
cut planes.

Step 3: Create the cross section geometry that represents the hole
diameter.

Choose the Three Points icon.

Choose the Arc/Ellipse/Sphere Center icon.

Select the two arcs as shown in the following illustration.

Choose the Quadrant Point icon.
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Lathe Cross Sections

Select the quadrant point of the arc at the approximate location
illustrated below.

Choose No when you are prompted to define more planes.

On the Lathe Cross Section dialog, choose Apply.

Make the solid body (layer 1) invisible so you can see the cross
section curves clearly.

Redisplay the part.

Cancel the Lathe Cross Section dialog.

Next, you will edit the part geometry and observe how the
associated cross sectional curves update automatically.
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Lathe Cross Sections

Step 4: Using expressions, change the height of the pad and view the
updated cross sectional curves.

In the Assembly Navigator, choose tmp_crs_sect_3 and
MB3→Make Displayed Part.

Choose Tools→Expression from the menu bar.

The Expressions dialog is displayed. Note the list of part
expressions.

Choose the pad_height expression.

You will change the pad height from 0.500 to 2.000.

Key in 2 in the Formula field.

OK the Expressions dialog to accept the edit.

In the Assembly Navigator, choose tmp_crs_sect_3 and
MB3→Display Parent→tmp_crs_sec_mfg_3.
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Lathe Cross Sections

Rotate the part to see how the pad height has changed.

Make the solid body (layer 1) invisible so you can see to
cross section curves clearly. Although the part geometry has
changed, the cross section curves have not yet updated

You need to redisplay the Lathe Cross Section dialog and then
Cancel to update the curves.

Choose Tools→Lathe Cross-Section.
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Lathe Cross Sections

Choose Cancel from the Lathe Cross Section dialog to update
the curves.

Redisplay the part so you can see both the part and the curves.

Save the part.

Close all parts.

The cross section only updates while in the
Manufacturing application. If the model changes
outside of the Manufacturing application, and these
changes affect the cross sections, they will be updated
only when you re-enter the Manufacturing application.
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Lathe Cross Sections

Summary
Associative cross sectional curves required for boundary creation can be
created very easily using the Lathe Cross Sections function. The following
functions are used to create cross section curves:

• Tools→Lathe Cross-Section→Simple Section

• Tools→Lathe Cross-Section→Complex Section
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UGS Education Services offers a blend of training 
solutions for all of our product lifecycle management 
products.  
Our Online Store “Learning Advantage” was  
developed to provide our customers with “just in time” 
training for the latest in application developments. 
 
Here are some of the Learning Advantages: 

• Customers have direct access 
• Self-paced course layout 
• Online Assessments 
• Just in time training for the latest release 

 
 
 
 
To learn more about the “Learning Advantage” visit 
our website http://training.ugs.com or email us at 
training @ugs.com 



 

 
STUDENT PROFILE 

 
In order to stay in tune with our customers we ask for some background information. This information will be kept 
confidential and will not be shared with anyone outside of Education Services. 

Please “Print”…  

Your Name          U.S. citizen Yes   No 
 
Course Title/Dates       /      thru        
 
Hotel/motel you are staying at during your training   
 
Planned departure time on last day of class   
 
Employer          Location        
 
Your title and job responsibilities       /  
 
Industry:  Auto Aero Consumer products Machining Tooling Medical Other 
 
Types of products/parts/data that you work with   
 
Reason for training   
 
Please verify/add to this list of training for Unigraphics, I-deas, Imageware, Teamcenter Mfg., Teamcenter Eng. (I-Man), Teamcenter 
Enterprise (Metaphase), or Dimensional Mgmt./Visualization. Medium means Instructor-lead (IL ), On-line (OL ), or Self-paced (SP) 
Software From Whom When Course Name Medium 

                           

                           

                           

                           

                           

                           

 
Other CAD/CAM/CAE /PDM software you have used   
Please “check”! your ability/knowledge in the following… 

Subject  
CAD modeling 
CAD assemblies 
CAD drafting 
CAM  
CAE 
PDM – data management 
PDM – system management 
 

None �  �  �  �  �  �  �  
 

Novice �  �  �  �  �  �  �  
 

Intermediate �  �  �  �  �  �  �  
 

Advanced �  �  �  �  �  �  �  

 
Platform (operating system)  
 
Thank you for your participation and we hope your training experience will be an outstanding one. 



 

 
TMP Course Agenda 

Day 1 Morning  
• Introduction & Overview 
• Lesson 1. Defining Part & Blank Geometry 
• Lesson 2. Retrieving & Creating Tools 
• Workbook Sections 1 -- 7 

 Afternoon 
• Lesson 3. Facing Operations   
• Workbook Section 8 
• Lesson 4. Verification 
 

 

Day 2 Morning  
• Lesson 5. Common Options 
• Lesson 6. Centerline Operations 
• Workbook Sections 9 & 10 
• Lesson 7. Roughing Operations – OD Work 
• Workbook Section  11 

 Afternoon 
• Lesson 8. Roughing Operations – ID Work 
• Lesson 9. Finish Operations OD and ID Work 

 

 

Day 3 Morning  
• Lesson 10. Grooving 
• Workbook Sections 12 - 17 
• Lesson 11. Teach Mode 
• Lesson 12. Threading Operations 
• Workbook Sections 18 - 20 

 Afternoon 
• Lesson 13. Using Multiple Spindles 
• Lesson 14 Mill Turn 
 

 
 
 
 



 

Accelerators 

The following Accelerators can be listed from within an NX session by choosing 
Information→Custom Menubar→Accelerators. 

 
Function Accelerator 
File→New... Ctrl+N 
File→Open... Ctrl+O 
File→Save Ctrl+S 
File→Save As... Ctrl+Shift+A 
File→Plot... Ctrl+P 
File→Execute→Grip... Ctrl+G 
File→Execute→Debug Grip... Ctrl+Shift+G 
File→Execute→NX Open... Ctrl+U 
Edit→Undo Ctrl+Z 
Edit→Cut Ctrl+X 
Edit→Copy Ctrl+C 
Edit-Paste Ctrl+V 
Edit→Delete... Ctrl+D  or Delete 
Edit→Selection→Top Selection Priority - Feature F 
Edit→Selection→Top Selection Priority - Face G 
Edit→Selection→Top Selection Priority - Body B 
Edit→Selection→Top Selection Priority - Edge E 
Edit→Selection→Top Selection Priority - Component C 
Edit→Selection-Select All Ctrl+A 
Edit→Blank→Blank... Ctrl+B 
Edit→Blank→Reverse Blank All Ctrl+Shift+B 
Edit→Blank→Unblank Selected... Ctrl+Shift+K 
Edit→Blank→Unblank All of Part Ctrl+Shift+U 
Edit→Transform... Ctrl+T 
Edit→Object Display... Ctrl+J 
View→Operation→Zoom... Ctrl+Shift+Z 
View→Operation→Rotate... Ctrl+R 
View→Operation→Section... Ctrl+H 
View→Layout→New... Ctrl+Shift+N 
View→Layout→Open... Ctrl+Shift+O 
View→Layout→Fit All Views Ctrl+Shift+F 
View→Visualization→High Quality Image... Ctrl+Shift+H 
View→Information Window F4 
View→Current Dialog F3 
View→Reset Orientation Ctrl+F8 
Insert→Sketch... S 
Insert→Design Feature→Extrude... X 
Insert→Design Feature→Revolve... R 
Insert→Trim→Trimmed Sheet... T 



 

    
Evaluation – Delivery 

NX 4 TMP, Course # MT11055 
Dates   thru   

 
Please share your opinion in all of the following sections with a “check” in the appropriate box: 

 
Instructor:  � 

If there were 2 instructors, please evaluate the 2nd instructor with “X’s”  

Instructor:  � 
1. …clearly explained the course objectives  
2. …was knowledgeable about the subject  
3. …answered my questions appropriately  
4. … encouraged questions in class  
5. …was well spoken and a good communicator  
6. …was well prepared to deliver the course  
7. …made good use of the training time  
8. …conducted themselves professionally  
9. …used examples relevant to the course and audience  
10. …provided enough time to complete the exercises  
11. …used review and summary to emphasize important information  
12. …did all they could to help the class meet the course objectives  

 

Comments on overall impression of instructor(s): 

Overall impression of instructor(s) Poor       Excellent 
 
Suggestions for improvement of course delivery:  

 
  
 
 

What you liked best about the course delivery:  
 
  
 

 
 

Class Logistics: 

1. The training facilities were comfortable, clean, and provided a good learning 
environment  

2. The computer equipment was reliable  
3. The software performed properly   
4. The overhead projection unit was clear and working properly  
5. The registration and confirmation process was efficient  

 
 

Hotels: (We try to leverage this information to better accommodate our customers) 

1. Name of the hotel     Best hotel I’ve stayed at  

2. Was this hotel recommended during your registration process?  YES  NO 

3. Problem? (brief description)   
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