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Course Overview

Course Description

The Advanced Machining Applications course includes advanced topics
that are designed to maximize productivity and efficiencies in everyday
programming environments.

Intended Audience

Manufacturing Engineers, Process Planners, NC/CNC Programmers and
CAD/CAM System Managers.

Prerequisites

The required prerequisites for the course are Practical Applications of NX
and the Mill Manufacturing Process course or the CAST equivalent. Your
experience as an NC/CNC programmer or machinist is also an asset in taking
this course.

Objectives

Upon completion of this course, you will be able to create manufacturing
assemblies using the Wave Geometry linker, machine faceted bodies and use
various cut patterns and operation types to perform high speed machining.

Student Responsibilities

• Be on time

• Participate in class

• Stick with the subject matter

• Listen attentively and take notes

• Practice on the job what you have learned

• Have fun

Class Standards for NX Part Files

The following standards will be used in this class. Standardization allows
users to work with others parts while being able to predict the organization
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Course Description

of the part file. All work should be performed in accordance with these
standards.

Class Part File Naming

This class utilizes the following file naming standard:

Where the student is requested to save a part file for later use, the initials
of the student’s given name, middle name, and surname replace the course
identifier "***" in the new filename with the remainder of the filename
matching the original. These files should reside in the student’s personal
directory.

Currently up to 128 characters are valid for file names. A four
character extension (.prt, for example) is automatically added to
define the file type. This means the maximum number of user
defined characters for the file name is actually 124.

Layers and Categories

The student will notice that there are standard layer assignments as well as
standard category names in each of the part files as follows:

Layers 1-100, Model Geometry (Category: MODEL)

Layers 1-14, Solid Geometry (Category: SOLIDS)

Layers 15-20, Linked Objects (Category: LINKED OBJECTS)

Layers 21-40, Sketch Geometry (Category: SKETCHES)

Layers 41-60, Curve Geometry (Category: CURVES)

Layers 61-80, Reference Geometry (Category: DATUMS)

Layers 81-100, Sheet Bodies (Category: SHEETS)

Layers 101 - 120, Drafting Objects (Category: DRAFT)

Layers 101 - 110, Drawing Borders (Category: FORMATS)

Layers 121 - 130, Mechanism Tools (Category: MECH)

Layers 131 - 150, Finite Element Meshes and Engr. Tools (Category: CAE)

Layers 151 - 180, Manufacturing (Category: MFG)

Layers 181 - 190, Quality Tools (Category: QA)
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Colors

The following colors are preset to indicate different object types:

Object Valid Colors

Solid Bodies Green

Sheet Bodies Yellow

Lines and Arc
(non-sketch curves)

Green

Conics and Splines
(non-sketch curves)

Green

Sketch Curves Cyan

Reference Curves
(in sketches)

Gray

Datum Features Aquamarine

Points and Coordinate Systems Green

System Display Color Red

Seed Part

Seed parts are an effective tool for establishing customer defaults or any
settings that are part dependent (saved with the part file). This may include
non-geometric data such as:

• Sketch preferences

• Commonly used expressions

• Layer categories

• User-defined views and layouts

• Part attributes

Once a seed part is established, it should be write-protected to avoid
accidental modification of the seed part.

How to Use This Manual

It is important that you use the Student Guide in the sequence presented
because later lessons assume you have learned concepts and techniques
taught in an earlier lesson. If necessary, you can always refer to any previous
activity where a method or technique was originally taught.

The format of the activities is consistent throughout this manual. Steps are
labeled and specify what will be accomplished at any given point in the
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Course Description

activity. Below each step are action boxes which emphasize the individual
actions that must be taken to accomplish the step. As your knowledge of NX
increases, the action boxes may seem redundant as the step text becomes all
that is needed to accomplish a given task.

Step 1: This is an example of a step.

This is an example of an action box.

The general format for lesson content is:

While working through lesson activities, you will experience a higher degree
of comprehension if you read the CUE and Status lines .

It is recommended that students who prefer more detail from an Instructor
Led Course ask questions, confirm with restatement, and, more importantly,
attend and pay attention to the instruction as it is given.

Obviously, it is always necessary for students to consider the classroom
situation and be considerate of other students who may have greater or
lesser needs for instruction. Instructors cannot possibly meet the exact needs
of every student.

At the start of each class day you will be expected to log onto your terminal
and start NX, being ready to follow the instructor’s curriculum. At the end of
the day’s class you should always quit NX and log off the terminal.

Workbook Overview

The Advanced Machining Application project allows the student to apply the
skills taught in this course. However, the time constraint of this course is also
a factor, at any point when progress is not being made, enlist the help of
your instructor.

Classroom System Information

Your instructor will provide you with the following items for working in the
classroom:

Student Login:

User name:

Password:
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Work Directory:

Parts Directory:

Instructor:

Date:
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Lesson

1 WAVE Geometry Linker in
Manufacturing

Purpose

In this lesson, you will learn different methods available for creating
machining geometry, using the WAVE (What If Alternative Value
Engineering) Geometry Linker, that is associated to the designer’s original
geometry.

Objective

Upon completion of this lesson, you will be able to:

• Use the WAVE Geometry Linker to create associative, linked geometry.

• Make modifications to linked geometry.

• Use a "base part" to control the manufacturing setup.

• Build a simulated casting solid body using the Wave Geometry Linker.

The WAVE Geometry Linker

The WAVE Geometry Linker is used to associatively copy geometry from a
component part in an assembly into the work part. The resulting linked
geometry is associated to the parent geometry. Modifying the parent geometry
will cause the linked geometry in the other parts to update.

The WAVE Geometry Linker is available with an Assemblies
license. It does not require a NX WAVE license.

Different types of objects can be selected for linking, including points, curves,
sketches, datums, faces, and bodies. The linked geometry can be used for
creating and positioning new features in the work part.

The Wave Geometry linker is accessed by choosing Insert→Associative
Copy→WAVE Geometry Linker from the menu bar.

©UGS Corp., All Rights Reserved Advanced Machining Applications– Student Guide 1-1



WAVE Geometry Linker in Manufacturing

• The At Timestamp option lets you specify where the linked object is placed
in the feature list. When turned off, any new features added altering the
parent geometry will be reflected in the linked geometry. When turned on,
new features added after the link was created will not be affected.

• Blank Original lets you blank the original geometry so that the linked
geometry in the work part will be easier to work with while the assembly
is displayed.

• Create Non-Associative option will create a broken link. The geometry
will be created in the work part but will not be associated to the parent
geometry.
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WAVE Geometry Linker in Manufacturing

Geometry Types used by the Geometry Linker

Several different types of geometry can be used in the WAVE application.

• Points

• Curves/Strings

• Sketches

• Datums

• Faces

• Regions of Faces

• Bodies and Mirrored Bodies

When selecting geometry to copy, you should consider how permanent the
geometry will be. If you copy as little geometry as possible to do the job,
performance will be improved but updates will be less robust when the parent
geometry is altered.

For example, if you copy individual curves to another part, the link may not
update correctly if one of the curves is deleted. Conversely, if you copy an
entire sketch, curves may be removed or added and the link will update.
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WAVE Geometry Linker in Manufacturing

Editing Links

Links may be edited by choosing Edit→Feature→ Parameters in the Model
Navigator and selecting a linked feature. Linked features have an Edit dialog
similar to the one below.

When this dialog is displayed, the cursor is active in the graphic window
allowing new parent geometry selection for the link being edited. The new
parent geometry must be the same type as the old geometry (curve, datum,
solid body, etc.)

• Parent indicates the parent geometry type. If the feature was linked, but
the link has been broken, the parent is shown as a Broken Link.

• Part shows the name of the part where the parent geometry is located. If
the parent geometry is located in the current work part, the part name
given is Work Part.

The dialog information updates when you select new parent
geometry, which you can do at any time.

• At Timestamp allows you to specify the timestamp at which the linked
feature is placed. If toggled on, the list box will display the features in the
parent part. One of these features may be selected from the list to specify
a new timestamp location for the linked feature being edited. If toggled
off, all features in the parent part will be reflected in the linked feature.

• Break Link lets you break the association between the linked feature and
its parent. This means that the linked feature will no longer update if its
parent changes. You can later define a new parent by selecting geometry
with the cursor.

• Replacement Assistant allows replacement of one linked object with
another (cannot be used on linked sketches or strings).

• Flip Face Normal reverses the normal of the face selected.

1-4 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



WAVE Geometry Linker in Manufacturing

• An Extracted feature (intra-part) can be converted to a Linked feature
(inter-part) by selecting the appropriate option and selecting new parent
geometry from another component in the assembly.

Depending on the geometry type of the feature being edited, other options
may appear on the dialog.

When editing links and selecting new parent geometry, it may
be easier to temporarily work in an exploded view to distinguish
between the existing linked geometry and the new parent geometry.
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WAVE Geometry Linker in Manufacturing

Broken Links

A link may become broken for several of the following reasons:

• The parent geometry is deleted.

• The path from the linked geometry to the parent part is broken. This can
occur if the component part containing the parent geometry is deleted
or substituted.

• If the parent is removed from the start part reference set that defines
the linked part.

• If you deliberately break the link (e.g., using Edit Feature or the Break
option on the WAVE Geometry Navigator dialog).
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WAVE Geometry Linker in Manufacturing

Newly Broken Links

When a link breaks for an indirect reason (i.e., any reason except the last one
listed above), the link is identified as newly broken until you accept it. You
can accept newly broken links from the WAVE Geometry Navigator dialog or
the Edit during Update dialog.

After a link is accepted, its status is changed to broken until a new parent is
defined.
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WAVE Geometry Linker in Manufacturing

Deleting Parent Geometry

To prevent unintentional deletion of the parents of linked geometry, a message
will warn you if a delete operation would cause inter-part links to break. This
applies to operations using Edit→Feature→Delete, Edit→Delete, and Model
Navigator→Delete while the parts containing the linked geometry are loaded.

• The Information option provides details about the links that will be
broken in an Information window.
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Deleting Linked Geometry

Linked geometry is created as a feature and can be deleted by choosing
Edit→Feature→Delete (or choosing the Delete Feature icon).

Linked bodies may also be deleted by choosing Edit→Delete. If you choose
this method, you will not have an opportunity to verify child features before
they are removed.

Assemblies and WAVE

The WAVE Geometry Linker only works in the context of an assembly. An
assembly link must exist between two part files before a WAVE link can be
established.
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Activity: Creating an Assembly for WAVE

In this activity, you will create an assembly structure for later use with the
WAVE Geometry Linker. Remember that WAVE only works in the context
of an assembly.

This activity uses a hypothetical company that has been awarded a contract
to machine a mixer housing.

The customer has supplied a NX solid model of the designed part. Since
high-production quantities are needed, the customer has decided to make the
part as an aluminum casting. This will reduce significantly, the amount of
time spent machining. Unfortunately, the customer has not supplied a solid
model of the casting which we will need to create. Using WAVE, you will
create a simulated casting model that is associated with the original geometry.

For the casting body, it will be necessary to remove the seven drilled holes,
and add .250" machining stock on the inlet, outlet and mixer tube faces. Also
note that the ring groove will not exist on the casting body.

All machined faces have 1/4" of added stock. Once the modeling changes
are made, you will drill all holes and machine the ring groove into the
mixer outlet face, since the casting process was not accurate enough for the
tolerances required.

Step 1: Open the seed part, ama_seedpart_in, and save it with a
new name.

If necessary, start NX.

Use File→Open.

Navigate to your parts folder and open the file.

Choose File→Save As ***_mixer_mfg where *** represents
your initials.
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Step 2: Add the existing designed part as an assembly component.

Your first objective will be to add the existing mixer housing as the
first component of the mixer_mfg assembly. All assembly links
will be on layer 11.

If necessary, from the main menu, choose
Applications→Assemblies.

Change the Work Layer to 11.

From the main menu, choose
Assemblies→Components→Add Existing.

In the Select Part dialog, select the Choose Part File button.

Select ama_mixer_body, then choose OK.

In the Add Existing Part dialog, change the component name
to mixer. It can be typed in upper or lower case.

If necessary, while still in the Add Existing Part dialog, choose
SOLID from the Reference Set pull-down menu.

The Add Existing Part dialog is still displayed.

Verify that the Positioning pull-down menu is set to
Absolute.

Choose OK in the Add Existing Part dialog.

The Point Constructor dialog is displayed.

Choose the Reset button in the Point Constructor dialog,
then choose OK.

The mixer body part is now a component of ***_mixer_mfg.

Cancel the Select Part dialog.

Step 3: Examine the current assembly structure.
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Display the Assembly Navigator by choosing the Assembly
Navigator tab in the resource bar.

Clicking once on the tab temporarily displays the
Assembly Navigator by sliding it to the left over the
graphics display.

Double-clicking on the tab displays the Assembly
Navigator in a separate window which can then be
moved and docked.

There are currently two parts in this assembly. The top-level
control part is ***_mixer_mfg, while ama_mixer_body is
the single component. Currently, only the component contains
any geometry.

The next step will be to create a new component that will
contain the WAVE casting body.

Step 4: Create an empty component, then apply the seed part
preferences.

Choose Assemblies→Components→Create New from the
menu bar.

In the File Name field, of the Select Part Name dialog, type
in ***_mixer_casting, then choose OK.

The Create New Component dialog is displayed.

In the Component Name field, type CASTING, then choose
OK.

A new component, named CASTING, is displayed in the
Component Name column of the Assembly Navigator.
The name of the part file is ***_mixer_casting. You may
need to display the Component Name column by selecting
MB3,Columns→Component Name.

Next, apply the layer and color standards from the seed part
file. In NX, all operations apply to the work part, which is
currently ***_mixer_mfg. To apply the seed part defaults, the
CASTING component should be the work part. For clarity, we
will also make it the displayed part.

In the Assembly Navigator, highlight the CASTING component,
***_mixer_casting, and using MB3 choose Make Displayed
Part from the pop-up menu.

To illustrate the lack of user-defined defaults, choose
Format→Layer Settings.
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Notice the category field is blank.

Choose Cancel in the Layer Settings dialog.

Choose File→Import →Part.

If necessary, in the Import Part dialog, uncheck Create
Named Group, then choose OK.

Browse to the ama_seedpart_in.prt, and double-click on it.

The Point Constructor dialog is displayed.

Choose OK in the Point Constructor dialog. Since no
geometry is being imported, position is not relevant.

Also, there is no interaction on the screen.

Choose Cancel in the Point Constructor dialog.

Choose Format→Layer Settings.

Notice the several different layer categories defined.

Choose Cancel in the Layer Settings dialog.

Step 5: Make the top-level part the displayed part, and save the
work created thus far.

In the Assembly Navigator, highlight ***_mixer_casting, and
using MB3, choose Display Parent→***_mixer_mfg.

In the Assembly Navigator, highlight ***_mixer_mfg, and
using MB3, choose Make Work Part.

Choose the Save icon on the toolbar.

When you save an assembly, all modified components
below the work part are saved as well.
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Linking Procedure

You use the Assemblies→WAVE Geometry Linker dialog to create associated
objects between part files. The linker allows you to copy geometry downward
into component parts, upward into higher level assemblies, or sideways
between components within an assembly. As you build your assembly you
will use the sideways functionality.

To create linked geometry:

• Arrange your assembly display so that the part containing the geometry
to be copied is visible, and the geometry of interest is selectable.

• Change Work Part to the part that is to receive the linked copies.

• Set the Work Layer to the layer you want to contain the linked copies.

• Choose Assemblies→WAVE Geometry Linker.

• Use the linker dialog to filter the type of object(s). You may select several
objects of different types.

• Choose Apply to make copies and remain in the Selection dialog, or OK
to copy objects and exit the dialog.

1-14 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



WAVE Geometry Linker in Manufacturing

Activity: Creating WAVE Geometry

In this activity, you will practice using the geometry linker. You will create
a WAVE linked copy of the mixer body, then perform modifications to that
copy to simulate a casting.

Step 1: Prepare the assembly.

If necessary, open the ***_mixer_mfg assembly part and then
the Assembly Navigator.

Highlight the component ***_mixer_casting in the Assembly
Navigator, and make it the Work Part by using MB3, and
selecting Make Work Part.

The mixer body, in the graphics window, fades to gray. This is a
visual clue that geometry is no longer in the current modeling
hierarchy.

The work layer is where linked geometry will be created.

Choose Format→Layer Settings.

Make Layer 1 the work layer.

Choose OK in the Layer Settings dialog.

Step 2: Create a linked body.

Choose Insert→Associative Copy→Wave Geometry
Linker.

It is possible to link types of geometry other than solid bodies.
Curves, Sketches, and Datum Planes are also commonly linked.

Choose the BODY icon in the WAVE Geometry Linker
dialog.

Select the mixer body.

Choose OK.

Step 3: Modify the display of the linked casting.

There are now two identical bodies, lying in the same model space;
the original mixer body and the linked copy. It can be difficult
to determine one from the other, it will be necessary to clarify
the differences. First, you will remove the original body from the
display. Then, you will change the display of the linked body.
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In the Assembly Navigator use MB3 over the
***_mixer_casting component, and choose Make Displayed
Part.

In the graphics window, use MB3→Replace View→TFR-TRI
from the pull-down menu.

Choose the Shaded icon from the main menu bar.

Choose Edit→Object Display.

Select the linked body and choose OK(green check mark) .

Using Edit Object Display is a powerful method
of differentiating between bodies that are similar in
appearance.

Change the Color to Yellow.

Choose OK in the Edit Object Display dialog.

Step 4: Make the top-level part the displayed part, then save the
work in progress.

At this point no physical difference exists between the mixer body
and the mixer casting. They do have a visual difference. In the
next activity, you will perform modeling changes to the mixer
casting.

In the Assembly Navigator, using MB3 on the
***_mixer_casting component, choose Display
Parent→***_mixer_mfg.

In the Assembly Navigator, using MB3 on ***_mixer_mfg,
choose Make Work Part.

Choose the Save icon on the toolbar.
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Simplify

Simplify is a powerful modeling tool that can be used to satisfy a wide range
of needs in developing models that are associative, but somewhat different.

Simplify provides a method of removing faces. This process must be able to
extend surrounding faces to "heal the wound" where the faces have been
removed.

Uses of Simplify:

• Remove "machined" features for preparing an as cast part from a body
that is not appropriately constructed for link At Timestamp, or from a
body whose features are not accessible.

• Remove details such as holes and blends for finite element analysis.

• In casting tooling work, core and pattern preparation in parts where the
regions were not modeled separately. Simplify can often be used both
to remove interior faces, for patterns, and to remove exterior faces, for
cores (if the system cannot heal wounds left by core removal, the pattern
designer must extract regions and sew core-print faces to obtain a core
body).

• Preparing a body for export to a supplier who need only be concerned with
the exterior envelope. Interior faces are removed using simplify, then the
simplified part is linked into a new part for export to the supplier. The
linked part has no "knowledge" of interior features in the original, but it
can still be updated by the owning company if the parent body changes.
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Simplify Body Procedure

You will use the Simplify Body function to remove holes from your mixer
casting body.

To simplify geometry:

• Choose as a retained face, one that will not be simplified away.

• Select the cylindrical faces of the holes as boundary faces.

• Deselect the boundary faces as retained faces.

• Choose Apply to perform simplification.

• Acknowledge the simplify notice.
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Activity: Using Simplify Body

In this activity, you will practice using Simplify Body as a tool to reduce the
complexity of a linked solid body.

Step 1: Make the CASTING component the work and displayed
part.

If necessary, open your ***_mixer_mfg assembly part and
then open the Assembly Navigator.

In the Assembly Navigator, use MB3 on the ***_mixer_casting
component and choose Make Displayed Part.

Step 2: Perform a Simplify Body operation on the five bolt holes
on the outlet face.

Choose Application→Modeling.

Choose Insert→Direct Modeling→Simplify.

The Simplify Body dialog is displayed.

The cue line reads Select retained faces.

Choose any face on the part that is not a hole, then choose OK
to advance to the next step.

The cue line reads Select boundary faces.

Choose the five cylindrical faces of the holes on the inlet face of
the mixer. Do not choose the cylindrical inlet face.
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When selected as a boundary face, NX also assumes that they
will be retained faces, and adds them to the retained face
selection. In this case, they will not be retained, so you will
deselect them from the retained faces set.

In the Simplify Body dialog, choose the Retained Faces
icon again.

Hold down the "shift" key, and deselect the five holes that were
previously chosen.

Choose Preview.

In the Simplify Body Preview dialog, choose Preview
Removed.

Only the hole faces highlight.

Choose Preview Retained.

Now all faces except the five holes highlight.

Choose OK in the Simplify Body Preview dialog.

Choose Apply in the Simplify Body dialog.

The Simplify Body information window gives the number of
faces removed and retained (in this case 5 faces are removed,
110 faces remain).
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Dismiss the Simplify Body information dialog by choosing OK.

Step 3: Simplify away the holes in the two bosses.

The retained face that was selected earlier is still active, so it is
not necessary to choose another.

In the Simplify Body dialog, choose the Boundary Faces icon.

Select the two cylindrical hole faces of the mixer tubes.

Choose the Retained Faces icon.

Using the procedure described previously, deselect the holes
as retained faces.

Preview the retained and removed faces.

Choose OK until the body updates.

Save the work in progress.
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Activity: Other Modeling Techniques

Previously, Simplify Body was used to remove unwanted geometry from the
Linked casting body. Now, you will explore other ways to modify a linked
body. The first option explored is Extrude.

Step 1: Make the CASTING component the work and displayed
part.

If necessary, open your ***_mixer_mfg assembly part and
then open the Assembly Navigator.

If necessary, in the Assembly Navigator, using MB3 on the
***_mixer_casting component, choose Make Displayed
Part.

Step 2: Use Extrude to fill in the ring groove.

Choose Application→Modeling.

Choose Insert →Design Feature→Extrude.

The Extrude Widget is displayed.

Choose the Extrude Dialog icon.

On the Selection toolbar change the type filter from Any to
Face.

Choose the bottom face of the ring groove, as shown below.
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Choose the Unite icon from the Boolean pull-down menu.

Under Limits, End, change from Value to Until Extended.

Select the outlet face, then choose OK on the Extrude dialog.

The O-ring groove has been removed from the outlet face.

Step 3: Use the Offset Face option to add machining stock.

In this step, you will add machining stock to the inlet and outlet
faces, as well as the mixer tube faces.

From the menu bar choose Insert→Offset/Scale→Offset
Face.

In the Offset Faces dialog, key in 0.250 for the offset value.

Select the inlet and outlet faces, and the two mixer tube faces.

Choose OK.
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The modeling changes are complete. It will be difficult to
visualize those changes in shaded mode, without a further
display change to the casting.

Step 4: Change the translucency of the casting.

To make it easier to visually distinguish between the original
designed part and the casting, you will make the casting model
translucent.

If necessary, use the Shaded icon to turn on shaded mode.

From the menu bar choose Edit→Object Display.

Select the body and choose OK.

Slide the Translucency bar to 50% and choose OK.

If the solid body does not become semi-transparent,
choose Preferences→Visualization Performance,
and turn off Disable Translucency, located on the
General Settings tab under Session Settings.

Step 5: Make ***_mixer_mfg the work part, and compare the two
solid bodies.

To fully realize the extent of the changes made, you will display
both the original and the linked body together.

Find and depress the Assembly Navigator button to activate
the Assembly Navigator.

Use MB3 on the CASTING component and choose Display
Parent→***_mixer_mfg.

In the Assembly Navigator, double-click on ***_mixer_mfg to
make it the work part.

Examine the two models.
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The CASTING component has stock added on the machined
faces. All drilled holes have been removed, as well as the ring
groove.

This is only one potential method for creating a simulated
casting body. Other methods and techniques could also have
been used. However, this method is fully associated to the
original, so that if the original body changes, the casting body
will update also.

At this stage, NC/CNC programming, using the CASTING
component as the BLANK, could now begin.

Choose File→Close →Save All and Close.
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Summary

The WAVE Geometry Linker provides an efficient method to associatively
copy geometry used for machining from a component part in an assembly into
a work part. The machining geometry is modifiable for manufacturing needs
but does not change the original design intent.

In this lesson you:

• Used Assemblies to enable "Best Practices" for modeling in manufacturing.

• Created a WAVE solid body that is associatively linked to the original.

• Modified the WAVE geometry to simulate a casting for machining.
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Lesson

2 In-Process Workpiece

Purpose

In order for you to make operations as efficient as possible, you must be able to
ascertain what has and has not been machined in each operation. Conditions
such as cutting tool lengths and diameters, draft angles and undercuts,
fixture and tool clearances, will affect the amount of material or stock that
each operation may leave. The representation of the material that remains
after each operation is referred to as the In-Process Workpiece or IPW.

Objective

Upon completion of this lesson, you will be able to:

• Use Auto Block to create blank geometry for the initial roughing operation.

• Turn on the Use 3D IPW option so that the IPW created by the previous
operation will be used as blank geometry in the current operation.

• Use the Previous IPW option to display the IPW being used

• Use the Display Resulting IPW option to display the IPW created in the
current operation.
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In-Process Workpiece (IPW) Overview

In a process commonly known as Rest Milling, the IPW is used for input
into the subsequent operation which may be used for additional roughing,
semi-finishing or finishing operations. The end result is a finished part that
has all excess material or stock completely removed.

Cavity Milling allows you to perform rest milling by creating an associative
In-Process Workpiece (IPW) in an operation and using it as blank geometry in
the next operation. It also allows you to display the previous and resultant
IPW for each operation.
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Activity: Creating and Using the IPW

In the following activity, you will create and use multiple In-Process
Workpiece (IPW) objects to rough, semi-finish, and finish a die cavity block.
The first Cavity Milling operation is provided. You will generate an IPW
in this operation and use it in a subsequent semi-finishing operation. You
will then generate an IPW in the semi-finishing operation and use it in a
subsequent finishing operation.

Step 1: Open an existing part, save with a new name and enter the
Manufacturing application.

Open the part ama_ipw_mfg_asmb.

Use the Save→As option under File on the menu bar and
rename the part to ***_ipw_mfg_asmbwhere *** represents
your initials.

Choose Application→Manufacturing.

If necessary, display the Geometry view of the Operation
Navigator.

An In-Process Workpiece (IPW) column can be added to
the Operation Navigator by clicking MB3 on the Operation
Navigator background, choosing Columns, and turning the
IPW option on.

Step 2: Displaying the Part Geometry.

The part geometry has been defined in the WORKPIECE parent
group.

In the Geometry view of the Operation Navigator, expand
all objects.

Double-click the WORKPIECE parent group.

The MILL_GEOM dialog is displayed.
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With the Part icon selected, choose Display.

Step 3: Define the Blank Geometry.

You will define the blank geometry using a method that creates a
solid body automatically by enclosing the part geometry.

Choose the Blank icon and Select.

The Blank Geometry dialog is displayed.

Turn the Auto Block option on.

A solid body bounding the part geometry is created. The XM,
YM, ZM fields allow you to modify the size of the body by
specifying offsets from each face.

Choose OK to accept the blank geometry with no additional
offsets.

Choose OK to accept the MILL_GEOM dialog.

Step 4: Generate the tool path.
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Highlight the CAVITY_MILL_ROUGH operation in the
Operation Navigator and using MB3→Generate, generate
the roughing tool path.

Choose OK to accept the Tool Path Generation dialog.

Refresh the graphics display.

Step 5: Create a Semi-Finishing operation.

You will create a semi-finishing operation that uses the IPW
defined by the roughing operation.

As shown below, select the Create Operation icon from the
Create toolbar.

The Create Operation dialog is displayed.

If necessary choose mill_contour as the type.

Choose CAVITY_MILL as the Subtype.

Specify the following parent groups.

Key in cm-semi-fin-1.0 in the Name field.

Choose OK to begin creating the operation.

Step 6: Use the IPW as blank geometry.

You will specify use of the IPW in the previous operation to define
the blank geometry in this current operation.

Choose the Cutting button.

The Cut Parameters dialog is displayed.
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Choose the Containment tab.

Select Use 3D from the pull-down menu for the In Process
Workpiece.

Choose OK to accept the Cut Parameters dialog.

The Blank icon at the top of the CAVITY_MILL dialog Main
property page has been replaced by the Previous IPW icon.

Choose the Previous IPW icon and then the Display button.

The processor may require some processing time to display
the faceted body.

This faceted body is the IPW that this operation uses as blank
geometry.

Step 7: Generate the tool path.

Choose the Generate icon and generate the tool path.
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Turn the three Display Parameter options off and choose
OK to continue generating the tool path.

Refresh the graphics display.

Step 8: Display the resulting IPW.

The IPW created by this operation can now be displayed.

Choose the Display Resulting IPW icon.

The processor may require some processing time to display
the faceted body.

This faceted body is the IPW the next operation will use as
blank geometry.

Refresh the graphics display.

Choose OK to complete the operation.

Step 9: Create a second semi-finish operation with a smaller tool.

You will now create a finishing operation that uses the IPW defined
by the semi-finishing operation.

Select the Create Operation icon from the Create toolbar.

Be sure CAVITY_MILL is selected as the Subtype.
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Specify the following parent groups:

Key in cm-semi-fin-.50 in the Name field.

Choose OK to begin creating the operation.

Step 10: Use the IPW as blank geometry.

You will specify that the IPW in the previous operation will define
the blank geometry in this operation.

Choose the Cutting button.

The Cut Parameters dialog is displayed.

Choose the Containment tab.

Select Use 3D from the pull-down menu for the In Process
Workpiece.

Choose OK to accept the Cut Parameters dialog.

Choose the Previous IPW icon and then the Display button.

The processor may require some processing time to display
the faceted body.
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This faceted body is the IPW that this operation uses as blank
geometry.

Key in 0.100 in the Global Depth Per Cut field.

Step 11: Generate the tool path.

Choose the Generate icon and generate the tool path.

Turn the three Display Parameter options off and choose
OK to continue generating the tool path.

Refresh the graphics display.

Step 12: Display the resulting IPW.

The IPW created by this operation can now be displayed.

Choose Display Resulting IPW.

The processor may require some processing time to display
the faceted body.

Choose OK to complete the operation.

The check marks in the IPW column indicate which operations
contain resulting IPW’s.
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If a new operation is inserted in the program sequence, if
an operation is deleted, or if the operations are reordered,
clock icons indicate that the resulting IPW’s are out of date.
This simply means that when generating the tool paths, the
IPW’s will need to be updated internally, requiring additional
processing time.

Save the part file.
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IPW and Performance

As you have noticed in the previous activity, generating the IPW takes
considerable computer resources. To improve performance, an option to store
the facet model representation of the IPW (FIPW) is available.

A new component part will be created that will be a combination of the work
part and operation name.

A reference set will be created within this part with the name of the operation
with FIPW added to this reference set. If the part already exists, the facets in
the reference set will be deleted and a new faceted body will be added.
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Summary

Rest milling can be performed by creating an associative In-Process
Workpiece \\(IPW\\) in an operation and using it as blank geometry in
the next operation. The In-Process Workpiece provides an efficient and
robust method of using material left by previous cutting operations as blank
geometry for the next operation in the program.

In this lesson you:

• Used Auto Block to create blank geometry for the initial roughing
operation.

• Turned on the Use 3D IPW option so that the IPW created by the previous
operation will be used as blank geometry in the current operation.

• Used the Previous IPW option to display the IPW being used.

• Used the Display Resulting IPW option to display the IPW created in
the current operation.
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3 Libraries

Purpose

This lesson introduces you to the concept of libraries as they pertain to the
Manufacturing Application. Libraries are used to access data for cutting
tools, machine tools, part materials, tool materials, cut methods and speeds
and feeds.

Libraries contain predefined entries, such as cutting tools and part materials,
and can be modified with user defined entries. Pre-V16 tool libraries
contained in part files can also be converted and utilized.

Objective

Upon completion of this lesson, you will be able to:

• Understand the concept and functionality of CAM libraries and data files.

• Add entries to existing libraries.

• Convert existing tool part file libraries to NX tool libraries.

©UGS Corp., All Rights Reserved Advanced Machining Applications– Student Guide 3-1



Libraries

Overview of CAM Libraries

Libraries are a convenient and easy tool that are used to access reference
data. Currently libraries can access information related to:

• Cutting tools

• Machine tools

• Part materials

• Cutting tool materials

• Cut methods

• Speeds and feeds

Cutting tool information is located in the file tool_database.dat and can be
modified through a text editor. Machining data, Cut Methods, Tool Materials,
Part Materials, Tool Machining Data, Machine Tools and Importing text
files can be accessed by selecting Tools → Edit Machining Data Libraries
and then selection of the appropriate tab. Respective, individual data files,
representing the above categories may also be modified through a text editor.

The configuration selected at the beginning of your CAM session (i.e.
mill_contour) defines the location of the various external libraries. Each
external library is represented by one line of information which identifies
library type and points to the Event Handler (file with .tcl extension) and
Definition file (file with .def extension) that are used for the Data Base
Connection (DBC). The Definition file is used to establish a class hierarchy
(the way tools are organized) and associated mechanism for queries,
establishes dialog layout definitions, attribute mappings, option menu
definitions, library reference names and delimiters.

All library files are located in the Mach\resource\library directory.
Subdirectories, under this directory, are categorized for feeds and speeds,
machine and cutting tools. Each subdirectory also contains additional
subdirectories of ASCII files.
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Included in each release of NX are the access mechanisms to the ASCII text
files. Sample ASCII based libraries are provided. GENIUS/4000 libraries
are optional.

The following pertains to library files in general:

• Some library files are opened and read by the system only the first time
they are read for performance reasons.

• When you edit library files, keep the library references (library references
are names given to every entry in the library) unique.

• After editing library files, reset the configuration to force any changes
to be read.

• Not all the information located in the library files are retrieved into the
part file. Extra fields are used to aid in selection by NX POST and Shop
Documentation.
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Activity: Preparation for modifying CAM Libraries

In order to modify the library or data files containing cutting tool information,
you will need read/write access to the library directory structure. Due to
the number of students in this class and the need to customize library
files, it is more conductive for each student to have a copy of the library
files in their home directory. In this activity you will make a copy of the
mach\resource directory structure to your home directory and modify the
directories for read/write access. Instructions are presented for Windows
and Unix separately.

Windows Environment:

Step 1: Copy the Mach\resource directory.

On the main menu bar, select Help → NX Log File to verify
the Mach directory being used by looking for the environment
variable UGII_CAM_BASE_DIR.

Open a Windows Explorer window and locate the directory
from the previous action item.

Highlight the Mach\resource directory, right-click on
Mach\resource directory and select Copy.

Highlight your home directory, right-click on your home
directory and select Paste.

Step 2: If necessary, copy the NX environment file, ugii_env.dat to
your home directory.

From the Explorer window locate the ugii_env.dat file in
the \xxx\ugii directory (where xxx represents the NX base
directory).

Highlight the ugii_env.dat file, right-click and select Copy.

Highlight your home directory, right-click on your home
directory and select Paste.

Step 3: Edit the ugii_env.dat file to redefine your Mach\resource
directory location.

Highlight the ugii_env.dat file from your home directory,
right-click and select Open.

Scroll down the file until you find the following line:
UGII_CAM_RESOURCE_DIR=${UGII_CAM_BASE_DIR}
resource\ and change the line to
UGII_CAM_RESOURCE_DIR=${Homedrive}resource\

3-4 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



Libraries

where Homedrive is the letter designator of the disk drive
where your home directory is located.

Save the file and exit from Notepad.

Step 4: If necessary, change the Read-only protection on your just
created local \Mach\resource\library directory to Archive.

With the Windows Explorer, locate your home
\mach\resource\library directory.

Highlight the directory and with MB3 select Properties.

Un-check Read-Only and then Check Archive.

Step 5: Restart NX.

Exit NX and then restart NX.

On the menu bar, select Help → NX Log File to verify that
your resource directory is being used.

Unix Environment:

Step 1: Copying the mach/resource directory.

On the menu bar, select Help → NX Log File to verify the
mach directory being used by looking for the environment
variable UGII_CAM_BASE_DIR.

Open a terminal window making sure that your default
directory is set to your home directory.

Copy the mach/resource directory to your home directory.
The path for the file will be the value obtained for
UGII_CAM_BASE_DIR. The format will be similar to the
following:

cp /usr/xxx/mach/resource (where xxx represents the NX
base directory).
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Step 2: Copying the NX environment file, .ugii_env to your home
directory.

Copy the .ugii_env file from /usr/xxx/ugii directory to your
home directory. The format will be similar to the following:

cp /usr/ugii/.ugii_env .

Step 3: Edit the .ugii_env file to redefine your mach/resource
directory location.

Edit the .ugii_env file from your home directory using the
vi or other Unix editor.

Find the following line in the .ugii_env file
UGII_CAM_BASE_RESOURCE=${UGII_CAM_BASE_DI
R}resource/ and change the line to
UGII_CAM_BASE_RESOURCE=${Home}/resource/.

Save the changes and exit from editor.

Step 4: If necessary, change the Read-only protection on your just
created local /mach/resource directory to rwed.

Change the directory protection by typing the following
command: chmod 777 ${HOME}/mach/resource.

Step 5: Restart NX.

Exit NX and then restart NX.

On the menu bar, select Help → NX Log File to verify that
your resource directory (based from your home directory) is
being used.
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Cutting Tool Libraries

Cutting Tool Libraries contain information related to all cutting tools used in
the generation of a tool path from an operation.

To access information in the cutting tool library, from the Create Tool dialog,
selection of the Retrieve Tool button (1), displays the Library Class Selection
menu for selection of the particular type of tool required for the operation
which you are about to create (milling, drilling, turning). Once the type of tool
is selected (2), the Search Criteria (3) is displayed, which allows you to search
for tools based on certain parameters. The search is then performed based
on information contained within the tool_database.dat file (modification of
this file, for the addition of your own tool entries, will be explained later in
this lesson) and a listing of the Search Results (4) is then displayed. Tools can
then be selected for retrieval into your part file for later use (5).

Cutting tool data is located in the Mach\resource\library\tool\ directory.
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This directory contains the following five subdirectories:

• ascii —–contains Definition and Event Handler files for ASCII text
databases. These files are used for the Data Base Connection and usually
are not modified by the user.

• english–contains the ASCII text database file (tool_database.dat) which
contains all the data records used for English tool descriptions.

This file is edited by the user when adding or modifying tool
data entries to the library.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.

• graphics-contains part files of tool assemblies used for advanced replays
with a solid tool. These assemblies are provided with the CAM release.

• metric—contains the ASCII text database file (tool_database.dat) which
contains all the data records used for metric tool descriptions.

This file is edited by the user when adding or modifying tool
data entries to the library.

The tool_database.dat files contains a list of tool data records that defines
parameters used for tool definition. This is the only file that needs to be
modified when you want to enter new tools. A data record consists of a record
type and associated parameters. There are three record types represented
in this file. They are:

• # which indicates a comment, the record is ignored.

• FORMAT which describes the type of parameters of subsequent DATA
records.
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• DATA which consists of parameters which describe the tool.

For example:

FORMAT LIBRF T ST DESCR MATREF MATDES HLD HLDDES DIA
FLEN FN HEI

describes the following data record:

DATA |ugt0201_001|02|01|End Mill|TMC0_00006|HSS-Co5-TiN |
320 | Steep Taper 20 | 10.5 | 35.3| 4| 55

Tool entries can be added to the Tool Libraries by two different methods. Data
records, as described previously, can be added to the tool_database.dat file
by simply editing the file or existing tools from current or legacy part files
can be extracted by activating the Shop Documentation icon (Information →
Documentation) and selecting Export Tool Library to ASCII datafile from
the Available Templates list box of the Manufacturing Part Reports dialog.
This will export all tooling data to the file that you designate. You then will
cut the tool data record(s) from the designated file and paste it into the
tool_database.dat file.

The following is an example of the various attributes used with the Tool
Library formats. All fields are documented within the file. Note that they are
not the same for each tool.

Note that the MATREF attribute is a reference to the cutter material located
in the file \MACH\resource\library\feeds_speeds\ascii\tool_materials.dat.
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Activity: Inserting Pre-existing Tools

Cutting tools with part files can be extracted and inserted into tool libraries.
This procedure will work with the pre-V16 as well as NX part files. The
following activity will take you through the process of inserting tools from a
part file into a tool library.

Step 1: Open the pre-existing part file containing tool entries.

Open the part file ama_lib_tools.

Step 2: Enter the Manufacturing Application.

Choose Application → Manufacturing.

The Operation Navigator and the Create Operation dialogs
are displayed.

Step 3: Export the existing tool entries to an ASCII data file.

Choose Information → Shop Documentation (or select the
Shop Documentation icon).

The Manufacturing Part Reports dialog is displayed.

Select "Export Tool Library to ASCII datafile".

Accept the default Output File Name.

Two files are created with a ".html" and ".dat" extension. The
".html" file is displayed in the information window when you
select OK. The ".dat" file contains entries that you will use to
insert into the tool_database.dat file.

Choose OK.
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Examine the listing window to see what tools have been
exported to the data file. Note at the end of the listing window
the location and name of the ".dat" file.

Step 4: Importing the tool data into the "tool_database.dat" file.

Open the file, tool_database.dat, in your home
MACH\resource\library\tool\english directory (Use the
Notepad editor).

Open the data file, ama_lib_tools.dat, created from Step 3,
and scroll to the area that begins with FORMAT LIBRF.

Select the lines beginning with FORMAT LIBRF and ending
with DATA |EM-1.00-06 (hold down MB1 and drag the mouse
through the lines).

Select MB3, then Copy.

Select the Notepad Window containing the contents of the file
tool_database.dat (this file was previously opened).

Select MB3, then Paste the contents into the file
tool_database.dat (You can paste anywhere in the file, but it
is suggested that you paste prior to the first FORMAT line).

Save the contents of the tool_database.dat file.
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Machine Tool Libraries

Machine Tool libraries contain information related to various machine tools
configured for CAM. This information is used by the Integrated Simulation
and Verification (IS&V) module used to simulate the execution of tool paths
on a particular machine tool and is also used to add machine tool entries
to the Postprocess dialog box (used to select a particular machine for post
processing).

To access information from the Machine Tool libraries, from the Machine
Tool view of the Operation Navigator, editing the Generic_Machine object
(1), displays the Generic Machine Selection dialog. Selection of the
Replace Machine button (2) from this dialog , presents the Library Class
Selection menu (3). Selection of the Machine type creates a query to the
machine_database.dat file (modification of this file, for the addition of your
own machine entries will be explained later in this lesson) with a listing of
the Search Results (4). Machine Tools can then be selected for later use (5).

Machine tool data is located in the Mach\resource\library\machine\
directory.
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This directory contains the following two subdirectories:

• ascii—–contains Definition and Event Handler files for ASCII text
databases. These files are associated with the Data Base Connection
(DBC) and usually are not modified by the user. It also contains the
machine_database.dat file. This file describes the various machine tools
configured for CAM. Attributes within this file reference machine type,
machine tool manufacturer, machine description, machine controller and
post processor which is displayed on the Postprocess dialog.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.

You can add or modify machine tool information by editing the data records
in the machine_database.dat file. Data records consist of library reference
(LIBRF), machine type (T), machine tool manufacturer (MNF), description of
the machine tool (DESCR), machine controller (CNTR) and the post processor
data file. Specifying the post processor data file specifies a specific post for
that machine tool.
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Activity: Machine Tool Libraries

In this activity, you will become familiar with the procedures to access
Machine Tool data from CAM Libraries. You will see how this library is
used in conjunction with the Postprocess dialog by replacing the Available
Machines with a 5–axis post processor.

Step 1: Open the part file.

Open the part file, ama_lib_function and if necessary, enter
the Manufacturing application.

Highlight the Program group object.

Step 2: Review available machines in the Post Process Dialog.

Select the Post Process icon.

The Postprocess dialog is displayed.

Choose Cancel or OK.

Step 3: Change the Postprocess Dialog to show a 5-axis machine
tool only.

If necessary change the Operation Navigator to Machine Tool
view.

Highlight the GENERIC_MACHINE object, using MB3,
select Edit.

The Generic Machine dialog is displayed.
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Select the Replace Machine button.

The Library Class Selection Menu is displayed.

Highlight MILL, then select OK.

The Search Result listing is displayed.

Highlight sim010101_008_in, then select OK until you are
back to the Operation Navigator.

Select the Post Process icon.

The Postprocess dialog is displayed.

Notice that only the FIVEAX_XY-TAB_Z_HD_AB-ROT_HOR
machine is displayed in the Postprocess dialog.

Choose the Cancel button.
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Part Material Libraries

Part Material libraries contains information which is used in the calculation
of feeds and speeds. This is not the same as Part Material used in Modeling.

To modify, insert or remove Part Material entries, select from the menu bar
Tools → Edit Machining Libraries and select the Part Material tab. Select the
desired Part Material from the Part Material list and make any modifications
necessary. New entries can be created by selecting the Insert button and
typing data in the appropriate fields.

Part Material can also be selected for individual Geometry groups. Part
Material data is located in the Mach\resource\library\feeds_speeds \
directory.

This directory contains the following two subdirectories:

• ascii—–contains Definition and Event Handler files for ASCII text
databases. These files are associated with the Data Base Connection
(DBC) and usually are not modified by the user. It also contains the
part_materials.dat file. This file defines part material used in the
calculation of feeds and speeds.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.
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You can also add or modify Part Material information by editing the data
records in the part_materials.dat file, using a text editor.

Data records consist of material code (MATCODE), material name
(MATNAME), material description (PARTMAT), material hardness
(HARDNESS) and part material library reference (LIBREF).
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Activity: Part Materials Library

In this activity, you will become familiar with accessing Part Material from
the Library.

Step 1: Add a new part materials which will become available for
selection.

Continue with the opened part, ama_lib_function.

If necessary, enter the Manufacturing Application.

If necessary, Select Tools → Edit Machining Data Libraries
from the menu bar.

Select the Part Materials tab.

Step 2: Insert a new part material.

You will insert a new part material that is similar to the existing
MAT0_00105, but has a slightly different hardness.

Select MAT0_00105 from the Edit Machining Data Libraries
dialog.

Choose the Insert button.

The Edit Part Material dialog is displayed.

You will change the Library Reference and the Hardness.

Key MAT0_00105A in the Library Reference field.

Key 220–225 in the Hardness field.
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Choose OK.

Scroll to the bottom of the list and note your new entry.

Do not save or close the part.

You are finished with this activity and will be using this part file in the next
activity.
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Cutting Tool Material Libraries

Cutting Tool Material libraries contains information which pertains to the
cutting tool material type which is used in the calculation of feeds and speeds.

To modify, insert or remove Cutting Tool Material entries, select from the
menu bar Tools → Edit Machining Libraries and select the Tool Material tab.
Select the desired Tool Material from the Tool Material list and make any
modifications necessary. New entries can be created by selecting the Insert
button and typing data in the appropriate fields.

To access information from the Cutting Tool libraries, in the Machine Tool
View of the Operation Navigator, editing any tool object (1) displays the Tool
Parameter dialog. Selection of the Material: button (2) from this dialog,
creates a query of the tool_materials.dat file with a listing displayed in the
Search Results dialog. Cutting Tool Material can then be selected from this
list (3).

Cutting Tool Material data is located in the Mach\resource\library
\feeds_speeds\ directory.
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This directory contains the following two subdirectories:

• ascii—–contains Definition and Event Handler files for ASCII text
databases. These files are associated with the Data Base Connection
(DBC) and usually are not modified by the user. It also contains the
tool_materials.dat file. This file describes cutting tool material which is
used in feed and speed calculations. This file is used in conjunction with
the tool_database.dat file which is used for the definition of cutting tools.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.

You can also add or modify Cutting Tool Material information by editing the
data records in the tool_materials.dat file by the use of a text editor. Data
records consist of cutting material code (LIBREF), material name (MATNAM)
and material description (MATDESC).
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Activity: Cutting Tool Materials Libraries

In this activity, you will become familiar with the Cutting Tool Materials
data. Cutting Tool Materials are used in the calculation of feeds and speeds.

Step 1: Accessing the Cutting Tool Material library.

Continue with the opened part, ama_lib_function.prt.

If necessary, enter the Manufacturing application.

If necessary, change the view of the Operation Navigator to
the Machine Tool view.

Highlight UGTI0203_017, select MB3, then Edit.

The Cutting Tool Parameter List is displayed.

Select the Material button.

The Search Result list is displayed.

Select the TMC0_00003 Carbide, Uncoated (Indexable) as
the material type.

Choose OK until your are returned to the Operation Navigator.

Do not save or close the part file.
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Cut Method Libraries

Cut Method libraries contain information which pertains to the Cut Method
type and is used in the calculation of speeds and feeds.

To access information from the Cut Method libraries, from the Machining
Method view of the Operation Navigator, editing any of the method objects (1)
displays the Method dialog. Selection of the Cut Method: button (2) from this
dialog, creates a query of the cut_methods.dat file with a listing of the Search
Results. A Cut Method can then be selected from this list (3).

To modify, insert or remove Cut Method entries, select from the menu bar
Tools → Edit Machining Libraries and select the Cut Method tab. Select the
desired Cut Method from the list and make any modifications necessary.
New entries can be created by selecting the Insert button and typing data in
the appropriate fields.

Cut Method data is located in the Mach\resource\library \feeds_speeds\
directory.
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This directory contains the following two subdirectories:

• ascii—–contains Definition and Event Handler files for ASCII text
databases. These files are used for the Data Base Connection (DBC) and
usually are not modified by the user. It also contains the cut_methods.dat
file. This file describes the "Cut Method" used for the Machining Method
in CAM. The library reference is used for feed and speed calculations.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.
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Activity: Cut Method Libraries

In this activity, you will become familiar with the Cut Methods Library.

Step 1: Accessing the Cut Method library.

Continue with the opened part, ama_lib_function.

If necessary, enter the Manufacturing application.

If necessary, change the view of the Operation Navigator to
the Machining Method view.

Highlight MILL_ROUGH, select MB3, then Edit.

The Mill_Method dialog is displayed.

Select the Cut Method button.

The Cutting Method Search List is displayed.

Select the OPD0_00010 MILL SIDE/SLOT MILL method.

Choose OK and notice the label on the Cut Method button.

Close the part.
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Feeds and Speeds Libraries

Feeds and Speeds libraries contains information which pertains to feeds and
speeds used in the generation of an operation.

Feeds and speeds information can be accessed while editing an operation
or from any of the Operation Navigator views. Select or highlight the
operation, use MB3 and choose Object → Feedrates (1). The Feeds and
Speeds dialog is displayed. Selection of the Reset from Table button (2) from
this dialog, will calculate the feeds and speeds based on data obtained from
the feeds_speeds.dat file, part material, tool material, cut method chosen
for the operation and Depth of Cut.

Feeds and Speeds data are located in the Mach\resource\library
\feeds_speeds\ directory.

This directory contains the following two subdirectories:
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• ascii—–contains Definition and Event Handler files for ASCII text
databases. These files are associated with the Data Base Connection
(DBC) and usually are not modified by the user. It also contains the
feeds_speeds.dat file. This file is used for defining feeds and speeds in
an operation.

• genius—contains the Definition and Event Handler files for Genius
databases. These files are not modified by the user.

You can add or modify Feeds and Speeds information by editing the data
records in the feeds_speeds.dat file. Data records consist of (LIBREF), Cut
Method Library reference (OPERTYPE), Part Material Library reference
(PARTMAT), Tool Material Library reference (TOOLMAT), Depth of Cut
(DPT_CUT_IN or DPT_CUT_MM), Surface Speed (SURF_SPEED_FPM or
SURF_SPEED_MPM) and Feed per Tooth (FEED_IPT or FEED_MMPT).

When adding entries for Feeds and Speeds, be sure that the Library Reference
for the Part Material (located in part_materials.dat), Tool Material (located
in tool_materials.dat) and Cut Method (located in cut_methods.dat) exist,
are unique and of the correct type.

Be sure to reset the configuration to force the update of the files that have
been modified.
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Activity: Feeds and Speeds

In this activity, you will set the options necessary for system generated feeds
and speeds. You will then change some of these settings to see how they affect
feeds and speeds which are calculated by the system.

Step 1: Open the part file.

Open the part file ama_lib_act_feeds_speeds and then
rename it to ***_lib_act_feeds_speeds.

Enter the Manufacturing application.

The Operation Navigator is displayed.

Step 2: Define the Part Material.

You only need to define the Part material once.

Change the Operation Navigator to the Geometry view.

Expand all of the Group objects.

Highlight Workpiece, then MB3, Edit.

The Mill_Geom dialog is displayed.

Choose the Material button.

The Search Result window is displayed. You will select the
material type from here.

Select Aluminum from the list and then choose OK twice to
return you back to the Operation Navigator.

Step 3: Define the Cut Method.
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You will now define the Cut Method by editing the MILL_ROUGH
method.

Change the Operation Navigator to the Method view.

Highlight MILL_ROUGH, then MB3, Edit.

The Mill Method dialog is displayed.

Choose the Cut Method button.

The Search Result dialog is displayed.

From this dialog, you can choose the type of cutting.

Select End Milling and then choose OK until you return to
the Operation Navigator.

Step 4: Define the Tool Material.

You can define the tool material when you first create a tool or
when editing an existing tool.

In this case, you are going to edit an existing tool.

Change the Operation Navigator to the Tool view.

Highlight the UGTI0201_013 tool name, then MB3, Edit.

The Milling Tool Parameters dialog is displayed. Note the
lower portion of the dialog. This is where you define the Tool
Material. Right now the material type is HSS COATED.

Choose the Material button.

The available tool material types are displayed.

Select TMCO_00002 Carbide on the list, then choose OK until
you return to the Operation Navigator.
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Remember, you could have also changed the Material type from
within the operation by editing the tool description.

Step 5: Define the Cut Depth.

This option is set from within the operation and is used in the
calculation of feeds and speeds.

You are now going to edit an existing operation.

Change the Operation Navigator to the Program view.

Expand all objects.

Highlight the operation named CAVITY_MILL. then MB3,
Edit.

The Cavity_Mill dialog is displayed.

Change the Global Depth Per Cut to .375.

Select the Cut Levels button under Control Geometry.

The Cut Levels dialog is displayed.

Change the Local Depth Per Cut to .375.

Choose OK until the Operation Navigator is displayed.

Step 6: Set the Feeds and Speeds.

Highlight the CAVITY_MILL operation.

Use MB3 and choose Object → Feedrates.

The Feeds and Speeds dialog is displayed.

Choose the Reset from Table button.
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The feeds and speeds parameters are calculated and displayed
in the value fields.

Choose OK to return to the Operation Navigator.

Resetting the speeds and feeds turns off the
inheritance of feed rates from the method parent.

Step 7: Changing the tool material and adjusting the Feeds and
Speeds.

You are going to change the tool material then recalculate the
Feeds and Speeds for the operation.

Change the Operation Navigator to the Machine Tool view.

Highlight the UGTI0201_013 tool name, then MB3, Edit.

Choose the Material button.

The Search Result dialog is displayed.

Select TMCO_00001 HSS on the list, then choose OK until
you return to the Operation Navigator.

Change the Operation Navigator to the Program View.

Highlight the Cavity_Mill operation.

Choose Object → Feedrates.
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Choose Reset from Table.

Notice the change in the speeds and feeds

Save and close the part file.
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Summary

Libraries are used for numerous applications in the Manufacturing
application. Libraries are convenient and easy tools that can be used to
access reference data with respect to cutting tool, machine tool, part material,
cutting tool material, cut method and feeds and speeds.

In this lesson you:

• Reviewed Cutting Tool Libraries.

• Inserted pre-existing cutting tools into libraries.

• Reviewed the Machine Tool, Part Material, Cutting Tool Material and
Cut Method Libraries.

• Changed various option settings to show their effect on feeds and speeds.
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4 Machining Faceted Geometry

Purpose

In numerous applications, faceted geometry is used to create prototype design
and manufacturing models. Direct Machining of Facets allows you to directly
machine faceted geometric without having to go through the tedious process
of converting the facets to a wire frame or solid geometric model.

Objective

Upon completion of this lesson, you will be able to:

• Import an STL file into NX.

• Generate tool paths on faceted geometry.

Direct Machining of Facets

It is extremely important for designers and manufacturing departments of
a company to be able to reverse engineer a product, when exact math data
may not be available, to be competitive in the marketplace. This example is
an ideal situations for Direct Machining of Facets (DMF). The process of
scanning or digitizing a part creates a cloud of points, which can be converted
into a faceted model. This faceted model can then be imported into NX for
modeling and or machining applications.

Real life examples such as the machining of dies and discrete part
manufacturing lend themselves to DMF.

The DMF allows you to generate tool paths on faceted part geometry without
the need to create surface geometry. DMF can be used with Fixed Axis Surface
Contouring, Cavity Milling and Z-Level Milling operations by allowing the
selection of Faceted Bodies as valid part geometry for tool path generation.
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Activity: Machining of Faceted Geometry

Step 1: Create a metric NX base file used for importing the faceted
model.

Choose File→New and name the part file ***_DMF, where
*** represents your initials.

If necessary, change the units to millimeters.

Choose OK.

A new part file has been created which will be used to import
the faceted model of the cavity of a plastic hair dryer. The
faceted model is in STL format.

Step 2: Import the faceted model.

Choose File→Import→STL.

The Import STL dialog is displayed.

If necessary select Angular Tolerance as Medium and STL
File Units as Millimeters.

Choose OK.

The Import STL File Selection dialog is displayed.

Select ama_facet_model.stl.

The faceted model data file usually has an ".stl" file extension.

Select OK.
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The file is imported into the NX "base" file which you previously
created.

Change the display to solid and fit the view to the screen.

Step 3: Create the Cavity Milling operation necessary to machine
the imported faceted model.

Enter the Manufacturing application.

The Machining Environment dialog is displayed.

Select mill_contour as the CAM Session Configuration,
select mill_contour for the CAM Setup and then select
Initialize.

Choose the Operation Navigator tab from the toolbar.

The Operation Navigator is displayed.

If necessary, change the view of the Operation Navigator to
the Program Order View.

Select Create Operation from the CAM Create toolbar.

The Create Operation dialog is displayed.

Select the Cavity_Mill subtype.
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Select OK.

The Cavity_Mill dialog is displayed. You will use an 8mm ball
tool, ugt0203_003, to rough out the cavity. Other parameters
used will be default parameters. You will first select the ball
tool and then the geometry to machine the part.

Choose the Groups tab from the CAVITY_MILL dialog.

If necessary, choose the Groups tab then chooseTool: NONE
and then the Select button.

The Select Tool dialog is displayed.

Choose the New button.

The New Tool dialog is displayed.
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Choose the Retrieve Tool icon and then choose OK.

The Library Class Selection dialog is displayed.

Expand the Milling group object and then double-click on the
Ball Mill (non indexable) object.

The Search Criteria dialog is displayed.

If necessary, choose the Millimeters radio button, key 8 in the
Diameter field and then choose the Count Matches button.
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Two matches, meeting the criteria of 8mm diameter, are found.

Choose OK from the Search Criteria dialog.

The Search Result dialog is displayed.

Highlight ugt0203_003 from the Search Result dialog.

Choose OK.

Select the Main tab from the CAVITY_MILL dialog.

Choose the Select icon from the Geometry section of the
CAVITY_MILL dialog.

Select the Facets radio button from the Part Geometry dialog.

You will now select all of the faceted geometry of the part.

Choose Select All from the Part Geometry dialog.

Select OK.

Step 4: Generate the tool path.

Choose the Generate icon and generate the tool path.

Examine the tool paths just created.

Close the part.
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Summary

Direct Machining of Facets (DMP) provides an easy and efficient method
of machining parts that have been reversed engineered and imported from
STL data files.

In this lesson you:

• Imported an STL file into NX, creating a faceted model.

• Directly machined a faceted model using the Cavity Milling operation
type.
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Lesson

5 High Speed Machining

Purpose

This lesson will introduce you to the concepts of High Speed Machining
(HSM), which increases productivity and improves the quality of the final part
being machined. HSM achieves these results through the use of consistent
volume removal concepts and smooth cutter path generation.

Objective

Upon completion of this lesson, you will be able to:

• Generate High Speed Machining operations.

• Generate Nurbs output.
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High Speed Machining- An Overview

The concept of High Speed Machining (HSM) is not new. The original concept
was conceived by Dr. Carl Salomon in 1924 and was patented in April of
1931. In recent years, the concept was further developed through United
States Air Force research funding and has slowly been brought out of the
classified world into the everyday commercial applications.

HSM technology has shown increases in productivity and improved part
quality. Characteristics of HSM are high spindle speeds, fast feed rates, light
cuts, smooth tool movement and constant volume removal. Due to the rapid
changes in dynamics of chip removal at these very high speeds, cut methods
and characteristics of the tool path are critical factors in the success of the
cutting process. Factors such as sudden stops, sharp corners, reversal of
cut direction and erratic tool movements will directly affect the speed at
which cuts are made.

There are two basic goals for HSM. They are:

• Maintain constant material volume removal

• Generate smooth tool moves throughout the entire cutting path

Applications abound in the aerospace and mold and die industry for HSM
technology. Cutting thin wall parts in the aerospace industry is a typical
application. In the mold and die industry, contoured surface cutting can
be accomplished at high spindle speed and feed rates. Incorporating very
small step overs results in very fine finishes that generally require no hand
finishing work. Since tool deflection is at a minimum, greater accuracies
can be achieved.

Basic requirements

HSM is currently being used in a variety of applications. Chip removal
characteristics translates into very high spindle speeds, typically
25000-100000 rpm. Corresponding feed rates from 250 -1200 ipm (or higher)
are typical. Due to these high spindle speeds and feed rates, heat is dissipated
through the chip, allowing the cutting tool to run cooler and being able to
keep its cutting ability for longer periods of time. The higher spindle speed
results in faster feed rates that will in turn maintain the proper chip load
per tooth. At these rates, the depth of cut can be reduced and high volume
removal rates can be maintained. The reduced depth of cut minimizes tool
and part deflection which results in better control of surface finishes and
part dimensions. HSM allows the roughing of parts to net sizes and shapes.
Reduced cutter stress also minimizes the risk of cutter breakage and allows
for longer production runs and unattended machining.

HSM also has the potential of reducing the time to manufacture. Normally,
much of the cost and time delay in manufacturing is due to two primary
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factors. First is the time that it takes to design the casting or forging and
then the time to do the manufacturing. Due to the higher material removal
rate associated with HSM, consideration can be given to manufacturing parts
from plate and bar stock rather than castings and forgings, saving the wait
time to normally procure the material.

HSM technology actually places a burden on programmers and the methods
which they use to produce tool paths. This is primarily a result of the NC/CNC
programs being longer because of shallow depths of cut and fine step overs.
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Methods for most High Speed Machining applications

The following methods should always be considered when doing HSM:

• Constant volume removal - an ideal goal is to maintain consistent volume
removal. With this goal, care must be taken when making step over
moves.

• Smooth tool movement - due to high feed rates, it is imperative to avoid
abrupt starts and stops as well as sharp corners. Acceleration at starts
and deceleration into stops are crucial. All corners should be rounded or
rolled, that is the cutter should make changes in its direction by going
through arc moves.

• Rounded or rolled exterior as well as interior corners.

• Multiple roughing tools and depth ranges - for deep cavities and pockets,
the preferred method of cutting is to use multiple tools with progressively
longer lengths. Shorter tools are rigid and can cut well when taking
deeper cuts. The depth of the feature(s) that are being cut is divided into
ranges that match the longer tool lengths.

• For roughing passes, use helical engage with a ramp angle of between
5-10 degrees. For semi-finish and finish cuts, use circular engages.

• When finishing, scallops must be kept to a minimum. Keep these heights
as low as 0.00005" and set Intol/Outol between 0.0005 and 0.00005".
This will substantially increase the size of the program but will greatly
decrease the amount of hand work to finish the part (if any) that must
be done.

• Optimization of tool paths - for tool paths cutting multiple regions,
engaging and retracting within those regions, optimization of the order of
those regions is necessary.

• Multiple pocket cutting order - must be able to specify the order of the
pocket or feature being cut to reduce part stress and part deflection.

• When cutting thin wall multi-pocket or cavity parts, always cut the level
first in all multiple features before progressing to the next level. This
should be done in both roughing and finishing to maintain rigidity in
the thin walls.
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High Speed Machining vs Conventional Machining

Conventional machining normally uses high speed steel or carbide cutters,
cutting up to 700 surface feet per minute (SFM), with feed rates up to 50
inches per minute (IPM). Tremendous heat is generated in the process. This
excess heat is transmitted to the cutter and work piece and is dissipated
through the use of large amounts of coolant.

High speed machining usually uses small, solid carbide, or large carbide
inserted tools. Cutting begins at 1000 SFM, with feed rates of 90 to 100
inches per minute without the use of coolant. With the use of coolant, feed
rates in excess of 1000 IPM can be achieved.

The key to successfully perform high speed machining are various methods
used in the cutting operations. Techniques such as roughing at a shallow
depth with maximum width of cut promotes longer tool life and higher cutting
accuracy. In some cases, semi-finish passes can be completely eliminated.
Tool paths, which are generated for these types of applications, need to use
very fine Intol/Outtol values (.0001") for optimum finishes. Scallop height
needs to be kept at a minimum with step over values set to .00005" or less.
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Activity: Creating a High Speed Machining operation

In this activity, you will edit a conventional pocketing operation, changing
parameters that will make the operation ideal for High Speed Machining.

Step 1: Open, then rename the part file and review an existing
operation.

Open the part file ama_hsm_1.

Save as ***_hsm_1, where *** represents your initials.

Enter the Manufacturing application.

This part file contains an operation that roughs a pocket with
default template settings and a clearance plane .100 above
the part. You will edit the operation and change numerous
parameters that will make the operation applicable to High
Speed Machining.

You will review the existing operation prior to making any
modifications.

If necessary, change the view of the Operation Navigator to the
Program Order view.

Highlight the operation, pocket_standard, use MB3 and
select Toolpath→Verify.

The tool path for the pocket_standard operation is displayed.
Pay particular attention to the method of engagement, the
sharp corners generated within the tool path, the depth of cut,
etc. The tool path display has been intentionally slowed so that
you may observe the various movements.

You will now edit the operation and modify parameters that
are applicable for High Speed Machining.

Cancel the Tool Path visualization dialog.

Step 2: Edit the existing operation and modify parameters suitable
for High Speed Machining.

Double-click on the operation, pocket_standard.
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The ROUGH_FOLLOW dialog is displayed.

Currently, all parameters set are default parameters. You will
now change parameters for High Speed Machining.

From the Stepover pull-down menu, select Tool Diameter
and then change Percent to 10. This will minimize the step
over value to 10% of the effective cutter diameter and will help
maintain constant tool loading conditions.

You will now change the parameters used for engagement from
one cut level to the next to Helical.
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Select Automatic under Engage/Retract.

The Automatic Engage/Retract dialog is displayed.

Select the Ramp Type pull-down menu and then select
Helical.

Changing the Ramp Type to Helical insures the tool
engagement at the next cut level will be with a helical move.
This will keep forces on the cutter consistent, more so than if
you were to plunge to the next level.

Note: Cutter geometry determines specific ramp angles and
overlap distance requirements.

Change the Activation Range to .0001 and choose OK.

Changing the Activation Range to this small value insures
that the cutter will not engage the part as it approaches the
walls.

Select the Cutting button.
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Select the Stock tab.

Change the Intol parameter to .00005 and the Outtol
parameter to .0005.

As the machine tool travels quicker and very accurately, a
much finer surface finish can be achieved. The movement per
block can be shorter to obtain the best dimensional accuracy.

Choose OK.

Select Corner.

This option will add a fillet at all corners (corner roll) which
eliminates sharp and sudden moves.
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Select All Passes from the Fillets pull-down menu and accept
the default of .020 for Fillet Radius.

Select Slowdowns (checked). Change Number of Steps to 10.

Slowdown is used to slow the feed rates as you approach
corners or obstructions in the tool path. Slowdown can
be controlled by length, starting location and the rate of
slowdown. Number Of Steps allows you to set the abruptness
of slowdown. The greater the number, the more even the
slowdown.

Choose OK.

Select Cut Depths.

The Depth of Cut Parameters dialog is displayed.
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Change the Maximum and Minimum values to .050.

Reducing the depth of cut while increasing feed rates is a core
process change of High Speed Machining. More material can
be removed in less time. An advantage of a shallower depth of
cut is less horsepower required to cut through the material.

Choose OK.

Select Feed Rates.
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The Feeds and Speeds dialog is displayed.

You now want to change your feed rate and spindle speed to
the maximum values that your HSM process can address; in
this example you will set the feed rate to 750 inches per minute
and the spindle RPM to 85000.

Change the Spindle Speed to 85000 and all Feed Rate values
to 750.

Changing all the feed rate values to the same feed rate insures
a constant load on the cutting tool.
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Choose OK.

Step 3: Create the tool path.

Choose the Generate icon and generate the tool path.

Examine the various motions. Once you generate the 1st cut
level, you may want to stop the display motion and change the
Path Display speed to 10. After generating the tool path at all
cut levels, list the tool path and examine the feed rates.

Choose OK to accept the operation.

Save the part file.
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Mixed Cut Directions

Cut patterns for high speed machining must allow constant volume removal
and eliminate burying the cutter into material. They must also provide
a smooth transition from level to level, eliminating constant retracting,
traversing and engaging.

Mixed cut directions are useful when large open areas are cut and you want
the cutter to cut back and forth instead of beginning each cut at the same end
of the part. This will minimize the time that is spent traversing between the
various cut levels and from the end of one cut to the beginning of the next.

The next activity will familiarize you with using mixed cut directions
and making direct moves when cutting between levels in a Zlevel cutting
operation.
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Activity: Mixed Cut Directions

In this activity, you will use the part file from the previous activity and
explore the use of the Mixed Cut Direction option.

Step 1: Edit the existing operation and modify parameters so that
the tool is in constant contact with the part.

Continue with the part file ***_hsm_1.

Double-click on the operation, zlevel_profile.

The ZLEVEL_PROFILE dialog is displayed.

Replay the tool path (you may want to slow down the display
speed).

Notice that the tool retracts and engages for each cut level.

You will now change the cut parameters to allow the cutter to
move directly from one cut level to the next without engaging,
traversing and retracting.

Refresh the graphics display.

Choose the Cutting button.

If necessary choose the Strategy tab.

Set the Cut Direction option to Mixed.
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Choose the Connections tab and change the Level to Level
option to Direct on Part.

Choose OK to accept the Cut Parameters.

Step 2: Create the tool path.

Choose the Generate icon and generate the tool path.

Notice how the cutting tool engages the part, feeds down the
wall of the part to get to the next level, and alternates the
direction of cut from one level to the next.

Refresh the graphics display.

Choose OK to complete the operation.

Save the part file.
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Nurbs

Many machine tool controllers have the option of creating non uniform
rational B-splines, commonly referred to as NURBS. NURBS output will
cause the tool to drive along these spline curves (degree 3, cubic splines)
instead of line/arc segments. The result is a very smooth and accurate surface
cut (particularly on contoured surfaces) that may result in reduced output for
the machine tool controller.

Not all controllers can handle NURBS, and those that do normally use
different formats. Currently, Fanuc, Seimens, Heidenhain and Fidia
controllers are supported for Nurbs input.

NURBS are available only for fixed axis machining methods of Fixed Axis
Surface Contouring, Planar Milling, and Cavity Milling.
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Activity: NURBS

In this activity, you will use the part file from the previous activity and
explore the use of the NURBS option.

Step 1: Edit the existing operation and modify parameters suitable
for the output of NURBS data.

Continue with the part file ***_hsm_1.

Double-click on the operation, pocket_standard.

The ROUGH_FOLLOW dialog is displayed.

Select the Machine button.

The Machine Control dialog is displayed.

Choose Nurbs from the Motion Output pull-down menu.

The Nurbs Motion dialog is displayed.

Join Segments determines whether or not the separate curve
segments join together into one curve to form a single Nurb
for each cut.

The finished part should not deviate from the design geometry
more than the specified Intol/Outtol if the defined Fitting
Control Tolerance is within the Intol/Outtol band. If a
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smoother path is desired, specify a tighter Fitting Control
Tolerance. When this option is used, the tool displays only at
the beginning and end of each cutting pass regardless of the
specified Display Frequency.

In addition to determining the degree of smoothness applied
to angles (as described above), Fitting Control Tolerance also
determines how accurately the tool path follows the NURB. A
tighter tolerance (defined by a smaller value) causes the tool
path to follow the NURB more accurately.

The Fitting Control Tolerance may be specified by either keying
in a value or by moving the slider bar.

Fitting Control Tolerance and Join Segments can be used
together to achieve the desired "polished" finished surface by
not only smoothing the surface, but also avoiding sharp turns
and irregular movements. By using a tight Fitting Control
Tolerance and an Angle Tolerance of less than five degrees, you
can fit to a smooth single NURB tool path.

Angle Tolerance is available when Join Segments is toggled
on. This option allows you to determine which angles formed
between the joined curves forming the NURB will be smoothed.
Angles smaller than or equal to the specified Angle Tolerance
will be smoothed. Angles greater than the specified Angle
Tolerance will not be smoothed. To obtain reliable results, you
should use an Angle Tolerance of 5 degrees or less.

Angles smaller than the Specified Angle Tolerance are
smoothed.

Larger Fitting Control Tolerance creates a smoother blend.

Choose Join Segments (checked) from the Nurbs Motion
dialog.

You will accept the other options as defaults.

Choose OK twice.

Step 2: Create the tool path.

Choose the Generate icon and generate the tool path.

Examine the output.
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List the tool path output.

Notice the tool path listing for NURBS, it will be similar to
the following:

GOTO/-1.9522,0.3426,-0.3950

GOTO/-1.9522,0.6165,-0.3950

GOTO/-1.9589,0.6739,-0.3950

NURBS/

KNOT/1.0000000

CNTRL/-1.9721,0.7307,-0.3950

CNTRL/-2.0055,0.7816,-0.3950

CNTRL/-2.0522,0.8165,-0.3950

PAINT/COLOR,37

RAPID

Close the part file.
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Trochoidal Cut Pattern

The Trochoidal Cut pattern is used when there is a need to limit excessive
step over to prevent tool breakage when the tool is fully embedded into a cut
and you want to avoid cutting excessive material. Most cut patterns generate
embedded regions between islands and parts during the engage process as
well as in narrow areas of a part.

The use of Trochoidal Cut pattern eliminates this problem by creating a
trochoidal cut offset from the part. The tool path cuts along the part and then
uses a smooth follow pattern to cut the regions inward. This cutting method
can be described as a method of milling where the cutter moves in a circular
looping pattern while the center of the circle moves along a path. This is
similar in appearance to a stretched out spring.

• (1) step over

• (2) Path Width

The following figure illustrates the Trochoidal Cut pattern. Note the looping
pattern. The cutter machines the material in small looping motions, spinning
as it moves in a looping cut pattern. Compare this with the conventional
method of cutting where the cutter moves forward in a straight path and is
surrounded by material on all sides.

This type of cut pattern is useful in high speed machining applications since
this method avoids embedding the tool in material and limits the amount of
step over which can occur. This cut pattern is available in Planar, Cavity
and Face Milling.
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Activity: Trochoidal Cut Pattern

In this activity, you will first examine an existing planar milling operation
that uses the Follow Part cut method. You will then change the cut method
to Trochoidal, select a different cutting tool and regenerate the operation to
observe the changes in the corresponding tool paths.

Step 1: Opening the part file ama_trochoidal_cut_method.

If necessary, start NX.

Use File→Open.

Navigate to your parts folder and open the file.

Briefly examine the part.

Step 2: If necessary, enter the Manufacturing application and
display the Operation Navigator.

Choose Application→Manufacturing from the menu bar.

Choose the Operation Navigator icon from the Resource bar.

If necessary, change to the Program Order view of the
Operation Navigator and expand the group objects.

You will notice one operation, PLANAR_MILL displayed. This
operation will be replayed and then modified by applying the
Trochoidal Cut method.

Step 3: Replay and then modify the PLANAR_MILL operation to
utilize the Trochoidal Cut method.

Double-click the PLANAR_MILL operation.

The PLANAR_MILL dialog is displayed.
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Choose the Replay icon.

The tool path is displayed.

You will now modify the operation by changing the Cut Method
to Trochoidal as well as using a different diameter tool.

Change the Cut Method to Trochoidal (1) and the Percent
(2) to 30.

Under the Groups tab, change the tool form UGTI0201_012
to UGTI0201_011.

Choose OK on the Reselect Tool dialog.

Under the Main tab, select the Cutting button.

From the Cut Parameters dialog, if necessary, choose the
Strategy tab.
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If necessary change Trochoidal Width (1) to Tool Diameter,
Percent (2) to 60.

Generate the tool path.

Step 4: Examine in detail, the tool path created using the
Trochoidal Cut method.

Zoom in on the various cut areas and examine the tool path in
detail.

Close the part file without saving.
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Summary

High Speed Machining technology has shown dramatic increases in
productivity and improved part quality. The characteristics of HSM such as
high spindle speeds, fast feed rates, light cuts, smooth tool movement and
constant volume removal are obtainable through various parameter settings.

In this lesson you:

• Explored various parameters within operations that lend themselves to
High Speed Machining concepts.

• Generated operations, using parameters that were conducive to HSM.

• Used the Trochoidal Cut method to generate tool paths that avoids
embedding the tool in material and limits the amount of step over.

• Explored parameters and techniques for generating NURBS output.
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6 NC Assistant

Purpose

This lesson will familiarize you with the functionality of the NC Assistant.
The NC Assistant is a very useful tool used to analyze corner and fillet radii,
draft angles and cutting depths. Analyzing these features will aid you in the
determination of the tool configuration needed to cut the part.

Objective

Upon completion of this lesson, you will be able to:

• Use the NC Assistant.

• Determine cutter geometry based on information feedback from the NC
Assistant.

Overview of the NC Assistant

The NC Assistant is an analysis tool that assists you in the selection of
the proper tool needed for machining various geometric configurations.
The Assistant provides you with information on planar levels (depths),
corner radii, fillet radii, and draft angles. The information provided is color
coded for easy detection on the model (model must be shaded) along with
an information listing giving pertinent data concerning the geometry being
analyzed. This information is useful in deciding the cutting tool parameters
which are necessary to machine the selected part geometry.
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The NC Assistant is activated once you are in the Manufacturing Application
from the Main Menu bar by choosing Analysis → NC Assistant.

You select the geometry to be analyzed and then set the various parameters.
Four Analysis Types are available: Levels, Corner Radii, Fillet Radii, and
Draft Angles.

When analyzing Levels, information is provided on the distance of planar
levels from a reference plane. If a reference plane is not specified, the MCS is
used as a reference. This information can be used as an aid in determining
the length of the tool(s) that is needed.

Analysis of Corner Radius provides information on the minimum corner radii
of the faces selected. This information will aid you in determining proper
tool diameter(s).

Analysis of Fillet Radius displays the minimum fillet radius of the selected
faces with reference to a vector. This information will help you to determine
the tool nose radius, required, if any.

Analysis of Draft Angle will determine the slopes of the faces selected with
reference to a specified vector. This information will help you to determine
the taper of the tool (also can be a quick aid in determining various areas of
draft on a casting or injection mold).

When analyzing the various types, limits can be set. For example, if you
wanted to check for all corner radii that were greater than .500 inches
and less than .750 inches, values can be set for the minimum of .500 and
maximum of .750.
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Activity: Using the NC Assistant

In this activity, you will become familiar with the various features of the NC
Assistant. You will use the NC Assistant to determine the length, cutting
diameter and corner radius of the tool(s) necessary to finish all pockets of the
part. Since you will only be analyzing this part, there is no need to rename or
save it.

Step 1: Open the part file and enter the Manufacturing Application.

Open the part ama_nc_assistant.

Enter the Manufacturing application.

Step 2: Activate the NC Assistant.

You will need to determine the tool configuration(s) necessary to
finish machine all pockets in this part. Visually, it is difficult to
detect draft, if any, on the pocket walls. It would be cumbersome
to verify all corner radii and floor depths. To make your job
easier, you will use the NC Assistant, to analyze the geometry
configuration. You will now activate the NC Assistant.

From the Main Menu Bar select, Analysis → NC Assistant.
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The NC Assistant dialog is displayed.

Step 3: Use the NC Assistant to determine cutter length.

The first item for consideration is to determine the length of the
cutter that will be needed. For this determination you will use
the NC Assistant to determine the various Levels. If you now
look at the cue line, you will see that you are being asked to set
parameters or select faces. You will accept the defaults for all
parameters and select the entire part for face selection.

Use MB1 and drag a rectangle around the entire part.

Choose Apply.

An Information Window is displayed containing the results of
the Level analysis.
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Notice the color set number, the colors associated with the
color set number, number of faces and distance. Compare the
colors with those now displayed in the graphics window. By
examining the distance values, the deepest level or floor is
located .800 below the top of the part (blue). Therefore the
length of the tool is .800 plus whatever clearance value that
you would want to use.

Step 4: Use the NC Assistant to determine cutter diameter.

The second item for consideration is to determine the diameter of
the cutter that will be required. For this determination you will use
the NC Assistant to determine the various corner radii of the part.

Choose Corner Radii from the Analysis Type pull-down
menu.
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The dialog for Corner Radii analysis is displayed.

Notice the limits for Minimum and Maximum Radius. If you
now look at the cue line, you will see that you are being asked
to set parameters or select faces. You will change the Radius
and Angle tolerances and select the entire part for faces.

Change the Radius value to .0001.

Change the Angle value to 10.0.

Use MB1 and drag a rectangle around the entire part.

Choose Apply.

An Information Window is displayed containing the results of the
Corner Radii analysis.
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Notice the color set number, the colors associated with the color
set number, number of faces and radius. Compare the colors with
those now displayed in the graphics window. By examining the
corner radii values, the largest is .300 (red), the smallest .230, the
closest standard size end mill required would be .4375 inches.
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Step 5: Use the NC Assistant to determine cutter corner radius.

The third item for consideration is to determine the corner radius
of the cutter that will be needed. For this determination you will
use the NC Assistant to determine the various fillet radii of the
part.

Choose Fillet Radii from the Analysis Type pull-down menu.

The dialog for Fillet Radii analysis is displayed.

If you now look at the cue line, you will see that you are being
asked to set parameters or select faces. You will accept all
defaults and select the entire part for faces.

Use MB1 and drag a rectangle around the entire part.

Choose Apply.

An Information Window is displayed containing the results
of the Fillet Radii analysis.
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Notice that there were no Fillet Radii displayed.

Step 6: Use the NC Assistant to determine draft angle on walls.

The fourth item for consideration is to determine any draft angles
on the part that are machinable through the use of an angle
cutter. For this determination you will use the NC Assistant to
determine the draft angles.

Choose Draft Angles from the Analysis Type pull-down
menu.

The dialog for Draft Angles analysis type is displayed.
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If you now look at the cue line, you will see that you are being
asked to set parameters or select faces. You will change the
Angle tolerance to 1.0 degree, accept all other defaults and
select the entire part for faces.

Under Tolerances, change Angle to 1.0

Use MB1 and drag a rectangle around the entire part.

Choose Apply.

An Information Window is displayed containing the results
of the Draft Angles analysis.

Notice the color set number, the colors associated with the
color set number, number of faces and angle. Compare the
colors with those now displayed in the graphics window. The
green faces represent 2 degrees draft, the cyan 5 degrees. All
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other walls have no draft. Two different angle cutters would
be necessary or a ball tool could be used to profile the draft
angle onto the wall.

Cancel the NC Assistant dialog and dismiss the Information
window

Close the part.
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Summary

The NC Assistant is an efficient tool to use for analyzing part geometry
for various corner radii, fillet radii, floor depths and draft angles. This
information is beneficial in the determination of cutter parameters used for
cutting your part.

In this lesson you:

• Became familiar with the functionality of NC Assistant.

• Performed various analysis functions which were used to determine cutter
length, diameter, corner radius and draft angle.
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Lesson

7 Templates

Purpose

Templates contain predefined parameters that enable you to quickly and
easily define new operations and group objects tailored to your specific needs.
Templates eliminate the tedious task of redefining parameters from a set
of standard defaults each time you define a new operation or group object
and allows you to customize your programming environment to your shop
standards and procedures.

Objective

Upon completion of this lesson, you will be able to:

• Understand the function and mechanism of templates.

• Create and use templates.

• Use a sequence of operations template to create numerous operations
automatically for similar parts.
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Templates Overview

Templates are operations and group objects within part files that contain
predefined parameters that allow you to define new operations and groups
quickly and easily for specific tasks. They determine the initial setup and
control the creation of operations, tools, programs, geometry and methods
group objects. They also reduce the laborious procedure of redefining
parameters from a standard set of defaults each time a new operation or
group is defined.

Templates are represented as Subtype (1) icons which are available in the
various Create dialogs (also referred to as object dialogs). They define
operation parameters including numerical values such as part Intol/Outol,
feed rates, etc. and can display customized dialogs.

In addition, templates determine the operations and groups that initially
appear in the Operation Navigation Tool when you first enter the
Manufacturing application.
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Template Part Files

A template part file contains a collection of predefined operations and/or
groups (templates) for selection. Template part files appear in the CAM Setup
portion of the Machining Environment dialog and are listed as Type options
in the operation and group creation dialogs.

In the above example, mill_contour is a template part file containing
predefined operations and groups which are represented by Subtype icons.

Template Sets

A Template Set is a collection of template part files. They are specified
from within the Configuration files. Basic Template Sets are provided and
maintained in each software release and/or may be created, customized
and maintained by users. Template Sets created by users may use
any valid naming convention, may be located in any directory and
must have a “.opt” file extension. Supplied Template Sets reside in the
\mach\resource\template_set directory.

The CAM Session Configuration window lists files with ".dat" extensions
containing the location of template files for operations, documentation, post
processors and libraries.

These files are located in the \mach\resource\configuration directory.
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The CAM Setup window lists Template Set files with ".opt" extensions
containing a list of part files with parameters used to generate the option.

These files are located in the \mach\resource\template_set directory.

You can specify the Template Set by selecting Preferences→Manufacturing
and then selecting the Configuration tab. You can browse and or specify the
directory and name of where the template set is located. When you specify
a template set, the available Type options in the object dialogs change to
reflect the new template set files. You may also select template files with the
Browse option in the Type option list.

When creating a new operation, you specify the template part by choosing
a Type and then the template by choosing an operation type (Subtype icon)
in the Create Operation dialog. The template parameters are then copied
into the new operation.

When creating a new Group, you specify the template part by choosing a Type
and then specify the Group Template by choosing the appropriate Subtype
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icon in the Create Program, Create Tool, Create Geometry or Create Method
group dialog.

Creating and Using Template Sets

Template Sets make template part files available for selection from within
dialogs. This prevents you from having to browse for individual part files. A
Template Set is a text file (.opt extension) listing the part files which contain
the templates that are to be utilized. The default Template Set is determined
by the Configuration file.

When creating operations or groups in part files that are members of a
Template Set, you may also want to customize the operation dialogs so
that only specific options are displayed when creating operations using the
template (verify that MB3 →Object →Template Setting →Template has been
toggled to on).

Once the template files have been created and saved, they are then grouped
together into a Template Set. A Template Set is simply an ASCII text file that
contains the directory path and file name of each template file in the set. This
file will always have a .opt extension associated with it.

The following flowchart, for the mill_planar default Template Set, shows the
relationship between various files used in Template Sets and their dialogs.
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The Type option (1) corresponds to the template file name.

The Subtype (2) option corresponds to the operation name within the
template file.

The selected Type determines the subtype options (3) (icons) that are available
(note that the subtype icon file names must match the subtype name).

The Name field (4) indicates the name of the operation or group object created.

The creation of tools within an operation will occur only if the template has
Load with Parent set to on. If the template loads a tool with the same name
but different parameters as a tool in the current part file, a new tool with a
different name is created with the new operation.

You can reset the current Template Set back to the default operation Template
Set by using the Reset to Default button in the Manufacturing Preferences
Configuration tab dialog. The default Template Set is determined by the
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Configuration file.

Creating a Template

As discussed earlier, a template is a predefined operation or group within
a part file. Template files can be new or can be copied, customized and/or
renamed from existing template files.

Template files can contain many operations and groups. You can specify
which operations and groups are used as templates by choosing the Template
Setting option in the Operation Navigator.
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Highlight the desired operations and/or groups in the Operation Navigator
(1) and with MB3 choose OBJECT (2) →Template Setting (3). This will
display the Template setting dialog which contains the Template and Load
with parent toggle settings.

If the Template option is toggled on (checked), the highlighted operations or
group will be available as a Template whenever the particular part is used
as a Template Part file. All operations and groups for which the template
option is toggled on (checked) will appear as subtype icons in the appropriate
Create dialogs.

The Load with parent option allows the determination of which operations
and groups will appear in the Operation Navigator when Setup is initially
selected from the Machining Environment dialog. It allows the specification
of certain operations and/or groups in addition to the current Parent Group
being created. For example, any time that an MCS geometry group is created,
a WORKPIECE geometry group is also created within the MCS geometry
group when Load with parent is specified for the WORKPIECE.

Load with parent allows the automatic loading of operations when creating
groups. This is useful when loading a predefined sequence of operations. The
operations which are loaded may have four parents (Program, Tool, Method
and Geometry) but only are loaded when creating Geometry groups. For
example, if you specify Load with parent in the Machine Tool view, the Parent
group, Tool will not load the operations. The Parent group, Geometry will.

The Load with parent option also allows the determination of which
operations and groups in a template part file will appear in the Operation
Navigator when the template part file is specified as a Setup in the Machining
Environment dialog. The Setup is the initial template part file which is
selected when first entering the Manufacturing application. When Load
with parent is specified for a continuous sequence of operations and groups
beginning at the parent root level, all of the operations and groups are
created when the part is selected as a Setup and will appear in the Operation
Navigator. An easy way to remember the Load with parent option function
is use to the following analogy: "Whenever you create my Parent group, I
will be created also."
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Activity: Creating a Template

In this activity, you will create rough and finish pocketing operations in an
existing part file. You will use this part file as a template for machining
pockets with different geometry in the activity which follows. This activity
establishes the template file settings.

Step 1: Open and rename a part file.

Open ama_single_pocket.

Save As ***_single_pocket, where *** represents your
initials.

Enter the Manufacturing application.

This part file contains several tools and blank geometry which
surrounds the part. The Configuration used is cam_general
and the Setup is mill_planar.

Select the Create Geometry icon from the Create toolbar.

The Create Geometry dialog is displayed.

Make sure the Type is set to mill_planar.

Step 2: Create a Geometry parent group to contain a sequence of
operations.

From the Create Geometry dialog, choose the Mill_Bnd icon.

Choose WORKPIECE as the Parent Group.

Change the Name to my_pocket_geom.

Choose OK twice to exit all dialogs.

Step 3: Create three template pocketing operations.

Choose the Create Operation icon from the Create toolbar.

The Create Operation dialog is displayed.

Choose the Rough_Follow icon as the subtype.
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Set the following:

• Program: PROGRAM

• Use Geometry: MY_POCKET_GEOM

• Use Tool: UGTI0201_025

• Use Method: MILL_ROUGH

Choose OK in the Create Operation dialog.

You do not need to create a tool path for this Template part file.
You will create a tool path in a future activity, using different
geometry with this template operation.

Choose OK in the Rough_follow dialog.

You will now create a template operation for finishing the
pocket floors.

Choose the Create Operation icon from the Create toolbar.

The Create Operation dialog is displayed.

Choose the Finish_Floor icon.

Change the Tool to UGTI0201_012.

Change the Method to MILL_FINISH.

Choose OK in the Create Operation dialog.

Remember that you do not need to create a tool path in a
template part file.

Choose OK in the Finish_Floor dialog.

Next, you will create an operation for finishing the pocket walls.

Choose the Create Operation icon from the Create toolbar.

The Create Operation dialog is displayed.

Choose the Finish_Walls icon.

Change the Tool to UGTI0201_011.

Choose OK twice.

You have just created a simple sequence for machining pockets.
The sequence can be automatically created in a later part file
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if the Load with parent and Template setting, for that
particular operation, is active. You will do this next.

Step 4: Make the pocket sequence available in other part files.

You will want the template operations that you have just created
to be available for use in another part. These operations will be
available only if the option, Load with parent, is toggled on.

Highlight the three operations ROUGH_FOLLOW,
FINISH_FLOOR, and FINISH_WALLS.

Use MB3→Object→Template Setting to set Template, off;
and Load with parent, on.

Choose OK.

The Load with parent setting assures that the three
operations will be created in a subsequent part file if the
Geometry parent group (MY_POCKET_GEOM) is created.
For this to occur, the parent group, MY_POCKET_GEOM,
must have the Template setting, Load with parent toggled
on.

Change the display of the Operation Navigator to the
Geometry view.

Choose the MY_POCKET_GEOM parent group and toggle the
Template and Load with parent, on (check mark the boxes).

Choose OK.

The template setting will create an icon in the Create Geometry
dialog in part files using this particular template file. The Load
with parent setting will automatically create the parent group.
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Save and Close the part file.
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Template Review

• Template Parts

– determine the initial Setup

– control the creation of operations, tools, programs, methods and
geometry groups

– the Setup is only selected once in a part file

– the Setup template part determines what is created in the work part
when the Setup is initialized

– the Setup template part becomes the first Type in the create dialog

– the Type is the template part for creating objects

– the Type template part controls what can be created in the work part

– the Type can be changed during a programming session

• Template Settings

– If Load with parent is active, then:

◊ if parent is created, so is the object

◊ any group object only has one parent

◊ any operation, has four parents and:

(1) the Geometry parent is the "Load with" parent

(2) if Tool, Method or Program are specified they are created if not
found in the work part

(3) template used determines if the tool is created with the
operation

– If Template is active, then:

◊ this object can be used as a template

◊ controls the icons created on the Create dialogs

◊ customized dialog and inheritance list are included
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• In general templates:

– for performance purposes, are opened and read only the first time
that they are required

– once it has been browsed, it remains on the list of Setups or Types for
the current session and will not be opened again, even if it has changed

– when editing, reset the Configuration to force the updated template
files to be read when you select or browse for them
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Activity: Using a Template

In this activity, you will use the part file that you created as a pocketing
template file to machine new pocket geometry. Since you specified most
options in the template file, including the operations, you will not need to
specify them in the new part file.

Step 1: Open a new part file and rename it.

Open ama_multi_pocket.

Save As ***_multi_pocket.

Choose Application→Manufacturing.

Choose the CAM Session Configuration as cam_general.

Choose the CAM Setup as mill_planar.

Choose the Initialize button.

In the Program Order view of the Operation Navigator, note
that no operations are listed.

Change to the Machine Tool view of the Operation Navigator
and note that no tools are present.

Change to the Geometry view of the Operation Navigator and
note that the MCS_MILL and Workpiece parent groups were
created by the selection of mill_planar as the Setup.

Since you chose mill_planar as the Setup, it is the current
template being used for this part.

Step 2: Change template files.

Another method of choosing a template is to change the Type in
the create dialogs. When using this method you are limited to the
options that are available in the template file.
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Choose the Create Geometry icon from the Create toolbar.

The Create Geometry dialog is displayed.

In the Create Geometry dialog, next to the Type label, choose
Browse and change mill_planar to ***_single_pocket.

Choose OK in the Template part dialog.

Notice that the only available Subtype is
MY_POCKET_GEOM. This is a result of the options
chosen when the original template was created.

Step 3: Specify Part, Blank, and Floor geometry.

You will create a parent group named MY_POCKET_GEOM and
specify the Part, Blank, and Floor geometry.

Choose the MY_POCKET_GEOM icon.

Choose WORKPIECE as the parent group.

Choose OK.
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The MY_POCKET_GEOM dialog is displayed.

In the MY_POCKET_GEOM dialog, choose the Part icon and
then Select.

Choose the Material side as Outside.

Using the Face Boundary method, select the top face of the
part.

Choose OK.

Choose the Floor plane icon and then Select.

The Plane Constructor dialog is displayed.

Set the Filter to Face.
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Select the floor of any of the pockets.

Choose OK twice.

You have specified all of the information needed to generate
the tool paths.

If necessary, change to the Geometry view of the Operation
Navigator and expand all parent groups.

Note the three operations created from the template to rough
and finish the part.

If necessary, change to the Machine Tool view of the
Operation Navigator and expand all parent groups.

Note the three tools created from the template used in roughing
and finishing the part.

Step 4: Generate the tool paths.

Change to the Geometry view of the Operation Navigator.

Choose the MY_POCKET_GEOM group object and using
MB3, Generate the tool paths.

The Tool Path Generation dialog is displayed.

Choose OK as necessary to continue generating the tool paths.
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The ROUGH_FOLLOW operation creates a tool path similar
to the following illustration:

The FINISH_FLOOR operation creates a tool path similar
to the following illustration:

The FINISH_WALLS operation creates a tool path similar
to the following illustration:

Choose OK to accept the tool paths.

Save and Close the part file.
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Review of the Procedure

This is a good time to review the several steps you took in creating the
pocketing sequence used for machining the previous activity. After this
review, you will see that you can also create a sequence of operations for
machining complex geometry just as easily. The complete sequence is built
upon the same principles you used in creating the previous pocketing
sequence.

These are the steps that you took in building the pocketing sequence:

In the Template part file, you:

• Created the Geometry parent group, MY_POCKET_GEOM which
contains the sequence of operations used to machine the part.

• You toggled the MY_POCKET_GEOM Template setting to on. This
creates the Subtype, MY_POCKET_GEOM in the Create Geometry dialog
when using this template in another part.

• You created Template operations under the parent group
MY_POCKET_GEOM, which roughed and then finished the floor and
walls of the pockets. The Load with parent setting was toggled to on and
the Template setting was toggled to off.

In the part file that used your template you:

• Used mill_planar as the Setup to Initialize the CAM session.

• Selected ***_single_pocket.prt as the Type (Template) using the Browse
feature.

• Created the MY_POCKET_GEOM group object in the Create Geometry
dialog (created by the template) which was used to choose the part and
floor geometry.

• Created three pocketing operations by selecting the part and floor
geometry. Most of the effort in creating these operations was through
the use of templates.
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Activity: Using the Die_Sequence Template

This activity shows the use of a die machining sequence of operations,
included in the Manufacturing application, to machine somewhat complicated
part geometry. This sequence is used to rough, semi-finish and finish a part
based on die machining practices.

Step 1: Open the part file.

Open ama_deep_core.

Save the part as ***_deep_core.

Choose Application→Manufacturing.

Choose the CAM Session Configuration mill_contour.

Choose the CAM Setup template die_sequences.

This is the template that contains the die machining sequence.

Choose Initialize.

The CAM Process Assistant for Die Machining is displayed.

The Process Assistant guides you in selecting the geometry
for the machining sequence.

Choose OK.
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The Process Assistant Step: 1 dialog is displayed, asking for
the selection of the MCS. By selecting OK, the MCS is set to
the WCS.

Choose OK.

The Process Assistant Step: 2 dialog is displayed. The part
and blank geometry were selected automatically. The Process
Assistant was designed to select the part and blank geometry
by searching for geometry with assigned attributes of those
names. The attribute names were assigned by the designer.
You do not need to select part or blank geometry for any
operation in this machining sequence.

In the Process Assistant Step: 2 dialog, choose Specify and
then create a clearance plane 25mm above the face as shown.

Choose OK until the Process Assistant Step: 3 dialog is
displayed.
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In the Process Assistant Step: 3 dialog, choose Display.

The part geometry is displayed.

Choose OK.

The Process Assistant Step: 4 dialog is displayed.

In the Process Assistant Step: 4 dialog, choose Display.

The Blank geometry is displayed.

Choose OK.

A dialog window appears, referring you to an information
window for further instructions. The information window
which is displayed, gives the steps necessary for creating a
machining sequence and/or individual operations.

Choose OK.

Choose the Create Geometry icon from the Create toolbar.

The Create Geometry dialog is displayed.

Notice the various Subtype icons on the Create Geometry
dialog. Each represents a cutting sequence ( Zigzag, Zlevel,
IPW, Profile 2D, Profile 3D).

Step 2: Create the Sequence.

In the Create Geometry dialog, choose SEQUENCE_ZLEVEL.
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Choose WORKPIECE as the parent group.

Choose OK.

A new Process Assistant starts.

The Process Assistance asks for the selection of the cut area
geometry. If you do not specify a cut area, all part geometry
will be machined by default.

At the prompt, choose OK to select all of the part geometry.

The Process Assistant Step:2 dialog is displayed asking you
to specify the trim area.

You can specify the trim boundary which limits the tool path
to the area inside or outside of the boundary. You will select a
trim boundary around the outside of the part to prevent the
tool from moving down the side of the part.

At the prompt to select the trim boundary, choose Select.

Set the Trim Side to Outside.

Select the bottom of the part and choose OK twice.

The Process Assistant Step:3 dialog is displayed asking you
to specify optional operations for cutting the part.

Choose OK.
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Choose OK for any other Process Assistant Steps.

The machining sequence of operations is created.

In the Operation Navigator Program Order view, expand
PROGRAM1 and note the various operations.

Step 3: Generate the tool paths.

Highlight the individual operations, group using MB3, select
Generate and examine each tool path individually.

Close the part file.
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More on Templates

Changing the Machining Environment

The option Tools→Operation Navigator→Delete Setup returns you to
the Machining Environment dialog. This option will delete all CAM
information in the part file and will allow the selection of another Machining
Environment. Note that use of this option will permanently remove all of
your operations, tools, etc.

The option Preferences→Manufacturing→Configuration tab, selecting a
configuration file, changes the CAM Session Configuration without changing
the Setup. The current data is preserved while the Configuration data (e.g.,
templates available, etc.) changes.

The option Preferences→Manufacturing→Configuration tab, Reset button
under Configuration File does not change Setup but it does restore the
original CAM Session Configuration.

Template Operations

The Template status for all Tools, Methods, Geometry and Programs is off
(by default).

The Template status for operations is on (by default).

Subtype Icons

Standard icons are provided for all Subtypes found in the standard Create
dialogs. When you are creating customized dialogs and using custom icons,
the icon file name must match the Subtype name in order for the correct icon
to appear on the dialog. Otherwise a default icon will be substituted

Icons are 24 x 24 x 16 color bit maps (.bmp file extensions). NX automatically
searches UGII_USER_DIR\application for bit map files. When creating
custom icons, place all icons in this directory and define the environment
variable UGII_USER_DIR located in the ugii_env.dat file.
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Activity: Using Icons in a Customized Template

In this activity, you will examine an existing template that is used for tapping.
The template contains center drilling, drilling and tapping operations, based
on tap size required. You will examine the template in detail and see how
custom icons are used for subtype representation. The use of custom icons
will further enhance your abilities to customize your machining environment.

Step 1: Open the existing template file.

If necessary, start NX.

Use File→Open.

Navigate to your parts folder and open the file
ama_tap_template.

Save the part as, ***_tap_template.

Enter the Manufacturing application.

Step 2: Examine the various operations.

Display the Program Order view in the Operation Navigator.

Note that operations were previously created to center drill,
drill and tap the various tap sizes that are available.

Display the Geometry view in the Operation Navigator and
expand the THREAD_1-4_20 geometry group object.

Pay close attention to the name of the individual geometry
objects. Individual bit maps have been previously created and
exist for each tap size. The names of these bit map files match
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the name of the geometry object. For instance, the bit map for
the THREAD_9-16_12 object is thread_9-16_12.bmp.

When this template is used by your part file, the Subtype
options will be represented by icons that have the same name
as the operation that you are performing.

If these names do not match, the default bit map icon will
appear.

NX, by default, uses the environment variable
UGII_USER_DIR\application to search for bit map files.
This variable must be set and is located in the UGII_ENV.dat
file. The environment variable, has already been set for you for
this activity.

To further show this relationship, you will rename the
group object, THREAD_3-4_10 to MY_THREAD. When the
template is retrieved in your part file, the default subtype icon
will appear for the THREAD_3-4_10 object.

Step 3: Rename the geometry object.

Highlight the THREAD_3-4_10 group object and using MB3,
rename the object to MY_THREAD.

Save the template part file.
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Step 4: Use the template file that you just modified.

You will retrieve an existing part file and change the template
to the template file that you modified in the previous step.
Remember that in order for modifications to the template file to
take effect, you must Browse or select the template file from the
type pull-down menu.

Open the part file ama_ipw.

If necessary, choose Application→Manufacturing.

Choose the Create Geometry icon from the Create toolbar.

The Create Geometry dialog is displayed.

Choose (or Browse) for ***_tap_template for the Type.

Choose OK.

The Create Geometry dialog is displayed. Note the default icon
for the 3/4 10 tap.

You will now rename the operation to match the existing
icon name and will reload the template for the change to be
implemented.

Cancel the Create Geometry dialog.

Step 5: Rename the operation and reload the template.

Change the displayed part to your template part file
(***.tap_template).

If necessary, change to the Geometry view in the Operation
Navigator.

Rename the MY_THREAD operation to THREAD_3-4_10.

Save your template part file.

Change the displayed part to ama_ipw.
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Choose the Create Geometry icon from the Create toolbar.

The Create Geometry dialog is displayed. You will now reload
the template.

Browse or select ***_tap_template for the Type.

The Create Geometry dialog is displayed, with the proper icons.

Choose Cancel.

Close all parts without saving.
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Customizing Dialogs

A unique and powerful feature of NX CAM is the ability to customize dialogs
by the addition or removal of items from operations, geometry or method
objects. You can also create you own unique dialogs. The following example
shows a standard NX dialog and the same dialog after customizing.

The Template status for operations is on (by default).
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Activity: Customizing Dialogs

In this activity, you will customize several dialogs.

Step 1: Create a template part file.

Customizing is practical for options and parameters that are used
numerous times with little or no changes being made. In this
activity you will create a new template part file to store the custom
dialogs that you create.

Navigate to your parts folder and open the file
ama_seedpart_in.

Save the part as, ***_customized_in.

Enter the Manufacturing application.

Use the CAM_GENERAL Session Configuration and the
mill_contour Setup.

Step 2: Customize a Cavity Milling Operation.

The first operation you will customize will be a Cavity Milling
operation.

Choose the Create Operation icon.

Choose the Cavity Milling icon from the Create Operation
dialog, in the Name field, key in CUSTOM_CM.

Choose OK.

The CAVITY_MILL dialog is displayed.

Towards the bottom of the dialog, choose the Options (1) icon.

The Other Parameters dialog is displayed.
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Choose the Customize Dialog button.

The Customize Dialog is displayed. This dialog consists of four
areas of importance:

• (1) scroll box consisting of items that are currently in the
operation dialog

• (2) scroll box consisting of items that can be added to the
operation dialog

• (3) dialog options allowing for property pages, scrolled
windows, group areas, labels, separator delimiters, More /
Less button, User Defined Events, and All other Parameters

• (4) in between the two scroll boxes (1) (2) are Add and
Remove arrows that push selected items from one scroll
box to the other

• (5) Up and Down arrows that allow the positioning of
various items within the dialog.

Start the customizing process by adding a More / Less item
to the dialog.
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In the Items Used scroll box (1), highlight the Start Page:
Main item.

At the bottom of the dialog (3), select the More / Less button.

This places the More / Less button on the dialog.

Currently, the More / Less button does not encompass any
dialog options. You will now position the end of the button
down, so that a portion of the dialog is within the confines of
the More / Less item.

In the Items Used scroll box (1) , highlight the End More/Less
item

Using the Move down arrow (5), move the item below the
Engage / Retract item (each click of the arrow will move the
item one position).

Choose OK.

Choose OK again.

The dialog is displayed in a much shorter form.
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Practice using the More/Less item to become more familiar
with it.

Choose OK to the Cavity Mill operation.

Step 3: Add a property page.

You will now add a property page and place items on the new page.

Highlight the CUSTOM_CM operation in the Operation
Navigator.

Use MB3, Object→Customize.

The Customize Dialog is displayed.

In the Items Used Scroll box (1), highlight the End Page:
Groups item.

Key in STUFF in the Label field.
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Select the Property page icon.

Choose the Preview button.

The Cavity Milling dialog is displayed with a new property
page.

Click on the STUFF property page.

The STUFF property page is blank. You will now add items
to this page.

Choose the Back button.

Highlight the Start Page: STUFF item in the Items Used
scroll box (1).

Highlight the Slowdowns item in the Available Items scroll
box (2).

Choose the Add button (4).

Choose the Preview button to review the additional item.

Click on the STUFF property page.

The STUFF property page has Slowdowns parameters listed
but lacks a clear label. You will now add the label.

Choose the Back button.

Highlight the Start Page: STUFF item in the Items Used
scroll box (1).
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In the Label field, key in SLOWDOWNS.

Click on the Label button.

Use the Preview button to view the dialog.

Choose the Back button.

Choose OK.

You have customized the Cavity Milling dialog. Take the time
to create a dialog for other operations that you may use on
a regular basis. Remember that you can use customizing to
change default values as well.
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Activity: Customizing a Program Header

In this activity, you will customize the Program object in the Program Order
view of the Operation Navigator.

Step 1: Examine the current Program object.

Continue using the part file from the previous activity.

If necessary, change to the Program Order view in the
Operation Navigator.

Double click on the Program object.

Note that the object will not open since the object contains no
data.

Step 2: Customize the program object.

Highlight the Program object.

Use MB3, Object→Customize.

The Customize Dialog is displayed.

There are no items in the Items Used scroll box. Specifically,
that is why double-clicking the Program object did not work.

Step 3: Create a User Defined Event.

You will add a User Defined Event (UDE) to the Items Used list.

Cancel the dialog.
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Highlight the Program object.

Use MB3, Object→Start Post....

The User Defined Events dialog is displayed.

Scroll down the list until the PPrint item is shown, then
double-click on the Operator Message item.

The Operator Message Item is displayed.

Key in This is a Comment in the text field.

Choose OK.

Choose OK on the User Defined Events dialog.

Step 4: Add the User Defined Event to the Program Object dialog.

Highlight the Program object in the Program Order view of
the Operation Navigator.

Use MB3, Object→Customize.
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Select the User Defined Events button.

The User Defined Events Customize dialog is displayed.

Highlight the Operator Message on the list.

Choose OK.

Choose OK in the Customize Dialog.

Step 5: Test the Results.

You have successfully added a User Defined Event to an object that
does not have a dialog. Since the item you added has a dialog, it
will be displayed when you double-click on the object.

Double-click on the Program object in the Program Order
view of the Operation Navigator.

The dialog exhibits the characteristics of the Operator Message
dialog.

On your own, add another User Defined Event to the Program
object (Hint: try the Origin UDE).
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Summary

The Template function provides an efficient means to customize your CAM
environment. Numerous parameters used by various operations, custom
operation sequences, tool and post processor availability, and numerous other
items that are used repeatedly, can be included into custom templates. The
possibilities are only limited to your imagination.

In this lesson you:

• Created a sequence of template operations.

• Interacted with a supplied template containing a sequence of operations
to machine part geometry.

• Became familiar with the advanced concepts of using templates.

• Became familiar with template icons; their naming conventions and
interactions.

• Customized dialogs.
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Lesson

8 Hole Making

Purpose

In this lesson, you will learn how to create and optimize a Hole Making
program.

Objective

Upon completion of this lesson, you will be able to:

• Create a hole making program that machines simple, countersunk, and
counter bored holes.

• Identify where tools must be edited or created for Hole Making and apply
the necessary changes.

• Tag simple geometry so to be recognized as machinable features for the
Hole Making processor.

• Optimize the Hole Making program.

• Use the features and functionality pertaining to Alternate Groups of
Operations, Cut Area, Feature Recognition, Feature Status, Holder Types,
3D In Process Work Piece, Maximum Cut Depth and Extended Length
and Multiple Selection.
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Hole Making Overview

Hole Making is an advanced manufacturing application that automates the
creation of operations such as spot drilling, drilling, countersinking, counter
boring, reaming, tapping, and deburring through the use of intelligent models
containing manufacturing features (User Defined Features, User Defined
Attributes, and NX based Features) and embedded machining rules.

Manufacturing features contain information that allows the Hole Making
processor to make machining decisions based on rules defined in templates
and applied through Knowledge Fusion. Manufacturing features most
commonly consist of NX modeled features such as simple, countersunk, and
counter bore holes and simple geometry such as points and arcs that contain
attributed information describing the shape and size of holes. Hole Making
groups similar features together (simple holes of a particular diameter, for
example), creates appropriate operations, chooses appropriate tools, specifies
cut methods and machining parameters, and outputs optimized tool paths.
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Hole Making Templates

A Hole Making template is a part file that contains predefined manufacturing
features, feature groups, tools, operations, machining rules and adopted
operations. The feature groups defined in the template contain features
modeled in various ways that the Hole Making processor will recognize in
your part. A countersunk hole, for example, can be a fully modeled feature or
simply a point with attributed information that describes its shape and size.
The Hole Making processor makes intelligent decisions about how to machine
these feature groups based on Knowledge Fusion rules.

Knowledge Fusion rules are associated with feature groups through Adopted
Operations displayed in the Knowledge Fusion Navigator. This association
allows the Hole Making processor to apply specific machining rules to feature
groups.
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Feature Groups

The Geometry view of the Operation Navigator associates manufacturing
features with feature groups. Feature groups organize operations according
to feature type. The feature group named SIMPLE_HOLE for example,
contains all operations (spot drill, drill, ream) that need to be performed on
simple holes of a particular diameter.
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The Knowledge Fusion Navigator

The Knowledge Fusion Navigator displays adopted operations. Adopted
operations are operations to which machining rules have been applied using
Knowledge Fusion.

When you create a program to machine simple hole features for example, the
adopted operations that apply to the machining of simple holes are copied
into the part file. The machining rules embedded in these adopted operations
determine which operations to use in the NC/CNC program based on the
properties and attributes of the features in the part. The operations that are
not needed are suppressed and are not displayed in the Operation Navigator.

To display the Knowledge Fusion Navigator you would choose Application
→Knowledge Fusion from the menu bar. You would then choose the
Knowledge Fusion Navigator tab in the resource bar.

Editing Knowledge Fusion rules requires a working knowledge of the
language in which the Knowledge Fusion rules are written and is typically
not done by the end-user. Knowledge Fusion will not be emphasized in this
course.
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Activity: Machining Holes

In this activity, you will create hole making operations that machine simple,
countersunk, and counter bore holes.

Step 1: Open an existing part, save with a new name and enter the
Manufacturing application.

Open the part ama_holemaking.

Save the file as ***_holemaking, where *** represents your
initials.

Choose Application→Manufacturing.

Step 2: Define the Machining Environment.

The Machining Environment dialog displays since the part has
not been saved in the Manufacturing application. The CAM Setup
you choose determines the template that will be used to define the
machining environment.

Choose hole_making as the CAM Session Configuration.

Choose hole_making as the CAM Setup.

Hole_making is the standard CAM Setup used for hole
making applications. Other setups may also be available
depending on your working environment.

Choose Initialize.

Step 3: Display Feature Properties.

You will display the feature name of a countersunk hole.

Choose the Select Features icon.
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Select the countersunk hole illustrated below.

Choose MB3, Properties.

The COUNTER_SUNK_HOLE Properties dialog is displayed
showing the feature name as COUNTER_SUNK_HOLE.

Since the hole making template also contains a feature called
COUNTER_SUNK_HOLE, the Hole Making processor will
recognize this feature and apply the appropriate machining
rules based on the shape, size, and surface finish of the feature.

Cancel the Feature Properties dialog.

Step 4: Display Object Properties.

You will display the properties of an attributed point.

Choose the Select General Objects icon.
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Select the point as illustrated.

Choose MB3, Properties.

In the Point Properties dialog, choose the Attributes tab.

Notice the feature name is SIMPLE_HOLE.

Since the hole making template also contains an attributed
point called SIMPLE_HOLE, the Hole Making processor will
recognize this point as a feature and apply the appropriate
machining rules based on the attributes.

Cancel the Point Properties dialog.

Step 5: Examine the Hole Making Template.

You will review the Hole Making template. You specified this
template when you chose hole_making as the CAM Setup. You will
see that this template contains a countersunk hole feature and an
attributed point similar to the ones you just observed in your part.
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In the menu bar, choose Window→More.

Choose hole_making in the Change Window dialog and
then choose OK.

Choose the Select Features icon.

Select the countersunk hole illustrated below.

Choose MB3. Properties.

In the COUNTER_SUNK_HOLE Properties dialog, notice that
the feature name, COUNTER_SUNK_HOLE, is the same
as the one in your part.

Since your part contains machinable features called
COUNTER_SUNK_HOLE, the Hole Making processor
will recognize all occurrences of this feature and apply the
appropriate rules for machining.

Cancel the Feature Properties dialog.

Choose the Select General Objects icon.
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Select the point (4th hole from the right corner) as illustrated.

Choose MB3, Properties.

In the Point Properties dialog, choose the Attributes tab.
Notice the feature name is SIMPLE_HOLE.

Since your part contains attributed points called
SIMPLE_HOLE, the Hole Making processor will recognize
all occurrences of this point as a machinable feature and will
apply the appropriate rules for machining.

Cancel the Point Properties dialog.

In the menu bar, choose Window→***_holemaking to display
the part.

Step 6: Specify an Appropriate Tool Axis.

You will specify a tool axis allowing the Hole Making processor to
create tool paths for holes at any angle (this would be applicable
for a 5-axis machine only).
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Double-click the Operation Navigator tab in the resource bar
and undock the Operation Navigator (using the Ctrl key) to
display in a separate window.

Display the Geometry view of the Operation Navigator.

Double-click on the MCS object.

Verify the Tool Axis option is set to All Axes.

Choose OK to accept the tool axis.

Step 7: Specify the Part Geometry.

You will specify the solid body as the part geometry.

Double-click on the Workpiece icon in the Operation
Navigator.

Verify the Part icon is chosen and choose Select.

Choose the solid body.

Choose OK to accept the part geometry.

Choose OK to accept the MILL_GEOM dialog.

Step 8: Create Operations to Machine Simple Holes.

You are now ready to create the operations that machine the
simple holes.
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Choose the Create Geometry icon on the toolbar.

Choose the SIMPLE_HOLE icon and verify the Parent
Group option is set to Workpiece.

Choose OK to create the operations.

The processor will take a few moments to process the
information.

Once the processing is complete, choose OK in the
SIMPLE_HOLE dialog to accept DIAMETER as the
classification criteria.

By choosing Diameter as the classification criteria, you have
specified that each feature group will contain operations
associated with simple holes of a particular diameter.

Display the Geometry view of the Operation Navigator and
expand the feature groups.

Notice in the Operation Navigator that two simple hole
feature groups, SIMPLE_HOLE and SIMPLE_HOLE_1 were
created. The simple holes in this part had only two diameters.
The simple holes of one diameter require spot drilling,
pre-drilling, drilling and deburring. The simple holes of the
other diameter require spot drilling, pre-drilling and drilling.
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Your results may differ slightly from those illustrated
above. Since the Hole Making processor assigns
feature group numbers randomly, the operations
listed in one feature group (SIMPLE_HOLE) might
be listed in the other feature group in your part.

Step 9: View the Information Window.

The Information window displays a record of the data that was
processed and the output that was generated.

Enlarge the Information window and examine the contents.

The Hole Making processor used the SIMPLE_HOLE
template, found ten simple hole features in the part and
classified these features into two feature groups according to
diameter.

Dismiss the Information window.

Step 10: Examine the Feature Groups.

Double-click on the SIMPLE_HOLE feature group icon in the
Operation Navigator.

The associated features, all of which have the same
diameter, are highlighted on the part. Your results may be
different for this particular feature group because the Hole
Making processor numbers the feature groups randomly. If
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double-clicking on SIMPLE_HOLE does not highlight the
holes illustrated below, double-click on SIMPLE_HOLE_1.

Choose Cancel to dismiss the Simple Hole dialog.

Step 11: Perform a Tool Query.

The Machining Method view allows you to perform a tool query
which displays the attributes the machining rules used when
selecting tools for each machining method.

Choose the Machining Method.

Expand the Machining Method groups.

Double-click on the SPOT_DRILL_METHOD group icon.

Choose Class under Tool Query.
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The Library Class Selection dialog indicates that Spot Drill
is the class of tool used for spot drilling operations.

Cancel the Library Class Selection dialog.

Choose Query under Tool Query.

This dialog displays the parameters for this tool class and the
specific Knowledge Fusion rule(s) that was applied. Editing
these items requires a working knowledge of the language in
which the Knowledge Fusion rules are written and is typically
not done by the end-user, and will not be covered here.

Cancel the Query from Method dialog.

Cancel the hole_making dialog.

Step 12: Generate the Spot Drill Tool Paths.

You will display the tools and generate the tool paths for the Spot
Drill operations.

Display the Program Order view of the Operation Navigator.

Double-click on the SPOT_DRILL_SIMPLE_HOLE operation
to display the operation dialog.
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Choose the Edit Display icon under Tool Path and set the
Tool Display option to 3-D.

Choose OK to accept the Display Options.

Generate the tool path. Your tool path might differ slightly.

Notice at the end of the part, only the outermost horizontal
holes are spot drilled and the operation does not attempt to
spot drill the inner holes. This is a result of each pair of holes
(the two holes drilled from the left and the two holes drilled
from the right) being modeled as a single feature.

Choose OK to accept the operation.

Step 13: Generate the Pre-Drill Tool Path.

You will display the tools and generate the tool path for the
PRE_DRILL_SIMPLE_HOLE operation.

Double-click on the PRE_DRILL_SIMPLE_HOLE operation
to display the operation dialog.

Choose the Edit Display icon under Tool Path and set the
Tool Display option to 3-D.

Choose OK to accept the Display Options.

Generate the tool path.
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Notice that the tool is not long enough to drill through the fork
area at the end of the part. This is a case where you will need
to edit the length of the tool.

Step 14: Edit the Tool Length.

Choose the Groups tab from the Hole_Making dialog.

With Tool:UGT0301_009 chosen, choose Edit.

Choose OK to the Group Editing warning message.

Change the Length to 425.

Choose OK.

Choose YES to the Edit Tool warning message.

Choose the Main tab.
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Generate the tool path.

The tools are now long enough to drill the full depth of the
holes.

Choose OK to complete the operation.

Step 15: Generate the Drill Tool Path.

You will display the tools and generate the tool path for the
DRILL_SIMPLE_HOLE operation.

Double-click on the DRILL_SIMPLE_HOLE operation to
display the operation dialog.

Choose the Edit Display icon under Tool Path and set the
Tool Display option to 3-D.

Choose OK to accept the Display Options.

Generate the tool path.

Again, the tool is not long enough to drill through the fork at
the end of the part. You will need to edit the length of the tool
as you did previously.

Change the length of the tool to 425 and regenerate the tool
path as you previously did.

Choose OK to complete the operation.

Step 16: Generate the Spot Drill Tool Path.

You will display the tools and generate the tool path for the
SPOT_DRILL_SIMPLE_HOLE_1 operation.

Double-click on the SPOT_DRILL_SIMPLE_HOLE_1.
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Choose Edit Display and set the Tool Display to 3-D.

Choose OK to accept the Display Options.

Generate the tool path.

This operation spot drills the 60 mm diameter holes defined by
attributes. If you look closely, you will notice that there are no
hole features modeled.

Choose OK to accept the operation.

Step 17: Generate the Pre-Drill Tool Path.

You will display the tools and generate the tool path for the
PRE_DRILL_SIMPLE_HOLE_1 operation.

Double-click on the PRE_DRILL_SIMPLE_HOLE_1.

Choose the Edit Display icon and set the Tool Display option
to 3-D.

Choose OK to accept the Display Options.

Generate the tool path.

Choose OK to complete the operation.

Step 18: Generate the Drill Tool Path.
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You will display the tools and generate the tool path for the
DRILL_SIMPLE_HOLE_1 operation.

Double-click on the DRILL_SIMPLE_HOLE_1.

Choose the Edit Display and set the Tool Display option
to 3-D.

Choose OK to accept the Display Options.

Generate the tool path.

This time you received an error message stating that no tool
has been specified.

The hole making template does not contain the tool required to
drill the 60 mm diameter holes.

Choose OK to the error message.

Choose OK to the operation.

Step 19: Add a Tool.

You should verify that every operation contains a tool. To
accomplish this look at the Geometry view of the Operation
Navigator. You can then add the required tools.

Display the Geometry view of the Operation Navigator.

Expand the SIMPLE_HOLE feature groups until you find the
operation that does not contain a tool.

You can display the diameter and depth of the holes defined
by the attributed points by selecting one of the points and
choosing MB3, Properties.
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You will find that the holes have a diameter of 60 and a depth
of 110. You can now create the required tool.

Double-click the DRILL_SIMPLE_HOLE_1 operation icon to
edit the operation.

Choose the Groups tab.

Notice that the Tool: option object is NONE.

Choose the Select button.

Choose New on the Select Tool dialog.

Choose the STD_DRILL icon and then OK to accept it.

Key in 60 in the Diameter field.

Key in 200 in the Length field.

Choose OK to create the tool.

Choose the Main tab.

Generate the tool path.

Choose OK to complete the operation.

Step 20: Create Operations to Machine the Counter bore holes.

Choose the Create Geometry icon in the toolbar.
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Choose the CB_HOLE icon and verify the Parent Group
option is set to Workpiece.

Choose OK to create the operations.

The processor will take a few moments to process.

Once the processing is complete, choose OK in the CB_HOLE
dialog to accept HOLE DIAMETER and C-BORE
DIAMETER as the classification criteria.

Dismiss the Information window.

Notice that one of the operations does not have a tool.

Step 21: Add a Tool.

You must first identify the features that are associated with the
CB_HOLE feature group. You can then analyze the feature to
identify the diameter and depth of the holes.
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Double-click on the CB_HOLE feature group icon.

Under Accessibility Vectors, choose Display.

The Vector is displayed in the Graphics window.

The vector identifies one of the features associated with the
CB_HOLE feature group.

Cancel the CB_HOLE dialog.

Choose Information→Feature from the toolbar.

Select the counter bore hole as illustrated.

Choose OK in the Feature Browser dialog.

The Information window indicates that the counter bore
diameter is 50 and the counter bore depth is 20.
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Dismiss the Information window.

You can now create the required tool.

Double-click the CBORE_CB_HOLE operation icon to edit
the operation.

Choose the Groups tab.

Notice that the Tool: option says NONE.

Choose Select.

Choose New.

Choose the COUNTER_BORE icon and OK to accept it.

Key in 50 in the Diameter field.

Choose OK to create the tool.

Choose OK to complete the operation.

All of the operations within the CB_HOLE feature group now
contain tools.

Step 22: Generate the Tool Paths for the Counter bore Holes.
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Highlight the CB_HOLE feature group and choose MB3,
Generate to generate the tool paths.

Choose OK to accept each one of the tool paths.

Save the part file.
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Tagging

The Hole Making processor recognizes NX based features such as simple
holes, countersunk holes, counter bored holes, and symbolic threads as
machinable features and applies machining rules based on their shape, size,
and other attributes such as surface finish. Simple geometry such as points
and arcs, can only be recognized by the Hole Making processor if they are
tagged. Recall in the previous activity that you were able to machine holes
where only tagged points represented the holes.

You were able to machine these points since they had been previously tagged
as simple holes with a specific diameter and depth. Tagging allows you to
apply attributes such as feature name, diameter, depth, tip angle, and surface
finish so that the Hole Making processor can recognize simple geometry as
machinable features and apply machining rules.
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Activity: Tagging Points

In this activity, you will tag pints so that the Hole Making processor
recognizes them as simple holes.

Step 1: Tag Points with Attributes.

Continue using ***_holemaking.

Choose Tools→Machining Feature Manager from the
menu bar.

The Machining Feature Manager is displayed.

Select the Tag Points icon.

Display the menu options next to Feature Name to see the
different feature names that can be assigned attributes.

Verify that SIMPLE_HOLE is specified as the Feature
Name.

Fill in the following values in the Tagging Attributes to
Points dialog. Verify the Surface Finish field has been
blanked out and that the Tolerance field says H7.

By specifying a tolerance of H7 the Hole Making processor will
include a reaming operation.
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Select the point as illustrated.

Choose Apply.

Select each of the remaining three points, choosing Apply
after selecting each point, for the attributes to be applied
individually to each point.

Close the Tagging Attributes to Points dialog.

Close the Machining Feature Manager dialog.

Step 2: Create Operations to Machine the Simple Holes.

Choose the Create Geometry icon in the toolbar.

Choose the SIMPLE_HOLE icon and verify the Parent
Group option is set to Workpiece.

Choose OK to create the operations.

Once the processing is complete, choose OK in the
SIMPLE_HOLE dialog to accept DIAMETER as the
classification criteria.

Dismiss the Information window.
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Step 3: Generate the Tool Paths for the Simple Holes.

Highlight the SIMPLE_HOLE_2 feature group and using
MB3, Generate the tool paths.

Choose OK to accept each of the tool paths.

You can double-click on each operation, choose the Edit
Display icon under Tool Path, set the Tool Display option to
3-D and Replay the tool path to see the tools.

Save the part file.
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Optimization

Optimization improves machining effectiveness by consolidating tools to
minimize the number of tools used, reordering operations to eliminate
redundant tool changes and resequences features to minimize the tool travel
distance.

The Optimization dialog displays three options:

• Consolidate Tools causes the program to use as few tools as possible
without compromising the effectiveness of machining.

• Minimize Tool Changes reorders operations to minimize the number of
tool changes that occur within the program. The Hole Making processor
does this without violating operation order constraints. For instance a
drilling operation will never be placed before a spot drilling operation.

• Create Optimization Group creates groups containing operations
that define an optimal tool path. Features cut with the same tool
are resequenced to minimize tool travel distance within and between
operations.
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Activity: Optimizing a Spot Drill Subprogram

Step 1: Open an existing part, save with a new name and enter the
Manufacturing Application.

Open the part ama_optimization.

Save the part as***_optimization, where *** represents your
initials.

Choose Application→Manufacturing.

Step 2: Generate the generic Tool Paths.

You will generate the tool paths for the existing SPOT_DRILL
sub operation to illustrate the inefficiency of the tool movements.

In the Program Order view, notice the excessive number of tool
changes in the SPOT_DRILL group object.

Highlight the SPOT DRILL sub operation icon and use MB3,
Generate.
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Turn the Pause After Each Path and Refresh Before Each
Path options off.

Choose OK to generate and display all of the tool paths for the
DRILL sub operation.

Choose OK to accept the tool paths.

Notice the excessive and disorganized non-cutting tool
movements.

It is more efficient to use one tool where possible regardless of
feature type and to minimize tool changes and traversals. You
will see how optimization can accomplish this.

Step 3: Optimize the Program.

Optimization should be done in the Program Order view. This
will allow you to observe the reordering of operations and the
creation of Optimization groups.

Choose the SPOT_DRILL subprogram icon in the Operation
Navigator and use MB3, Object→Optimize .

Verify that all three options are turned on and then choose OK
to begin the optimization process.

The Hole Making processor will take a few moments to process
the holes.

When processing is complete, expand the Optimization
groups.
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The number of tool changes has been reduced to four.

Step 4: Generate the Optimized Tool Paths.

Choose the OPTIMIZE_NC_3 object and then Generate the
tool path for this optimization group.

Choose OK to complete the tool path generation.

The Hole Making processor no longer machines manufacturing
features in the order according to feature type. As illustrated
below, all manufacturing features that can be cut by the same
tool regardless of feature type are grouped and an optimal tool
path is generated to minimize tool travel distance.

Choose the SPOT_DRILL object and then Generate the tool
paths for all of the optimization subprograms.

Save the part file.
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Additional Hole Making Topics

Alternate Groups of Operations

Alternate Groups of Operations allows you to create groups of operations that
perform machining tasks that are different than the feature templates that
are provided as a standard with Hole Making.

As an example, you can define one group of operations that drills before
countersinking and another group of operations that countersinks before
drilling. When defining the hole making process, you can then choose the
appropriate group of operations for machining that type of particular feature.
You would then use this option when you want to minimize the number of
feature templates being used.

Alternate Groups of Operations are created in the Geometry view of the
Operation Navigator by highlighting a feature group, and then by selecting
MB3 →Object →Alternate Groups of Operations. In the Alternate Groups of
Operations dialog, the upper list which is displayed contains the operations
allowed for the selected feature group. The lower list displayed contains the
alternate groups and their respective operations in their current order.

You can create the alternate groups in the lower list by choosing the New
Group icon. You may add operations to the alternate group by highlighting
the operation in the Available Operations list and then choose the Move
Operation to Group icon.

To delete operations or alternate groups, use the Delete Group/Operation
icon. For specific Knowledge Fusion rules, use the Alternate Group Rule field
to write the KF rule that will be used to decide which group of operations
will machine that particular feature group. For example, a rule might be as
follows: If the material of the part is steel, Alternate Group one is TRUE
else False.

Cut Area

Cut Area allows you to reduce the scope of machinable feature identifications
by creating a MILL_AREA group that identifies specific faces to be machined.
When there is no Cut Area geometry identified, the feature identification will
be the entire part. The WORKPIECE group should be specified as the parent
when creating this MILL_AREA group.
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The face geometry defining the Cut Area is specified within the MILL_AREA
group. Selected points and arcs will be identified during the feature grouping
regardless of part or Cut Area geometry since Cut Area geometry is based on
faces and part geometry is based on bodies. Points and arcs are considered as
neither faces or bodies.

Feature Recognition

Hole Making will recognize simple, counter bored and countersunk hole
features that have not been explicitly created as a NX feature. These features
are based on cylinders with diameter and depth parameters, cones with
maximum and minimum cone diameters as well as cone angle and planes.

A simple hole is created from a cylinder with planes designating the top and
bottom of the hole.

• (1) Cylinder

• (2) Cylinder and plane

• (3) Cylinder and cone

• (4) Cylinder, Cone, Plane

• (5) Cylinder, Cone, Plane
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A counter bored hole consists of a cylinder and plane, which designate the
counter bore with the addition of a simple hole feature.

• (1) Cylinder, plane, simple hole

• (2) Cylinder, plane, simple hole

• (3) Cylinder, plane, cone, simple hole

• (4) Cylinder, plane, cone, simple hole

• (5) Cylinder, plane, cone, simple hole

A countersink hole consists of a cone with the addition of a simple hole.

• (1) Cone, plane, simple hole

• (2) Cone, plane, simple hole

• (3) Cone, plane, cone, simple hole

• (4) Cone, plane, cone, simple hole

• (5) Cone, plane, cone, simple hole

To use this functionality, declare all simple hole, counter bored hole and
countersunk hole shapes as machinable features, create the operation and
generate the tool path.
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Activity: Feature Recognition

In this activity you will utilize the Hole Making processor to machine
simple, counter bored and countersunk hole shapes that have not been
created explicitly as features. You will first replay existing operations that
will machine the holes that have been modelled as features. You will then
use the Feature Recognition option to recognize holes that were created by
subtracting cylinders from the solid body. Finally, you will create operations
that will machine all of the holes in the part.

Step 1: Open the part ama_hole_making_feature.

Briefly examine the part.

Step 2: Enter the Manufacturing Application and display the
Operation Navigator.

Choose Application→Manufacturing from the menu bar.

Choose the Operation Navigator icon from the Resource bar.

If necessary, change to the Program Order view of the
Operation Navigator and expand the SPOT _DRILL, DRILL
and COUNTERBORE objects.

You will replay existing operations and observe that only
features which have been modeled are machined.
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Step 3: Replay the SPOT_DRILL_SIMPLE_HOLE and
SPOT_DRILL_CB_HOLE operations.

Highlight the SPOT_DRILL_SIMPLE_HOLE operation,
using MB3, Replay the operation.

Highlight the SPOT_DRILL_CB_HOLE operation, using
MB3, replay the operation.

Note that only four holes, that were previously modelled as
features, are recognized as machinable features and have tool
paths associated with them.

Replay the tool paths for the DRILL and COUNTERBORE
objects as well.

You will now create operations that will machine all of the
holes that are contained in the part.

Step 4: Create operations that will machine non modelled as well
as modelled features.

In order for the Hole Making processor to select the holes that
were not modelled as simple hole features, you will need to use
the Feature Recognition option.
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Choose Tools→Machining Feature Manager from the
toolbar.

The Machining Feature Manager dialog is displayed.

Select the Recognize Feature icon.

The Machining Feature Recognition dialog is displayed.

Set the Type to HOLE(1).

Set the Hole Type to SIMPLE_HOLE(2).

Select the body containing the features (part).

Choose the Apply button.

Choose the Part.
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The four holes are now recognized as being simple holes, are
displayed in the Feature List box of the Feature Recognition
dialog and are highlighted on the part.

You will now use the Feature Recognition function to recognize
the counter bored hole feature types as machinable features.

Set the Hole Type to COUNTER_BORE_HOLE.

Choose the Apply button.
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The four holes are now recognized as being counter bored holes,
are displayed in the Recognized Features box of the Machining
Feature Recognition dialog and are highlighted on the part.

Choose OK on the Machining Feature Recognition dialog.

Close the Machining Feature Manager.

You will now create the operations that will machine all holes
that are contained in the part.

Choose the Create Geometryicon.

If necessary, set the Type to hole_making and the Parent
Group to WORKPIECE.

Choose the SIMPLE_HOLE icon from the Create Geometry
dialog.

Choose OK from the Create Geometry dialog to begin
generating the operations.

The Information Window and SIMPLE_HOLE dialog is
displayed.

Dismiss the Information window and choose OK on the
SIMPLE_HOLE dialog.
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The diameter of the hole will be used as the classification
criteria. You will now create the operations for the counter
bored holes.

Choose the Create Geometry icon from the toolbar.

The Create Geometry dialog is displayed.

Choose the CB_HOLE icon.

Choose OK from the Create Geometry dialog to begin
generating the operations.

The Information Window and CB_HOLE dialog is displayed.

Dismiss the Information window and choose OK on the
CB_HOLE dialog. The diameter of the hole and counter bore
will be used as classification criteria.

You will now generate the tool paths.

Highlight the SPOT_DRILL object, using MB3, Generate
the tool path.

The tool path is generated.

Repeat the above process for the DRILL and COUNTERBORE
operations.

Close, without saving, the part file.
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Feature Status

The Feature Status option allows you to identify features that have not been
machined. This can occur due to collisions with clamps or the tool holder.

To check Feature Status, in the Geometry view of the Operation Navigator,
highlight the feature, use MB3→ Object→ Feature Status.

Holder Types

Holder Type is found in the Tap tool dialog and allows you to specify either a
rigid or float type tapping holder. For legacy operations, Holder Type needs
to be customized in the Tap dialog.

3D in Process Work Piece

Hole Making allows you to create and use an associative In Process Work piece
(IPW). Using an IPW assures that blank geometry is recognized and each
subsequent cut region is based on remaining material. This will prevent the
tool from colliding with any material that remains from previous operations.

The following illustration represents a tool path (1) not using and (2) using
an IPW:

When the IPW is not used, the tool will traverse through the material.
When using the IPW the tool traverses above and clears any material which
remains. In sequential operations, an IPW is created and then used as blank
geometry in the operation which follows. The resultant IPW can be displayed
for each operation.
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Activity: Using the IPW in Hole Making

Step 1: Opening the part file, enter the Manufacturing application
and display the Operation Navigator.

Open the file ama_hole_making_ipw.

Briefly examine the part.

Choose Application→Manufacturing from the menu bar.

Choose the Operation Navigator from the resource bar.

If necessary, change to the Geometry view of the Operation
Navigator and expand the group objects.

You will notice that operations exist to spot drill, drill, counter
bore and counter sink the holes in the part. Next you will verify
the part and blank material and will replay the operation
SPOT_DRILL_SIMPLE_HOLE.
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Step 2: Verify the part and blank material and then replay the
SPOT_DRILL_SIMPLE_HOLE operation.

Double-click the WORKPIECE object and display the Part (1)
and Blank (2) material.

The operation recognizes Blank geometry only if the IPW is
utilized. In this example, the Blank geometry, which extends
above the actual Part surface, in not recognized and the tool
collides with the Blank material.

You will now replay the tool path, and observe how the tool
collides with the Blank material.

Choose OK on the MILL_GEOM dialog.

Highlight the SPOT_DRILL_SIMPLE_HOLE operation,
using MB3, Replay the operation.

Note how the tool, when positioning from one hole to the next,
does not retract high enough, to avoid colliding with the Blank
material.

You will now activate the IPW, which will keep the tool from
colliding with the Blank material.Use 3D IPW option must be
customized into each HOLE_MAKING operation dialog.

Step 3: Incorporate and use the IPW.

Change to the Program Order view of the Operation Navigator
and if necessary expand all objects.

Highlight the SPOT_DRILL_SIMPLE_HOLE operation and
using MB3, select Object→Customize.

The Customize Dialog is displayed.
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Highlight Retract Distance On Tool Change from the
Items Used List.

This will be the area of the Hole_Making dialog in which the
Use 3D IPW option will appear.

Highlight Use 3D Workpiece from the Available Items list.

Select the ADD arrow to move the Use 3D Workpiece option
into the Items Used list.

Choose OK to accept the Customize Dialog.

You will now activate the Use 3D IPW that will enable this
operation to use the IPW.

In the Operation Navigator, double-click on the
SPOT_DRILL_SIMPLE_HOLE operation.

The HOLE_MAKING dialog is displayed.
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Set the In Process Workpiece option to Use 3D.

You will now generate the operation.

Choose the Generate icon.

Notice how the tool retracts to a higher position when moving
from one hole to the next.

Choose OK on the HOLE_MAKING dialog.

Close, without saving the part file.

©UGS Corp., All Rights Reserved Advanced Machining Applications– Student Guide 8-47



Hole Making

Maximum Cut Depth and Extended Length

Check Flute Length and Check Tool Length are parameters that are used to
verify that the appropriate tools are retrieved into the part when performing
tool queries from the tool library. Check Flute Length validates that the
tools copied from the tool library have a flute length that is long enough for
the required cut depth. Check Tool Length validates that the tools copied
from the tool library have a tool length that is long enough to avoid collisions
between the tool holder and adjacent walls of the part.

• (1) Cut Depth

• (2) Flute Length

• (3) Tool Length

Check Flute Length and Check Tool Length must be customized
into the HOLE_MAKING dialog.
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Activity: Maximum Cut Depth and Extended Length

In this activity you will first examine a Hole Making operation and observe
that the tool holder will collide with the work piece since the tool does not
have enough length to drill through the part. You will then search the tool
library for tools with appropriate tool lengths that can perform the required
operation without colliding with the part.

Step 1: Open the part, enter the Manufacturing Application and
display the Operation Navigator.

Open the part ama_hole_making_mx_ct_dp.

Briefly examine the part.

Choose Application→Manufacturing from the Menu bar.

Choose the Operation Navigator icon from the resource bar.

If necessary, change to the Geometry view of the Operation
Navigator and expand the group objects.

You will replay the DRILL_SIMPLE_HOLE operation and
observe how the tool holder collides with the part. When
the tool was selected originally from the library search,
consideration was not given to check the flute or tool length.

Step 2: Replay the DRILL_SIMPLE_HOLE object.

Highlight the DRILL_SIMPLE_HOLE operation, using MB3,
Replay the operation.
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Note how the tool, when positioning from one hole to the next,
does not retract high enough to avoid colliding with the part.
By using the Check Tool Length option when searching the
library for tools, collisions like those previously displayed can
be avoided.

If appropriate tools are not found in the search, you will be
prompted to create a new tool.

You will now use the Check Flute Length and Check Tool
Length options to search the tool library for proper length tools.

Check Flute Length and Check Tool Length option must be
customized into each HOLE_MAKING operation dialog.

Step 3: Incorporate and use the Check Flute Length and Check
Tool Length options.

Highlight the DRILL_SIMPLE_HOLE operation, and use
MB3→Object→Customize.

Highlight Tool Class Query from the Items Used List of the
Customize Dialog.

This will be the area of the Hole_Making dialog in which the
Check Flute Length and Check Tool Length option will
appear.

Highlight Valid Flute Tool Length from the Available
Items list.
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Choose the ADD arrow.

Choose OK to accept the Customize Dialog.

You will now retrieve tools using the Check Flute Length
and Check Tool Length options when querying the library.

From the Operation Navigator, double-click on the
DRILL_SIMPLE_HOLE operation.

The HOLE_MAKING dialog is displayed.

Choose the Groups tab at the top of the HOLE_MAKING
dialog.

The Check Flute Length and Check Tool Length options are
turned off. You will turn these options on and then query the
library for the proper tooling.

Turn the Check Flute Length and Check Tool Length options
on.
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Choose Reselect.

The Search Result dialog is displayed with the proper tool.

Highlight the tool from the list and then choose OK on the
Search Result dialog.

Choose the Main tab from the top of the HOLE_MAKING
dialog.

Choose the Generate icon.

Notice how the extended tool length now clears the part.

Choose OK on the HOLE_MAKING dialog.

Close, without saving, the part file.
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Multiple Selection

Features can be selected using the Class Selection dialog when appending
or removing them from a feature group. This allows the selection of several
features at once.

Inch and Metric Availability within Tool Query

Units options are selectable from the Query From Method dialog. The toggle
buttons available allow you to specify Inches or Millimeters as the units of
the tools to be retrieved into the part when performing queries from the tool
library. This allows you to search for metric tools in an inch part and inch
tools in a metric part. If the retrieved tool has a different unit from that of
the part, the tool parameter values are converted into the units of the part.
This setting is applicable only to queries that are being used in the ASCII tool
database. To specify the Units query parameter, double-click on a Machining
Method object in the Operation Navigator. Select Query and then select
either the Inches or Millimeters button.

Then accept the Query from the Method dialog. This setting will be saved
with the Machining Method object selected and is then applied to that object
when the query is executed and when subsequent tools are retrieved.

To execute a tool query, double-click an operation inside the Machining
Method object that has been edited. Select the Groups tab, turn the Tool
button on and choose Reselect. Then select the tool you desire from the
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Search Result dialog. If the query cannot find any tools in the specified Inches
or Millimeters library, then the Reselect Tool dialog will be displayed.
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Summary

Hole Making is an advanced application that automates the creation of
operations such as spot drilling, drilling, countersinking, counter boring,
reaming, tapping, and deburring through the use of intelligent models
containing manufacturing features (User Defined Features, User Defined
Attributes, and NX Based Features) and embedded machining rules. Using
Hole Making greatly simplifies the process of making holes, regardless of
the type of application.

In this lesson you:

• Created a hole making program that machines simple, countersunk, and
counter bore holes.

• Identified where tools must be edited or created and applied the necessary
changes.

• Tagged simple geometry so it would be recognized as machinable features.

• Optimized a program.

• Utilized Alternate Groups of Operations and Cut Area features of Hole
Making to further limit the types of holes to be machined.

• Used Feature Recognition and Feature Status to identify and utilize
specific features in the hole making process.

©UGS Corp., All Rights Reserved Advanced Machining Applications– Student Guide 8-55





Lesson

9 Integrated Simulation and
Verification

Purpose

In this lesson, you will learn how to use the Integrated Simulation and
Verification module to verify tool paths by means of machine tool simulation.

Objective

Upon completion of this lesson, you will be able to:

• Interact with the Integrated Simulation and Verification module.

• Configure and mount parts and fixtures on existing machine tools
configured for simulation.

• Simulate tool paths.
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Integrated Simulation and Verification Overview

The Integrated Simulation and Verification module (IS&V) allows you to
simulate a machine tool with an actual piece part, giving you an overview
of the entire machining process. The simulation process animates the exact
machine tool motions, taking into account controller functions and cutting
tool configurations.

IS&V features collision checking which allows collision detection between
machine components, fixtures, tools, parts and the in-process work piece. You
may also view machine controller functions including macros, subroutine
calls, cycles and function M, G and H commands.

IS&V can improve the quality of machining processes by allowing the
comparison of the designed part to the part which is being manufactured.
Reduction in cost can be obtained by the elimination of expensive and time
consuming dry runs; reduction in manual operator intervention; and the
reduced risk of expensive damage to machine tools, fixtures and parts by
elimination of collisions.

IS&V consists of the following components:

• Visualize

• Simulation

• Advanced Simulation

• Machine Tool Builder

• Machine Tool Driver

• Setup Configurator
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Visualize

• basic level of visualization of tool paths

• represents tool only moves, no kinematic model of machine tool

• performs gouge and collision checking with part and IPW

• display of material removal is 2D only

• optionally produces IPW used in roughing
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Simulation

• basic level of tool path simulation

• uses kinematic model of machine tool - simulation shows configuration
of machine including head and table movement

• common machine tool library

• common controller library

• shows collision detection with associated components
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Advanced Simulation

• uses kinematic model of machine tool - simulations shows configuration
of machine including head and table movement

• includes Machine Tool Builder capabilities

• provides gouge checking and collision detection

• provides methods to configure the manner of simulation (controller
configuration)

• includes interface to Post Builder - enhanced, to generate machine
controller drivers automatically (V3.1+ of Post Builder)

• provides the ability to simulate existing machine G & M codes (reverse
postprocessing)
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Machine Tool Builder

• used to build a Machine Tool or device

• uses geometric model, created as an assembly

• builds a kinematic model of machine tool members

• defines a mounting model

• animates motion along machine axis for testing purposes

• may edit model through associated kinematics tree manipulation
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Activity: Using Simulation

In this activity you will become familiar with some of the components used in
the simulation process. You will execute a simulation of sample components
supplied with this release of NX. For the simulation of the sample part to
work correctly, you must first define the search directory of where the files
are located.

Step 1: Define a new Search Directory for part retrieval.

If necessary, start NX.

Choose File→Options→Load Options.

The Load Options dialog is displayed.

If necessary, choose the Search Directories (1) option.
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Select the Define Search Directories (2) button.

An updated Load Options dialog is displayed.

Select the Browse button.

Filter to your home NX directory and then the MACH
subdirectory.
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Choose OK to the Choose Search Directory.

The directory name will appear in the "New Directory" field.

Focus on the "New Directory" field, add three period characters
to the end of the field and then select the Enter key from the
keyboard.

Choose OK on the Load Options dialog.

Choose File→Open.

Browse to your home MACH\samples directory.

Select the sim_1_machine_3x.prt from the Open Part File
dialog.

Choose OK.

If necessary, start the Manufacturing application.

If necessary, switch to the Program Order view of the
Operation Navigator.
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Using MB3 on the NC Program parent, select Tool
path→Simulate.

In the Simulate Control Panel, choose the Play button.

Open the part sim_10_lathe_horizontal and repeat the
simulation process.

Open the part sim_11_lathe_vertical part and repeat the
simulation process.

Close all parts without saving.
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Machine Tool Driver

• generates motion control program and emulates CNC controller

• accurate path based on machine tool configuration

• handles specific machine tool features including macros, cycles and
subroutines

• can be customized using Tcl scripting language

• text and graphics feedback initiated by Events

The Machine Tool Driver (MTD) creates the CNC program that emulates
the CNC controller. The CNC controller emulator (or Virtual NC controller)
is a programmable interface that instructs the machine tool model on
actual movements and how those movements are displayed. Any motion
and feedback displayed during machine tool simulation is controlled by the
dedicated MTD.

For comparison purposes, the MTD is analogous to the machine tool simulator
as the CNC controller is analogous to the machine tool that it controls. For
each machine tool in the machine tool library, there is a MTD driver available
(twelve generic MTD’s come standard with NX). For creating an MTD for a
new machine tool, you can modify a generic driver to work with that machine.
MTD’s are written in the Tcl scripting language but may also be developed
in higher level languages such as C++. MTD’s can emulate special cycles,
User Defined Events (UDE’s), macros and other CNC controller dependent
functions that the Manufacturing application does not support.
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Setup Configurator

• similar functionality to Machine Tool Builder

• used for mounting work piece and fixtures to machine tool

• used for defining machine state
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Activity: Use of Simulate on a Four Axis Part

In this activity, you will select a machine tool from the existing library of
machine tools, add a fixture and part component using the Machine Tool
builder and Mating Conditions, and then simulate a machining operation.

Step 1: Opening the part file ama_simulate.

If necessary, start NX.

Use File→Open.

Navigate to your parts folder and open the file.

Choose File →Save as ***_simulate where *** represents
your initials.

Briefly examine the part.

Step 2: If necessary, enter the Manufacturing application and
display the Operation Navigator.

Choose Application→ Manufacturing from the menu bar.

Choose the Operation Navigator icon from the Resource bar.

If necessary, change to the Machine Tool view of the
Operation Navigator and expand the group objects.
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Step 3: Selecting the machine tool.

Highlight the GENERIC_MACHINE group object, use MB3,
and choose Edit.

The Generic Machine dialog is displayed.

Select the Replace Machine button.

The Library Class Selection dialog displays.

Double-click on the MILL group object.

The Search Result list is displayed, showing the various
machines available for selection.

The machines beginning with "sim" are machines ready for use
in simulations. These machines have been previously modelled
with the kinematics (motion of machine tool members) already
defined and have Machine Tool Drivers already developed.

Choose the 4-axis vertical milling machine, sim010101_005_in
from the Search Result list.

Choose OK on the Search Result list.

Choose OK on the Generic Machine dialog.

9-14 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



Integrated Simulation and Verification

With the cursor in the graphic window, use MB3, Fit to size the
view to the graphics window.

The machine tool, sim010101_005_in has been loaded. You
must now mount the work piece to the machine. This is
accomplished by using the Machine Tool Navigator.

Step 4: Mounting the work piece to the machine tool.

Open the Machine Tool Navigator by selecting the Machine
Tool Navigator icon from the Resource bar.

Expand all objects.
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Two objects, Part and Fixture must be assigned.

Double-click on the Part component.

The Edit-K Component dialog is displayed.

Choose the Add button.

Select the part geometry.

Choose OK in the Class Selection widget.

Choose OK in the Edit K-Component dialog.

You will now select the Fixture component.

Double-click on the Fixture component in the Machine Tool
Builder dialog.

The Edit-K Component dialog is displayed.

Choose the Add button.

Select the fixture geometry.

Choose OK in the Class Selection widget.

Choose OK in the Edit K-Component dialog.

The components have been assigned to the machine tool and
have to be positioned to the center of the rotary table. You will
accomplish this by mating the two components using Mating
Conditions.

Verify that the Assemblies application is turned on.

Choose Assemblies → Components → Mate Components.
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The Mating Conditions dialog is displayed.

Choose the icon representing the center Mating Type.

Choose the cylindrical face of the headstock as the FROM face.

Choose the cylindrical face of the fixture as the TO face.

Choose the Mating Type, Mate icon.
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Choose the planar face of the headstock as the FROM face.

Choose the backside planar face of the fixture as the TO face.

Choose OK until the fixture is oriented to the machine.

Step 5: Simulation of the program.

Switch to the Program Order view in the Operation
Navigator.

Highlight the Program group object.

Using MB3, choose Tool Path → Simulate.

The Simulate Control Panel dialog is displayed.

You will set the options, necessary for collision checking
between the spindle nose and the part.

Select the Options button at the bottom of the dialog.

9-18 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



Integrated Simulation and Verification

The Simulation Options dialog is displayed.

Highlight Collision Checker.

Choose the Options button.

The Collision Configuration dialog is displayed.

In the Name field, choose SPINDLE from the drop down list.

From the top of the dialog, choose the Second Object or Class
icon.

In the Name field, choose PART from the drop down list.

Choose OK twice.

Select the Play button.

The operations are simulated. Try various settings and options
that are available to you on the Simulate Control Panel.

Save and Close the part file.
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Activity: Using a pre-built Simulation Machine

In this activity, you will use an existing Simulation Machine to simulate an
NC program. NX has numerous styles of pre-built machines ready for use.

Step 1: Opening the part file and examine the NC program.

Open the part file ama_isv_support_mfg.

This part is a manufacturing assembly of an aerospace support
strut. Due to the low quantity required, a solid block of
aluminum will be used for stock. The ama_isv_support_frame
component serves as a window frame around the part to hold
it in place.

Enter the Manufacturing application.

Display the Program Order view of the Operation Navigator.

Highlight the SIDE_1 operation, use MB3, Tool path→Verify.

Choose the 3D Dynamic tab on the Tool Path Visualization
dialog.

Choose the Play button at the bottom of the dialog.

The tool path is rapidly displayed. It is difficult to determine if
any collisions have occurred. You will use the IS&V simulation
tool to examine the object in greater detail.

Cancel the Tool Path Visualization dialog.

Step 2: Choose the Machine Tool for Simulation.

NX contains several pre-built IS&V machines in a library. You will
choose one of these machines to run your simulation.
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Change to the Machine Tool view of the Operation Navigator.

Highlight the GENERIC_MACHINE group object, use MB3,
choose Edit.

The Generic Machine dialog is displayed.

Choose the Replace Machine button.

The Library Class Selection dialog displays.

Double-click on the MILL group object.

The Search Result list is displayed, showing the various
machines available for selection.

Any item that begins with “sim” in the name is a ready made
simulation machine.

Choose sim010101_001_in from the Search Result list.

Choose OK on the Search Result list.

Choose OK on the Generic Machine dialog.
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With the cursor in the graphic window, use MB3, Fit to size the
view to the graphics window.

The machine tool, sim010101_001_in has been loaded and is
ready for use. Before testing can begin, you must specify the
relationship between the setup and the machine tool.

Step 3: Mount the manufacturing assembly to the machine tool.

Mounting a fixture or manufacturing assembly to a machine tool
can be accomplished in one of two ways. Option 1 is to place the
setup on the machine in a fixed location using Assemblies; option 2
is to use a Part Mount Junction. In this activity you will use the
Assemblies option.
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Verify the Assemblies application is on by choosing Application
from the main menu bar. There should be a check mark next to
Assemblies, if not turn the option on by clicking it.

This machine tool has a vice that will not be used and will be
removed from the display.

Choose the Assembly Navigator tab.

In the Assembly Navigator, use MB3, Expand All.

Choose the red check mark next to vise_body_3 to remove
from the display.

Choose the red check mark next to vise_jaw_3 to remove from
the display.

You will now mate the setup to the machine.

Choose Assemblies→Components→Mate Component (or
select the Mate Components icon on the Assemblies toolbar).

To perform the mating properly, you will mate the machine to
the setup, rather than mate the setup to the machine. This
method will maintain the correct MCS/WCS relationship.
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Verify the Mating_Type is set to Mate and the Filter is set to
Face.

Choose the top face of the machine table as the From (1)
object, and the bottom face of the blank as the To (2) object.

Choose Preview.

The machining center should move until the mating condition
is applied. You will now center the setup in the X-axis.
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Choose the Center icon and set the Center Objects at 2 to 2.

Choose the front face of the table as the First From (1) object
and then the front face of the blank as the First To (2) object.

Choose the back face of the table as the Second From (3)
object and the back face of the blank as the Second To (4)
object.

Use the Preview button to view the results.

The Status line should indicate that the mating condition is
fully constrained.

Step 4: Assign the Setup, Blank and Fixture Elements.
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Before testing can begin, the components of the assembly
representing the designed part, the fixture and the raw stock must
be defined.

If necessary, enter the Manufacturing application.

Select the Machine Tool Navigator tab.

Use MB3, in the Machine Tool Navigator to Expand All.

Examine the tree structure of the machine tool. Notice that
it describes the various elements that comprise the machine
itself. The SETUP sits on the X_SLIDE, which resides on
the Y_SLIDE. Notice the relationship of the SETUP and the
components that reside within it.

Double click on the Part element.

The Edit K-Component dialog is displayed.

Choose the Add button.

Choose the part isv_support, then choose OK until the Edit
K-Component dialog is no longer available.

Double click on the Fixture element in the Machine Tool
Navigator.

Remove the two existing components by highlighting them and
then choosing Remove.

Choose the Add button.

Select the two clamps and two bolts, then choose OK until the
Edit K-Component dialog is no longer available.

Double click on the Blank element in the Machine Tool
Navigator.

Choose the Add button.
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Select the translucent blank body, isv_support_stock and the
window frame, window_frame, then choose OK until the Edit
K-Component dialog is no longer available.

You are now ready to begin the simulation process.

Step 5: Simulate the Machining Process.

Close the Machine Navigator dialog.

Change to the Program Order view in the Operation
Navigator.

Highlight the SIDE_1 object, use MB3, Tool Path→ Simulate.

Choose the Play button on the Simulation Control Panel
dialog.

Choose OK when finished.

File→Close all parts.

This completes the activity.
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Activity: Using the Part Mount Junction

In the previous activity you used the concept of Assemblies to mount the
setup onto the machine tool. In this activity you will create a Part Mount
Junction to locate the manufacturing setup.

Step 1: Opening the part file.

Open the part file ama_isv_support_mfg.

Enter the Manufacturing application.

Step 2: Create a Part Mount Junction.

You must specify the Part Mount Junction on the setup. You must
first move the WCS to the position where the Part Mount Junction
will reside.

Make Layer 51 the Work Layer.

Move the WCS to the saved CSYS as shown.

Open the Machine Tool navigator.
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Highlight the NO_NAME object, use MB3, Insert→
K-Component.

The Create K-Component dialog is displayed.

In the Name field key in setup.

Choose OK in the Create K-Component dialog.

Use MB3 on the setup object and choose Junctions.

The Junctions dialog is displayed.

Choose Add.

Change the name to Part_Mount_jct.

Choose Define Coordinate System.

Since the WCS is already in the proper location, no movement
or manipulation of the CSYS is required.

Choose OK in the CSYS dialog.

Choose OK in the Edit Junction dialog.

Choose OK in the Junctions dialog.

Step 3: Define the Setup Geometry.

In the Machine Tool Navigator, use MB3 on the SETUP object
and choose Classify.
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The K-Component Classification dialog is displayed.

Select the _SETUP_ELEMENT component.

Choose OK.

In the Machine Tool Navigator dialog, use MB3 on the SETUP
object and choose Insert→K-Component.

Key in part as the Name.

Choose the ADD button.

Choose all of the setup geometry (part, blank, clamps).

Choose OK.

In the Machine Tool Navigator dialog, use MB3 on the Part
object and choose Classify.

Turn on the check mark adjacent to the _PART element.

Choose OK.

Step 4: Load the Machine Tool.

The final step is to load the machine tool from the library.

Change to the Machine Tool view in the Operation Navigator.

Highlight the GENERIC_MACHINE object, use MB3, choose
EDIT.

The Generic Machine dialog is displayed.
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Choose the Replace Machine button.

The Library Class Selection dialog is displayed.

Choose the MILL object, then choose OK.

From the Search Result list, choose sim010101_001_in, then
choose OK.

The Setup Replacement dialog is displayed. This dialog
indicates the presence of a Part Mount Junction and allows
the option to use if so desired.

If necessary, select the Position Machine on to Setup radio
button.

Choose OK.

The Setup is placed on top of the vise, on the machine table.

Choose OK in the Generic Machine dialog.

Step 5: Simulate the Program.

Close the Machine Navigator dialog.

Change to the Program Order view in the Operation
Navigator.

Highlight the SIDE_1 object, use MB3, Tool Path→ Simulate.

Choose the Play button on the Simulation Control Panel
dialog.

Choose OK when finished.

File→Close all parts.

This completes the activity and the lesson.
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Summary

The Integrated Simulation and Verification module (IS&V) allows you to
simulate a machine tool with an actual piece part, giving you an overview
of the entire machining process. The simulation process animates the exact
machine tool motions, taking into account controller functions and cutting
tool configurations.

In this lesson you:

• Reviewed the components that comprise the Integrated Simulation and
Verification module.

• Mounted a part and fixture to an existing machine tool for simulation
purposes.

• Used Mating Conditions to mount the setup to the machine.

• Used a Part Junction to mount the setup to the machine.

• Ran simulation on a sample part.
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A Advanced Surface Contouring

Projection

Mathematics of Projection:

• Place tool end at drive point

• Project tool along projection vector

• Tool stops when making contact with part

• If necessary, adjust the tool axis and repeat the above steps until the
tool axis is satisfied

• Add more intermediate drive points to satisfy the Intol/Outol with the part

Projection and Steep Surface:

• �X = �d/sin���d/�

�X becomes large if � is very small (steep surface)

• The source of �d is the chordal deviation of the drive path
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Projection and Material Side:

• Surface contouring does not have explicit definition of material side for
part geometry, only the drive surface has explicit material side

• Material side of the part is determined implicitly by the projection vector

• In the case of Area Milling Drive (no projection vector), the tool axis vector
is used to decide Material Side

Tool Axis

Definition of Lead/Tilt angles:

• Begin with cut vector, rotate it toward the Reference vector 90 - � degrees

• Then rotate around the cut vector � degrees (counter clockwise)

• Reference vector is the surface normal relative to the part/drive or a
vector which is relative to a vector
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Definition of 4-axis rotation angle:

•

The unconstrained tool axis vector could be:

• Normal to Part / Drive

• Relative to Part / Drive

Interpolated tool axis algorithm:
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Drive Surface

Remap of drive surface:

Remap algorithm:

Swarf developable surface:

• Developable surfaces are special kinds of ruled surfaces when the surface
normal vectors on any given rule line are the same (ruled surface without
twisting)

• Only developable surfaces can be milled by swarfing without undercut or
overcut

Planar Milling

• Blank - the region to be included

• Part - the region that can not be violated

• Check - the additional region that can not be violated

• Trim - as a final step, the region to be trimmed away
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Boolean Logic

Boundary Drive

• Drive boundary - similar to "blank" if no part containment, otherwise
it is like "part"

• Part containment - similar to "blank"

Area Milling Drive

• Cut area - similar to "blank"

• Trim - behaves slightly different from planar milling

Stock

Part offset and part stock

What Where

Part Offset Offset of part as the
permanent definition of
the final shape of the
product

Geometry Group

Part Stock Leftover material
on part by a given
operation

Operation

• Part stock is defined on "top" of part offset
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Safe clearance and part stock offset

What Where

Part Stock Offset Difference between the
part stock from the
previous operation and
the part stock of the
current operation

Operation

Safe Clearance The additional safety
zone for collision
checking

Operation

• Safe clearance is defined on "top" of part stock offset

• Part stock offset is used in multiple pass, engage/retract and collision
checking

• Safe clearance is used in engage/retract and collision checking

A-6 Advanced Machining Applications– Student Guide ©UGS Corp., All Rights Reserved NX 3



Advanced Surface Contouring

Gouge / Collision

Definitions:

Rapid moves Feed moves

Cutting part of tool
assembly

Collision Gouge

Non-cutting part of
tool assembly

Collision Collision

• Usually gouge check against part offset + part stock

• Usually collision check against part offset + part stock + part stock offset
+ safe clearance

Usage:

Collision check Gouge check

Tool Path Generation No Yes on Part

Drive Path
Generation

No Optional on Drive

Engage/Retract No Optional on Part

Transfer Moves Optional on Part Optional on Part

Cut Region
Computation

Cut Area

Optional (holder) on
Part/Check

Yes on Part

Check Geometry No Optional on Check

Gouge Check

(Operation
Navigator)

No (No Part Stock)
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Noncut Moves

Azimuth / Latitude:

• Begin with cut vector, rotate it toward the part normal � degrees

• Then rotate around the part normal � degrees (counter clockwise)

End / Intermediate traverse:

• There is only one End Traverse in the sequence, but there may be zero or
multiple Int Traverse

• The Start and End positions of the End Traverse move are determined by
other moves in the sequence
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B Project using Advanced Features

Purpose

Since it is sometimes difficult to comprehend and use new procedures and
functionality together in a process, the following series of activities will guide
you through using several of the concepts that you have learned in this class.

In the following activity, our fictitious company has received an order to
produce a prototype hydraulic manifold. The final product will be a casting,
however our customer is assembling a prototype machine and the casting
tool required will not be completed in time. Your task is to rough machine
a simulated casting from a billet. A four-axis machining center is available
for your use.

You will use the WAVE Geometry Linker and the In Process Work Piece (IPW)
together to rough out a simulated casting. You will then use Z-Level Profile
Steep and Mill Area Non-Steep to finish the casting simulation.

In the first part of this activity, you will open and examine the customer’s
part file and then create a suitable assembly, using WAVE, to simulate the
casting of this part.
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Advanced Features

Step 1: Open the part file ama_manifold.

Examine the part by rotating the object and use of the
Information function on the main menu bar.

The part will be mounted with the base (large flat area with
four holes) on a rotary table. All four sides of the part will be
machined in one setup.

Step 2: Create the WAVE assembly.

Open the file, ama_seedpart_in, from the
student_home\parts directory.

Choose File → Save As → ***_manifold_mfg where ***
represents your initials.

Standards require that you use a seed part whenever possible.
Seed parts enforce standards such as layer control and color
settings. Standards also dictate part file naming conventions.
In this case, a manufacturing assembly is represented by "mfg"
appended to the end of the file name.

Step 3: Add the customer part file as a component.

Our intentions are to maintain full associativity to the customer’s
part file since we anticipate modeling changes as the prototype
part is tested.

Choose Applications → Assemblies.

Choose Assemblies → Components → Add Existing.

Highlight the ama_manifold file name and choose OK.

The Add Existing Part dialog is displayed.

Set the Reference Set to BODY.

Choose OK.

The Point Constructor dialog is displayed.
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Since this is the first component to be added to the assembly,
the position does not concern us.

Choose OK on the Point Constructor dialog.

Choose Cancel in the Select Part dialog.

Step 4: Create a new component and apply the seed part standards.

The customer’s manifold part has been added as a component to
the assembly. You will now add a component that will serve as a
repository for the WAVE geometry.

Choose Assemblies → Components → Create New.

Choose OK.

The Select Part Name dialog is displayed.

Key in ***_manifold_casting as the new component part file
name.

Choose OK.

The Create New Component dialog is displayed.

Key in "casting" as the component name.

Choose OK on the Create New Component dialog.

You will now apply the standards from the seed part file.

Click on the Assembly Navigator tab on the resource bar.

In the Assembly Navigator, double-click on the "casting"
component (***_manifold_casting).

Double-clicking on a component in the Assembly Navigator
results in the component becoming the Work part.

From the main menu bar, choose File → Import → Part.
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The Import Part dialog is displayed.

If necessary, turn off the Create Named Group option.

Choose OK on the Import Part dialog.

The Import Part file selection dialog is displayed.

Highlight the file named ama_seedpart_in and choose OK.

The Point Constructor dialog is displayed.

Accept the defaults by choosing OK on the Point Constructor
dialog.

No geometry is added to the part, only layer categories and
object color standards are derived from the seed part.

Cancel the Point Constructor dialog.

Step 5: Save the modified assembly.

The ***_manifold_casting file has been created, however, the
top-level component has not been saved. If you were to close the
assembly at this time and then re-open it, the results would be
incorrect.

In the Assembly Navigator, make ***_manifold_mfg
component the work part.

Save, but do not close the part.

This concludes this part of the activity.
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As stated earlier, the ultimate goal of this project is to create a
prototype, realistic casting that can be machined and tested.
You will use the WAVE geometry linker and modeling tools to
cover the openings in the casting for subsequent machining
operations.
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The WAVE geometry linker can be used to make associative copies of various
types of geometry. In this part of the activity, you will use the linker to link
face edges. In essence you will be "plugging" the holes for later machining
operations.

Step 1: Using the WAVE geometry linker.

Continue using ***_manifold_mfg from Part 1 of the activity.

In the Assembly Navigator, double-click on
***_manifold_casting to make it the work part.

Choose Application → Modeling from the main menu bar.

Choose Insert → Associative Copy → WAVE Geometry
Linker from the main menu bar.

The WAVE Geometry Linker dialog is displayed.

In the WAVE Geometry Linker dialog, select the Curves
icon.
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Select the four curves, representing holes, as shown.

Choose OK on the WAVE Geometry Linker dialog.

Step 2: Extruding the curves.

You will now extrude the linked curves into solids. When creating
the machining operation, the solids created in this step will be
chosen as part geometry. This will prevent the cutting tool(s) from
entering those areas.

In the Assembly Navigator, select the check mark next to
ama_manifold to hide this component from the display.

From the Main menu bar, choose Insert → Design Feature
→ Extrude.

The Extruded Widget is displayed.

Choose the Extrude Dialog icon.

On the Selection toolbar change the type filter from Any to
Curve.

Select the two holes that are on the same plane, but dissimilar
in size as shown.
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Choose OK on the Extrude dialog.

Repeat the procedure for the other two curves.

Step 3: Save the Assembly.

In the Assembly Navigator, click on the check mark next to
ama_manifold to display the part again.

Notice how the four holes have been essentially “plugged”.

In the Assembly Navigator, make ***_manifold_mfg
component the work part by double-clicking on the object.

Save and Close the part.

This concludes this part of the activity.
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In the previous two parts of the activity, you closed the machined holes in the
manifold to simulate a casting. The following steps have been performed for
you to save you some time in completing the activity:

• the billet representing the raw stock has been created and added to the
assembly

• a mounting plate for the part has been designed and added to the assembly

• the rotary axis of the machining center has been added to the assembly

• all components were mated and or positioned in the correct relationship
with the manifold

You will start the process at the stage where the NC programming will begin.

Step 1: Open and rename the existing assembly.

Open ama_manifold_mfg from your parts directory.

Choose File → Save As → ***_manifold_mfg2, where ***
represents your initials.

Examine the assembly by opening the Assembly Navigator.

Since it is not necessary to see the rotary head or table, you
will hide those objects by using the Assembly Navigator.

Hide the display of the rotary table and head by clicking on the
check marks next to them in the Assembly Navigator.
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Fit the view to the graphics window.

Step 2: Set up the manufacturing process.

Choose Application → Manufacturing from the main menu
bar.

The Machining Environment dialog is displayed.

Choose cam_general as the Configuration and mill_contour
as the Setup.

Choose Initialize.

You will now retrieve a tool, used for roughing, from the tool
library.

Choose Insert → Tool from the main menu bar.

The Create Tool dialog is displayed.

Choose the Retrieve Tool icon.

Choose OK on the Create Tool dialog.

The Library Class Selection dialog is displayed.

Highlight the Milling group object on the Library Class
Selection dialog and then choose OK.

The Search Criteria dialog is displayed.

Key in 1.25 in the Diameter field

Choose OK on the Search Criteria dialog.

The Search Result listing is displayed.
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Highlight the ugti0201_069 tool and choose OK.

You have selected your tool and will now select the appropriate
geometry objects.

Click on the Operation Navigator tab from the resource bar.

Using MB3, switch to the Geometry view and expand all
group objects.

Double-click on the MCS_MILL geometry parent.

The MILL_ORIENT dialog is displayed.

Select the Constructor icon.

The CSYS Constructor dialog is displayed.

Choose OK on the CSYS Constructor dialog.

The MCS is now positioned and oriented to the WCS. It is
generally a common practice to place the NC/CNC program
zero at the center of rotation for rotary axis work.

Choose OK on the MILL_ORIENT dialog.

You will now select the blank geometry.

In the Geometry view of the Operation Navigator, double-click
on the Workpiece group object.

The MILL_GEOM dialog is displayed.

Choose the Blank icon and then choose Select.

The Blank Geometry dialog is displayed.

Choose the blank geometry as shown.
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Choose OK on the Blank Geometry dialog.

You will now select the part geometry.

In the Assembly Navigator, choose the check mark next to
ama_manifold_stock.

From the MILL_GEOM dialog, choose the Part icon and then
choose Select.

The Part Geometry dialog is displayed.

Select the five components as shown in the figure (part and
four plugs which you created to fill the holes).

Choose OK on the Part Geometry dialog.

From the MILL_GEOM dialog, choose the Check icon and
then choose Select.

The Check Geometry dialog is displayed.

Choose the fixture base as shown.

Choose OK.

From the MILL_GEOM dialog, change the Material to
Aluminum.

Choose OK in the Search Result dialog.

Choose OK in the MILL_GEOM dialog.
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Step 3: Create the first Cavity Milling operation.

The next set of steps will lead you through the creation of a Cavity
Milling operation, used in roughing the part.

From the main menu bar, choose Insert → Operation.

The Create Operation dialog is displayed.

If necessary, change the Type to mill_contour.

Choose the CAVITY_MILLING icon.

Set the parent group objects as shown:

Choose OK.

The CAVITY_MILL dialog is displayed.

This part will be rough machined from all four sides. Z zero
has been determined as an appropriate location to stop the
machining from any of the sides.

Choose the Cut Levels button.

Change Measured from to WCS Origin.

Change the Global Depth Per Cut to .125.

Change the Range Depth to 0.0.

Recalculate the feed rate based on part material and cutter
type.

Choose the Feed Rates button.

Choose Reset from Table.
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Choose OK.

Specify the Engage/Retract direction.

Under the Engage/Retract area of the CAVITY_MILL dialog,
choose Method.

Change Initial Engage and Final Retract to Tool Axis and
then change the Distance parameter to 4.0.

Choose OK in the Engage/Retract dialog.

Choose Generate to generate the tool path.

Turn off Pause After Display.

Choose OK.

Once the tool path has finished generating, choose OK.

Choose OK in the CAVITY_MILL dialog.

Step 4: Create the next Cavity Milling operation.

Now that the first operation, for roughing, has been created, the
remaining three roughing operations will be a simple copy and
paste. The only changes that you need to incorporate will be to
turn on the IPW processing and modify the tool axis.

Change to the Program Order view in the Operation
Navigator.

Highlight the CAVITY_MILL operation.
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Use MB3 → Copy.

Use MB3 → Paste.

Rename the copied operation to CAVITY_MILL_2.

Edit the operation CAVITY_MILL_2 by double-clicking it.

Choose the Machine button.

The Machine Control dialog is displayed.

Change the Tool Axis to Specify Vector.

The Vector Constructor dialog is displayed.

From the Vector Constructor dialog, choose the YC Axis
icon.

Choose OK.

The warning indicates the current cut levels are not compatible
with the tool axis. The processor will modify the cut levels to
make them perpendicular to the new tool axis.

Choose OK on the Warning dialog.

Choose OK on the Machine Control dialog.

Choose the Cut Levels button.

Change the Measured from to WCS Origin.

Key in 0.0 in the Range Depth field.

Choose OK.

Choose the Cutting button.

Choose the Containment tab.

For the In Process Workpiece select Use 3D.
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Choose OK.

Choose Generate to generate the tool path.

The processing will be somewhat longer than the first Cavity
Mill operation due to the considerable amount of calculations
that are made for the In Process work piece.

Turn off the Pause After Display dialog when it appears.

Choose OK.

After generation of the tool path, choose OK on the
CAVITY_MILL dialog.

Step 5: Create the final Cavity Milling operation.

In this step, you will create another Cavity Mill operation,
modifying the cut levels and tool axis.

On the Operation Navigator, highlight the CAVITY_MILL_2
operation.

Use MB3 → Copy.

Use MB3 → Paste.

Rename the copied operation to CAVITY_MILL_3.

Edit the operation CAVITY_MILL_3 by double-clicking it.

Choose the Cutting button.

For the In Process Workpiece, select NONE.

Choose OK.

Choose the Machine button.

Change the Tool Axis to Specify Vector.

Choose the ZC Axis icon.

Choose OK to the warning dialog.

Choose OK on the Machine Control dialog.

Choose the Cut Levels button.

Change the Measured from to WCS Origin.
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Change the Range Depth to 0.0.

Choose OK.

Choose the Cutting button.

Choose the Containment tab.

For the In Process Workpiece, select Use 3D.

Choose OK.

Generate the operation.

When the operation has been generated, choose OK.

Verify the results of the entire program (Hint: go to the
Program Order view, highlight the NC Program group object,
using MB3 → Toolpath → Verify).

Each operation used only the blank material that was available. The first
Cavity Milling operation used the entire blank, while each subsequent Cavity
Milling operation used the In Process Workpiece from the previous operation.
The result is a very efficient compliment of roughing operations with little,
if any, non-cutting motion.

This concludes this part of the activity.
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Finishing the Simulated Casting

In the previous parts of the activity, you used Cavity Mill and the In-Process
Workpiece to rough a blank shape, removing most of the excess or stock
material. Your goal is to simulate the casting body, therefore you need to
finish the exterior portion of the casting body before you can begin the actual
machining of the interior portion.

You will use a combination of Z-Level Profile Steep and Contour Area
Non-Steep operations to finish the exterior of the simulated casting body.
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In this part of the activity, you will combine operations for steep and
non-steep machining to finish the exterior of the simulated casting body.
Additionally, you will execute tool axis changes for both types of operations to
machine completely around the body.

Step 1: Open the part file.

Choose File → Open → ama_manifold_mfg_3.

Choose File → Save As → ***_manifold_mfg_3.

Choose Application → Manufacturing.

Step 2: Examine the current part.

You will now examine the existing rouging operations which were
created earlier.

If necessary, change to the Program Order view in the
Operation Navigator and highlight the Program group object.

Choose the Verify icon.

The Tool Path Visualization dialog is displayed.

Choose the 3D Dynamic tab.

Choose the Play button at the bottom of the Tool Path
Visualization dialog.

After examining the geometry, choose OK.

Step 3: Determine the appropriate tool size.

To determine the appropriate tool size for finishing purposes, you
need to know the smallest radius that is on the outside of the part.
You will use the NC Assistant to determine this radius.

In the Assembly Navigator, turn off the display of the
ama_manifold_fixture component by clicking on the red
check mark next to the name.

Choose Analysis → NC Assistant from the main menu bar.

The NC Assistant dialog is displayed.

Change the Analysis Type to Corner Radii.
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Click and drag a rectangle around the part in the graphics
window.

Choose Apply.

There are two different corner radii listed. The smaller size,
0.125, does not affect the cutting operations since it is on the
inside of the part only. The .250 corner radius listed will,
however, affect the tool size.

You will now check the fillet radii.

Change the Analysis Type to Fillet Radii.

Click and drag a rectangle around the part in the graphics
window.

Choose Apply.

The smallest fillet radii that applies to machining the part is
0.1398; therefore a tool with a radius of .130 will suffice. The
desired diameter of the tool should be no more than twice the
corner radius.

Choose Cancel in the NC Assistant dialog.

From the main menu bar, choose Insert → Tool.

If necessary, set the Type to mill_contour.

Choose the MILL icon.

Key in em-.5-.13 for the Name.

Choose OK.
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Key in the parameters as shown:

Choose OK.

Step 4: Create a Z-Level Steep operation.

You will now create a Z-Level Profile Steep operation to machine
those areas of the part that are close to parallel with the current
tool axis.

From the main menu bar, choose Insert → Operation.

If necessary, change the Type to mill_contour.

Choose the Z_LEVEL_PROFILE_STEEP icon and set the
parent objects as shown:

Key in ZL_1 as the Name.

Choose OK.

The ZLEVEL_PROFILE_STEEP dialog is displayed.
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Change the Steep Angle to 50.

Choose the Cut Levels button.

In the Cut Levels dialog, change the Measured from to WCS
Origin.

Set the Range Depth to 0.0.

Set the Local Depth Per Cut to 0.03.

Choose OK in the Cut Levels dialog.

Choose Generate to generate the tool path.

When the operation has generated, choose OK.

Step 5: Create a Contour Area Non-Steep operation.

You have completed the machining of the steep portions of the part
and need to create a Fixed Contour operation, using the Mill Area
drive method to machine those areas that are not steep.

From the main menu bar, choose Insert → Operation.

If necessary, change the Type to mill_contour.

Choose the CONTOUR_AREA_NON_STEEP icon and set
the parent objects as shown:

Key in CA_1 as the Name.

Choose OK.

The CONTOUR_AREA_NON_STEEP dialog is displayed.

Select Area Milling as the Drive Method.

The Area Milling Method dialog is displayed.
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Set the Steep Angle to 50.

This Steep Angle value matches the Steep Angle from the
previous Z-Level operation.

Change the Pattern to Parallel Lines.

Change the Stepover to Scallop.

Change the Height to 0.005.

Under Apply, choose the On Part radio button.

Choose OK.

In the CONTOUR_AREA_NON_STEEP dialog, choose the
Cutting button.

Choose the Stock tab.

In the Check Stock field, key in -.09.

The negative check stock will allow the ball-nose tool to follow
the edge of the check stock.

Choose the Clearances tab.

Change the When Gouging option to Retract

Choose OK.

In the CONTOUR_AREA_NON_STEEP dialog, choose
Generate to generate the tool path.

After examining the tool path, choose OK.

Step 6: Repeat the finishing process using new tool axis options.

You will now repeat the ZLEVEL_STEEP and
CONTOUR_AREA_NON_STEEP machining operations,
changing the tool axis each time.
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In the Program Order view, highlight the ZL_1 operation,
using MB3 → Copy.

Paste the operation immediately below the ZL_1 operation.

Rename the operation to ZL_2.

Double-click on the new operation, ZL_2.

Choose the Machine button.

Change the Tool Axis to Specify Vector.

In the Vector Constructor dialog, choose the Spherical
Coordinates radio button.

Key 120.0 for the Phi angle; 90.0 for the Theta angle.

Choose OK.

Choose OK to the warning dialog.

Choose OK in the Machine Control dialog.

Choose the Cut Levels button.

Change Measured from to WCS Origin.

Set the Range Depth to 0.0.

Choose OK.

You will also need to reset the Clearance Plane for this
operation.

Choose the Avoidance button.

Choose the Clearance Plane button.

Choose Specify.
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Select the face as shown.

Key in 2.00 for the Offset.

Choose OK until the ZLEVEL_PROFILE_STEEP dialog is
displayed.

Note that once that the Clearance Plane has been specified in
the operation dialog, it will no longer inherit the Clearance
Plane established in the MCS_MILL dialog.

Generate the operation.

When you have finished examining the operation, choose OK.

In the Operation Navigator, highlight the CA_1 operation, use
MB3 and choose Copy.

Use MB3 to paste the copied operation following the CA_1
operation.

Rename the copied operation to CA_2.

Double-click on the operation CA_2.

This operation will require a tool axis change, just like in the
previous operation. The option to change the tool axis is not on
the dialog. You will add the option through Customized dialogs.

On the CONTOUR_AREA_NON_STEEP dialog, choose the
Options icon.

The Other Parameters dialog is displayed.

Select the Customize Dialog button from the Other
Parameters dialog.

The Customize Dialog is displayed.
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From the bottom scroll listing window, highlight the Tool Axis
option.

Choose the Add button.

Choose OK until the CONTOUR_AREA_NON_STEEP dialog
appears.

Choose the newly created More tab.

Change the Tool Axis from ZM Axis to Specify Vector.

In the Vector Constructor dialog, choose the Spherical
Coordinates radio button.

Key in 120.0 for the Phi angle; 90.0 for the Theta angle.

Choose OK.

Choose the Main tab.

Generate the operation.

On your own, create the final two finishing operations.
Remember to place the tool axis at Phi=240.0 and Theta at
90.0, and then place the operations in the proper location in
the Program Order view.

This completes the activity.
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Advanced Machining Applications Course Agenda

Day 1
• Introduction &Overview
• Lesson 1. Wave Geometry Linker in Manufacturing
• Workbook: Wave Geometry Linker
• Lesson 2. In-Process Workpiece

Afternoon
• Lesson 3. Libraries
• Workbook: Libraries
• Lesson 4.          Machining Faceted Geometry

Day 2
• Lesson 5. High Speed Machining
• Lesson 6. NC Assistan

Afternoon
• Lesson 7. Templates
• Workbook:         Templates
• Lesson 8 Holemaking

Day 3
• Lesson 8. Holemaking
• Lesson 9. Integrated Simulation and Verification
• Workbook: Integrated Simulation and Verification

Afternoon
• Project
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Layers and Categories

The follo wi ng layer  and category standards will  be fol lo wed in  this
class.

Model  Geome t r y

Objec t  Type Layer Assign men t Category Name
Solid Geo me t ry 1-20 SOLIDS
Inter-par t Mo deling 15-20 LINKED_OBJECTS
Sketch Geo me t ry 21-40 SKETCHES
Curve Geo me t ry 41-60 CURVES
Reference Geo me t ry 61-80 DATUMS
Shee t Bodies 81-100 SHEETS

Dra f t ing Objects

Objec t  Type Layer Assign men t Category Name
Drawi ng Borders 101-110 FORMATS

Engineering Disciplines

Objec t  Type Layer Assign men t Category Name
Mechanism Tools 121-130 MECH
Fini te  Elemen t
Meshes and Engr.
Tools

131-150 CAE

Manufac turing 151-180 MFG
Quali ty Tools 181-190 QA
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Hot Key Char t

Hot
Key

Func tion Hot Key Func tion

Ctrl-A Ctrl-N File, New
Ctrl-B Edi t, Blank Ctrl-O File, Open
Ctrl-C Copy Ctrl-P File, Plo t
Ctrl-D Delete Ctrl-Q
Ctrl-E Tools, Expression Ctrl-R  View,  Opera t ion,  Ro ta te

(full menu)
Ctrl-F Fi t View Ctrl-S File, Save
Ctrl-G Grip Execute Ctrl-T Edi t, Transfo r m
Ctrl-H Ctrl-U Execu te User Func ti on
Ctrl-I Info r ma tion, Objec t Ctrl-V Paste
Ctrl-J Edi t, Objec t Display Ctrl-W Appl icat i on, Gate way
Ctrl-K Ctrl-X Cut
Ctrl-L For mat, Layer Set t i ngs Ctrl-Y
Ctrl-M Appl icat i on, Modeli ng Ctrl-Z Edi t, Undo



Ctrl-Shi f t-A File, Save As Ctrl-Shi f t-N For mat, Layou t, New
Ctrl-Shi f t-B Edi t, Blank, Reverse

Blank All
Ctrl-Shi f t-O For mat, Layou t, Open

Ctrl-Shi f t-C View, Curvature Graph Ctrl-Shi f t-P Tools, Macro, Playback
Ctrl-Shi f t-D Draf t i ng Ctrl-Shi f t-Q Quick Shaded Image
Ctrl-Shi f t-E Ctrl-Shi f t-R Tools, Macro, Record
Ctrl-Shi f t-F For mat, Layou t, Fi t All

Views
Ctrl-Shi f t-S Toolsm Macro, Step

Ctrl-Shi f t-G Debug Grip Ctrl-Shi f t-T  Prefe rences,  Selec t i on
Ctrl-Shi f t-H High Quali ty Image Ctrl-Shi f t-U Edi t, Blank, Unblank All

Of Par t
Ctrl-Shi f t-I Ctrl-Shi f t-V For mat, Visible In View
Ctrl-Shi f t-J Prefe rences, Objec t Ctrl-Shi f t-

W
Ctrl-Shi f t-K Edi t, Blank, Unblank

Selec ted
Ctrl-Shi f t-X

Ctrl-Shi f t-L Ctrl-Shi f t-Y
Ctrl-Shi f t-M Ctrl-Shi f t-Z View, Opera t i on,

Zoo m (full  menu)

Al t-Tab Toggles Appl icat i on Ctrl-Al t-B Tools, Boundary
Al t-F4 Closes Active Windo w Ctrl-Al t-C Tools, CLSF
F1 Help on Con text Ctrl-Al t-M Appl icat i on

Manufac turi ng
F3 View Curren t Dialog Ctrl-Al t-N Tools, Unisim
F4 Info r ma tion  Windo w Ctrl-Al t-W Appl icat i on

Assemblies
F5 Refresh Ctrl-Al t-X Tools, Lathe Cross-

Section
F6 Quick Zoo m
F7 Quick Rota te



Evaluation – Delivery
NX 3 Advanced Machining Applications, Course #MT11045

Dates thru
Please share your opinion in all of the following sections with a “check” in the appropriate box:

Instructor: R
If there were 2 instructors, please evaluate the 2nd instructor with “X’s”

Instructor: T
1. …clearly explained the course objectives
2. …was knowledgeable about the subject
3. …answered my questions appropriately
4. … encouraged questions in class
5. …was well spoken and a good communicator
6. …was well prepared to deliver the course
7. …made good use of the training time
8. …conducted themselves professionally
9. …used examples relevant to the course and audience
10. …provided enough time to complete the exercises
11. …used review and summary to emphasize important information
12. …did all they could to help the class meet the course objectives

Comments on overall impression of instructor(s):
Overall impression of instructor(s) Poor  Excellent

Suggestions for improvement of course delivery:

What you liked best about the course delivery:

Class Logistics:
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2. The computer equipment was reliable
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5. The registration and confirmation process was efficient

Hotels: (We try to leverage this information to better accommodate our customers)
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2. Was this hotel recommended during your registration process?  YES  NO
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Evaluation - Courseware
NX 3 Advanced Machining Applications, Course #MT11045

:

Please share your opinion for all of the following sections with a “check” in the appropriate box

Material:
1. The training material supported the course and lesson objectives
2. The training material contained all topics needed to complete the projects
3. The training material provided clear and descriptive directions
4. The training material was easy to read and understand
5. The course flowed in a logical and meaningful manner

6. How appropriate was the length of the course relative to the material?  Too short  Too long  Just right

Comments on Course and Material:

Overall impression of course Poor  Excellent

Student:
1. I met the prerequisites for the class (I had the skills I needed)
2. My objectives were consistent with the course objectives
3. I will be able to use the skills I have learned on my job
4. My expectations for this course were met
5. I am confident that with practice I will become proficient

Name (optional):  Location/room

Please “check” this box if you would like your comments featured in our training publications.
(Your name is required at the bottom of this form)

Please “check” this box if you would like to receive more information on our other courses and services.
(Your name is required at the bottom of this form)

Thank you for your business. We hope to continue to provide your training
and personal development for the future.
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